Results 1 to 8 of 8

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Update iPhone 3GS 05.13.04 V. 4.0 - Questions

  1. #1
    iPhone? More like MyPhone
    Join Date
    May 2009
    Location
    Seattle, WA
    Posts
    212
    Thanks
    37
    Thanked 4 Times in 4 Posts

    Default Update iPhone 3GS 05.13.04 V. 4.0 - Questions
    Looking to upgrade my iPhone BB 05.13.04 V. 4.0; what is the highest/safest upgrade I should attempt with this? Having a lot of troubles downloading apps and checking email as everything seems to be outdated.

    I am looking for a simple upgrade, if there happens to be a form written on it and you don't mind directing me there it would be greatly appreciated!

    Thank You.

  2. #2
    First of all, we need more info about your 3gs before anyone can help.

    1. Do you need to preserve BB 5.13.04 for Ultrasn0w unlocking?
    2. Do you have any SHSHs saved?
    3. Do you want a jailbreakable firmware (older than current 6.1.3 version)?

    If you don't need Ultrasn0w unlock then you don't care about preserving baseband and only need to upgrade firmware.
    If you used iFaith or TinyUmbrella to save SHSHs, especially, iOS 6.0.1 or 6.1.2 then you can upgrade to those firmware.
    If you didn't save SHSHs then hopefully your iPhone is jailbroken and Cydia may save them on its server. However, the highest untethered jailbreakable firmware is 5.1.1. For iOS 6, the SHSHs saved by Cydia has some problem, and you can't restore using them.

    Good luck

  3. #3
    iPhone? More like MyPhone
    Join Date
    May 2009
    Location
    Seattle, WA
    Posts
    212
    Thanks
    37
    Thanked 4 Times in 4 Posts

    Default Reply to questions
    1. I do not "need" to preserve BB necessarily, however I use T-Mobile so I need to do whatever will keep T-Mobile working on this cell phone.

    2. I do not have any SHSH saved but the phone still works perfectly fine and I can easily save SHSH.

    3. I do not necessarily care about jail breakable firmwares. Basically just want to use the phone as efficiently as possible with T-Mobile.

    Not really sure what path for unlocking I should be taking. The phone works fine with T-Mobile currently but I am unable to download most apps in app store as my iOS is too old. Also cannot open gmail as it's too old.

    Thank You!

    Quote Originally Posted by hcgaloi View Post
    First of all, we need more info about your 3gs before anyone can help.

    1. Do you need to preserve BB 5.13.04 for Ultrasn0w unlocking?
    2. Do you have any SHSHs saved?
    3. Do you want a jailbreakable firmware (older than current 6.1.3 version)?

    If you don't need Ultrasn0w unlock then you don't care about preserving baseband and only need to upgrade firmware.
    If you used iFaith or TinyUmbrella to save SHSHs, especially, iOS 6.0.1 or 6.1.2 then you can upgrade to those firmware.
    If you didn't save SHSHs then hopefully your iPhone is jailbroken and Cydia may save them on its server. However, the highest untethered jailbreakable firmware is 5.1.1. For iOS 6, the SHSHs saved by Cydia has some problem, and you can't restore using them.

    Good luck

  4. #4
    can I update my Ipad2 ios 4.3.3, jailbroken, to ios 5.1.1

  5. #5
    iPhone? More like MyPhone
    Join Date
    May 2009
    Location
    Seattle, WA
    Posts
    212
    Thanks
    37
    Thanked 4 Times in 4 Posts

    Quote Originally Posted by ipadapps View Post
    can I update my Ipad2 ios 4.3.3, jailbroken, to ios 5.1.1
    I do not know anything about iPad's this thread is for an iPhone 3GS, not iPad.

  6. #6
    Since you're using T-mobile, you need to preserve the 5.13.04 baseband for Ultrasn0w unlock. This also means that you need to jailbreak to install UltraSn0w. Below are your choices:

    1. iOS 5 firmwares are the best that you can upgrade to if Cydia saved the SHSHs for you with the latest was 5.1.1. To find out
    if it does, run Cydia and look at the top, it will list all the available SHSHs for your iPhone. Forget about the iOS 6 SHSHs because
    they have error(s) and can't be used until Saurik fixes the problem.
    Use this tutorial to upgrade your iPhone to iOS5.1.1 (the guide is for downgrading from iOS 6, but the steps are the same)
    Downgrade iOS 6.0.1 To 5.1.1 [How-To Tutorial] | Redmond Pie

    2. If you don't have iOS 5 SHSHs saved, your only choice is to upgrade to the current iOS 6.1.3 which is a tethered jailbreak
    for the 3GS. If this is your only option, I recommend to pay for an IMEI unlock (around $4 on eBay or check with moderators on this
    board). This way you don't have to deal with jailbreaking and preserving baseband.

    Note: If you decide to do a tethered jailbreak on 6.1.3, every time you reboot the phone you need to connect it to a computer
    and run Redsn0w or other tools to perform a tethered reboot (a hassle).

    Good luck....

  7. #7
    iPhone? More like MyPhone
    Join Date
    May 2009
    Location
    Seattle, WA
    Posts
    212
    Thanks
    37
    Thanked 4 Times in 4 Posts

    Thank You!

  8. #8
    ipadapps, you may want to open a separate thread, and hopefully you will get better response. Anyway, before you do anything, you may want to save the precious 4.3.5 SHSH and hopefully together with an iOS 5 SHSH you will be able to upgrade/downgrade to iOS 5.

    Read the info here from developers for more info: Dev-Team Blog

    Good luck


    Quote Originally Posted by ipadapps View Post
    can I update my Ipad2 ios 4.3.3, jailbroken, to ios 5.1.1

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •