+ Reply
Results 1 to 6 of 6

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: 3GS 4.33 need to upgrade and keep unlock on tmobile help

is a discussion within the

Unlocking / Activation

forums, a part of the

iPhone Modding

section;
Hi, I had my 3GS on ATT. I jailbroke and ulocked, I now have 4.33 with BB 6.15 Its been a while, now I am on tmobile. I "think" I
...
  1. #1
    What's Jailbreak?
    Join Date
    Jul 2012
    Posts
    4
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default 3GS 4.33 need to upgrade and keep unlock on tmobile help
    Hi,

    I had my 3GS on ATT. I jailbroke and ulocked, I now have 4.33 with BB 6.15

    Its been a while, now I am on tmobile. I "think" I used the geohot jail brake, maybe ultrasnowunlock. Not really sure at this point. I have cydia on my screen. Rarely use it.

    I am considering updating the software but I am cautious an upgrade will make it unlocked and unlockable.

    I see redsnow can downgrade the BB from the 6.15 version so that could be good.

    Now that I no longer have access to att to unlock if I screw up, how do I upgrade the 4.33 and make sure it is unlocked so I can use it on tmobile?

    Help please?
    Last edited by homebuilder; 07-06-2012 at 03:48 PM.

  2. #2
    My iPhone is a Part of Me Susty's Avatar
    Join Date
    Sep 2011
    Location
    Europe
    Posts
    785
    Thanks
    9
    Thanked 100 Times in 99 Posts

    Well... If you know anyone with an AT&T simcard, you can use that onetime to get past the activation screen.. However if it's an out of contract phone (past two years I think) AT&T can unlock it for you. If any of that helps..

    If however you cannot gain access to an AT&T simcard, then you'll want to get sn0wbreeze (windows) or pwnagetool (mac) to create a hacktivated custom IPSW... That way you'll bypass the activation screen you'll get if your upgrading to 5.1.1 & don't have access to any AT&T simcard.
    Last edited by Susty; 07-07-2012 at 01:11 PM.

  3. #3
    What's Jailbreak?
    Join Date
    Jul 2012
    Posts
    4
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Thanks for the reply.

    So if I upgrade now I will not be able to use without an att sim? Any att sim? I have my old one but it is not active.

    If I update without the att sim, I am guessing then it will be locked. any way to unlock?

    With windows, will the new redsnow work? It looks like pawnage is only for MAC?
    My understanding is snowbreeze is installed from cydia, so you must first install cydia via... redsnow?

    Please can someone confirm, give me some detailed steps so I do not lose use of my phone?

  4. #4
    My iPhone is a Part of Me Susty's Avatar
    Join Date
    Sep 2011
    Location
    Europe
    Posts
    785
    Thanks
    9
    Thanked 100 Times in 99 Posts

    Quote Originally Posted by homebuilder View Post
    Thanks for the reply.

    Quote Originally Posted by homebuilder View Post
    So if I upgrade now I will not be able to use without an att sim? Any att sim? I have my old one but it is not active.
    Correct.. Would need to be a working AT&T sim but any working AT&T sim, otherwise you'll have to build a hacktivated Ipsw, however you may run into push notification errors with this that may take abit to fix.
    If I update without the att sim, I am guessing then it will be locked. any way to unlock?[/QUOTE]

    Correct, (presuming you hacktivate it), to unlock it, you'd do the same as you would with any phone, you'd have to use wifi to connect to cydia & install ultrasn0w to do the software unlock (same as you use at the moment).

    [/QUOTE]With windows, will the new redsnow work?[/QUOTE]

    Yes, it will.

    [/QUOTE]It looks like pawnage is only for MAC? My understanding is snowbreeze is installed from cydia, so you must first install cydia via... redsnow? [/QUOTE]

    Correct, pwnagetool is for mac, you can use Sn0wbreeze, sn0wbreeze is the same as pwnagetool, it's just a ported program to windows, no you do not need cydia installed to run sn0wbreeze, it's a separate program in itself that creates custom IPSW's & will hacktivate your phone for you (which you'll need should you not have access to any active AT&T simcard).


    Please can someone confirm, give me some detailed steps so I do not lose use of my phone?[/QUOTE]

    Also you might want to look at downgrading your baseband before hand so that you will get your GPS back working... I've enclosed the link with the details.

    http://blog.iphone-dev.org/
    Last edited by Susty; 07-07-2012 at 02:22 PM.

  5. #5
    What's Jailbreak?
    Join Date
    Jul 2012
    Posts
    4
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default Help!
    I upgraded to 5.11, jailbreak worked with both absinthe and redsnow ( tried both ) but both kept the 5.16 baseband in the upgrade and neither allowed me to either upgrade or downgrade the baseband for unlocking.

    It is now jailbroken but not unlocked.

    When I re hook up to redsnow it does not give option to change baseband to 6.15 or to downgrade to 5.13...

    What can I do now?

  6. #6
    EVO
    EVO is offline
    Super EVO Moderator EVO's Avatar
    Join Date
    Dec 2009
    Posts
    3,493
    Thanks
    105
    Thanked 799 Times in 486 Posts

    Quote Originally Posted by homebuilder View Post
    I upgraded to 5.11, jailbreak worked with both absinthe and redsnow ( tried both ) but both kept the 5.16 baseband in the upgrade and neither allowed me to either upgrade or downgrade the baseband for unlocking.

    It is now jailbroken but not unlocked.

    When I re hook up to redsnow it does not give option to change baseband to 6.15 or to downgrade to 5.13...

    What can I do now?
    make sure you are using the latest redsn0w v0.9.14b2 from their website

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts