Results 1 to 5 of 5

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: iPhone 3GS - 5.1 - BB 0.6.15.00 - can't unlock HELP!!

  1. #1
    Default iPhone 3GS - 5.1 - BB 0.6.15.00 - can't unlock HELP!!
    Total n00b here. What idiotically simple thing am I doing wrong?


    OK. I just purchased this phone. It is locked into AT&T and I live on the other side of the world. I have jailbroken with redsn0w and then installed com.zmaster.ultrasn0w-fix_1.0_iphoneos-arm.deb (not through wifi, just files from pc to phone using i-funbox and cydia autoinstall) rebooted, then installed ultrasn0w_1.2.5_iphoneos-arm.deb (again from pc NOT using wifi) rebooted 3 times. The files both show up in Cydia on the phone as working ok.

    From the various tuts that I have read it seems that I should now have an unlocked 3GS, but I don't.

    Do I have to create a custom ipsw? Because that is the one thing that I haven't done yet, even though it's not in the tuts about unlocking, should I? I haven't made it because I'm on an XP machine and redsn0w has a glitch where it crashes when trying to create a custom ipsw on pc's running XP. Should I try Snowbreeze and do it?


    Thanks in advance.
    Last edited by TheCrodGoesWild; 04-22-2012 at 11:54 AM.

  2. #2
    OK, this is where I am at. I have ultrasn0w working and the phone at long last recognises that I have a sim installed (got this by flicking Airplane mode on and off), I then get the 'carrier' tab, which wasn't there before. When I go in there it is empty, set to auto, so I change it to manual and it gives me an error 'unable to load network list'.

    I'm starting to hate my iphone.

  3. #3
    they fact that you already have bb 6.15 means that you already loaded 5.1 with custom baseband 6.15 right? i would remove ultrasnow 1.25 and re-install it. after installing it, reboot the phone. sometimes toggling airplane mode does not reset it correctly. make sure before you reboot, that you already have the new sim card installed.

  4. The Following User Says Thank You to daytonaviolet For This Useful Post:

    TheCrodGoesWild (04-22-2012)

  5. #4
    I GOT IT WORKING!!!!!!!!

    Sorry if the following is overly simplistic, this is my first iPhone and I've only owned it for a couple of days.

    This is what I did for any n00bs like myself who are having similar problems. My 3GS is one of the old bootroms so it runs on an untethered jailbreak, if you have a newer bootrom then apparently you will need to use redsn0w to reboot each time you turn your phone off in the following set of instructions.


    1) Made a custom 5.1 ipsw with Snowbreeze and chose the 'install ipad baseband' (6.15) option (even though I already had it) I had not chosen this option with any of my previous builds and had not seen it mentioned in any tutorials that I had read. Put in DFU mode and installed custom ipsw through iTunes

    2) Used Redsn0w to jailbreak the phone, the only box I ticked was 'install cydia'.

    3) After Redsn0w was finished I then used I-Funbox to transfer the Ultrasn0w 5.1 fix to Cydia and rebooted.

    4) Then transferred Ultrasn0w 1.2.5 to Cydia and rebooted TWICE.

    5) Put my simcard in the phone and rebooted a third time and BOOM, bars on the screen and service.


    The only thing that I did different this time to the other 25+ times that I tried and failed, was that I chose the 'install ipad baseband' option.

    See? I knew it would be some basic simple thing that I was/wasn't doing.

    Hopefully this helps a couple of people having the same problem as I had.


    Thanks Daytonaviolet for trying to help me out, appreciated.
    Last edited by TheCrodGoesWild; 04-22-2012 at 12:39 PM.

  6. #5
    Default Thank you, thank you, thank you!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
    [/B][/B]
    Quote Originally Posted by TheCrodGoesWild View Post
    I GOT IT WORKING!!!!!!!!

    Sorry if the following is overly simplistic, this is my first iPhone and I've only owned it for a couple of days.

    This is what I did for any n00bs like myself who are having similar problems. My 3GS is one of the old bootroms so it runs on an untethered jailbreak, if you have a newer bootrom then apparently you will need to use redsn0w to reboot each time you turn your phone off in the following set of instructions.


    1) Made a custom 5.1 ipsw with Snowbreeze and chose the 'install ipad baseband' (6.15) option (even though I already had it) I had not chosen this option with any of my previous builds and had not seen it mentioned in any tutorials that I had read. Put in DFU mode and installed custom ipsw through iTunes

    2) Used Redsn0w to jailbreak the phone, the only box I ticked was 'install cydia'.

    3) After Redsn0w was finished I then used I-Funbox to transfer the Ultrasn0w 5.1 fix to Cydia and rebooted.

    4) Then transferred Ultrasn0w 1.2.5 to Cydia and rebooted TWICE.

    5) Put my simcard in the phone and rebooted a third time and BOOM, bars on the screen and service.


    The only thing that I did different this time to the other 25+ times that I tried and failed, was that I chose the 'install ipad baseband' option.

    See? I knew it would be some basic simple thing that I was/wasn't doing.

    Hopefully this helps a couple of people having the same problem as I had.


    Thanks Daytonaviolet for trying to help me out, appreciated.
    I can't thank you enough for this thread! It has saved me so much more time! Hope you have a great night!

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •