+ Reply
Results 1 to 4 of 4

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: [Solved] No Service after jailbreak and ultrasn0w on 3GS, 5.0.1, 6.15.00

is a discussion within the

Unlocking / Activation

forums, a part of the

iPhone Modding

section;
Hi folks, I recently upgraded my 3GS to 5.0.1. I had been running 4.3.5 (jailbroken with sn0wbreeze) and had needed to install the iPad baseband to jailbreak it originally in
...
  1. #1
    What's Jailbreak?
    Join Date
    Dec 2010
    Posts
    25
    Thanks
    1
    Thanked 0 Times in 0 Posts

    Default [Solved] No Service after jailbreak and ultrasn0w on 3GS, 5.0.1, 6.15.00
    Hi folks, I recently upgraded my 3GS to 5.0.1. I had been running 4.3.5 (jailbroken with sn0wbreeze) and had needed to install the iPad baseband to jailbreak it originally in late 2010.

    I went through all the standards steps: updated my firmware through iTunes, jailbroke with the most recent redsn0w (0.9.10b5), and then installed ultrasn0w 1.2.5. However, I didn't get any service after doing that. I went through a number of potential fixes I found online, like reinstalling Mobile Substrate, re-jailbreaking and installing ultrasn0w several times, all the while confirming that my baseband was still 6.15.00 (the iPad baseband).

    Turns out the solution was pretty simple: you have to reinstall the iPad baseband with redsn0w, even though the baseband was apparently still installed on my phone. As soon as I did that service was restored.

    Note, that when you use redsn0w to install the baseband, you have to ONLY select the baseband option. If you select "Install Cydia" as well (which is selected by default), redsn0w will crash. Also, make sure you have the old bootrom 3GS before installing the iPad baseband. Unfortunately, but not surprisingly, my GPS still does not work. I had a glimmer of hope that updating and reinstalling might fix the GPS problem, but no such luck.

    iPhone 3GS (old Bootrom)
    5.0.1 (stock installed through iTunes)
    6.15.00 (iPad baseband)
    redsn0w 0.9.10b5
    ultrasn0w 1.2.5

  2. #2
    Superbad Modder-ator Simon's Avatar
    Join Date
    Nov 2007
    Location
    Bermuda
    Posts
    46,502
    Thanks
    6,794
    Thanked 15,203 Times in 6,978 Posts

    iPad baseband can be installed on new bootrom 3GS just fine. It is the newer model ones that were made week 35 or later in 2011 that cannot.

  3. #3
    What's Jailbreak?
    Join Date
    Dec 2010
    Posts
    25
    Thanks
    1
    Thanked 0 Times in 0 Posts

    Thanks for clarifying...

  4. #4
    Green Apple Firefighter0205's Avatar
    Join Date
    Dec 2009
    Location
    Cincinnati
    Posts
    69
    Thanks
    6
    Thanked 3 Times in 2 Posts

    The iPad also uses a different GPS chip than the iPhone 3G or 3GS so the iPad Base Band renders the iPhone GPS chip useless. No way to get it back.
    Having an unlocked phone with no GPS was a fair trade to me though.
    Badges? We don't need no stinking badges!

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts