Results 1 to 11 of 11

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: iPhone 4 5.0.1 JB - Invalid SIM even with SAMPrefs - CANNOT Activate

  1. #1
    Default iPhone 4 5.0.1 JB - Invalid SIM even with SAMPrefs - CANNOT Activate
    So my iphone is on 5.0.1 UNtethered JB with 4.10.01 BB.

    I got my phone hactivated by jailbreaking the iphone since it wouldnt activate the phone prior to the jailbreaking even with legit (but not active) ATT Sim.

    Now jailbroken, I tried using SAM but itunes keep saying it is invalid, I tried many different methods and configuration regarding the SAM but nothing works. (It is factory activated btw, aka Hackitvated)

    I am also unlocked via Gevey sim Using t-mobile.

    Does anyone have any solution regarding to this issue?

  2. #2
    Superbad Modder-ator Simon's Avatar
    Join Date
    Nov 2007
    Location
    Bermuda
    Posts
    47,106
    Thanks
    7,201
    Thanked 15,910 Times in 7,254 Posts

    You sure it is a ATT locked iPhone? What problems were you getting when trying to activate with the ATT sim you have?

  3. #3
    Quote Originally Posted by Simon View Post
    You sure it is a ATT locked iPhone? What problems were you getting when trying to activate with the ATT sim you have?
    Positive thats it's ATT locked, its not my first time jailbreaking an iphone, in fact, it's how I made money in High School.

    When I tried to activate it with ATT MicroSim, itunes refuse to do so and displays a long paragraph that can be summed up "Invalid Sim Card, I won't activate the iphone until you insert a legit Sim Card".

    I gave up, I procede to jailbreak the iphone via redsn0w. Then installed SAMPrefs but still Hackivated.

  4. #4
    Superbad Modder-ator Simon's Avatar
    Join Date
    Nov 2007
    Location
    Bermuda
    Posts
    47,106
    Thanks
    7,201
    Thanked 15,910 Times in 7,254 Posts

    Then something is wrong with your ATT sim card. I activate them all the time just fine. I have a few of them I keep lying around.

  5. #5
    I have two of them. They both worked when I activated my sister's iphone 4. They also worked when I activated my own when restoring 4.3.3.

    Both Sim card says "No Service" on the top left of the iphone screen.

  6. #6
    Superbad Modder-ator Simon's Avatar
    Join Date
    Nov 2007
    Location
    Bermuda
    Posts
    47,106
    Thanks
    7,201
    Thanked 15,910 Times in 7,254 Posts

    Don't need service to activate. Just need to get past the initial setup screens.

  7. #7
    I know but I cant get past the activation part for some reason. I had a real ATT sim but itunes wont accept it, and I tried many different ATT Sim.

  8. #8
    Anyone have a solution?

    Please and thank you

  9. #9
    I got the No service thing also.

    -----
    EDIT


    Don't know what I did but it fixed it self after a while of no service.
    Last edited by MiaField; 01-15-2012 at 05:58 PM.

  10. #10
    had same problem tonight. it took a while, but it finally recognized ATT after 5min.

  11. #11
    Quote Originally Posted by Simon View Post
    Then something is wrong with your ATT sim card. I activate them all the time just fine. I have a few of them I keep lying around.
    I have the same problem as cybrax2 ..but i have a friend with the ATT sim... Will it possible to activate the phone with that sim?? if yes can you please tell me how to.. coz after a long struggle and reading a zillion posts iv managed to make my iphone 4 on 5.0.1 jailbroken and unlocked by gevy sim to work... i used SAM prefs and itime to activate my facetime and imessages aloing with Push... now the only struggle remains is that the phone doesnt go past the "no sim" in itunes..!!

    I'm on Airtel (Indian carrier) and my friend has come down to visit ... so i have a small window to use his card...

    Plz Help

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •