Page 1 of 2 12 LastLast
Results 1 to 20 of 37

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: How to build custom IPSW with 06.15.00 BB for iPhone 3G on Windows?

  1. #1
    Default How to build custom IPSW with 06.15.00 BB for iPhone 3G on Windows?
    Hi Folks,

    I have an iPhone 3G with iOS 4.2.1 that I want to unlock, and in order to do so I must update the baseband to 06.15.00 (I have bootloader 5.9 with BB 05.15.04 - and I know I'm risking GPS). I want to build a custom IPSW so I can restore properly in the future. I'm on Windows, so Pwnage Tool doesn't work for me. Sn0wbreeze doesn't seem to be able to update the baseband to 06.15.00 using the iPad IPSW. So, how do I do this on Windows? Any ideas?

    Thanks!
    Last edited by luckycharms; 07-28-2011 at 08:43 AM.

  2. #2
    My iPhone is a Part of Me xtacy's Avatar
    Join Date
    May 2011
    Location
    Mumbai
    Posts
    980
    Thanks
    1
    Thanked 93 Times in 92 Posts

    She call me Mr. Boombastic say me fantastic, touch me in me back
    she say I'm Mr. Ro...mantic

  3. #3
    Livin the iPhone Life
    Join Date
    May 2008
    Posts
    8,021
    Thanks
    102
    Thanked 788 Times in 731 Posts

    FYI: Once the iPad BB is installed, it no longer needs any future changes. In fact it can not be changed !!
    That's the reason a custom firmware is required for updates after it is installed.

  4. #4
    Livin the iPhone Life
    Join Date
    Nov 2007
    Location
    Arkham Asylum
    Posts
    1,041
    Thanks
    12
    Thanked 104 Times in 103 Posts

    +1. Use redsn0w 0.9.6rc16

    Redsn0w 0.9.6rc16 Released (Download Links)

    this will allow you to install the ipad baseband. As Mes stated, once you install the 6.15.00 bb there is no going back unless you have the 5.08 bootloader (which is really rare)

  5. #5
    I have a related question for all you experts:
    I have a 3G that is on 4.1 and already has baseband 6.15.00.
    I want to upgrade the phone to 4.2.1 and maintain BB 6.15.00, I obviously also don't want to encounter any "surprises" along the way.
    Can I use sn0wbreeze to load a custom 4.2.1? And I assume I should just preserve the current baseband, since that is what I want.
    Thanks in advance, and please no "guesses" or "it should work," I only want knowledgeable replies, preferably from people who have already done this. I already know "it should work," I'm looking for some verification.

  6. #6
    Livin the iPhone Life
    Join Date
    May 2008
    Posts
    8,021
    Thanks
    102
    Thanked 788 Times in 731 Posts

    As you probably already know...... a custom firmware IS required (iPad BB installed)
    SHSH blobs for 4.2.1 are required. TU + Start TSS server are required
    Pwnd-DFU mode is required. Enter this state using Sn0wbreeze.

  7. #7
    Livin the iPhone Life
    Join Date
    Nov 2007
    Location
    Arkham Asylum
    Posts
    1,041
    Thanks
    12
    Thanked 104 Times in 103 Posts

    Quote Originally Posted by Alinv View Post
    I have a related question for all you experts:
    I have a 3G that is on 4.1 and already has baseband 6.15.00.
    I want to upgrade the phone to 4.2.1 and maintain BB 6.15.00, I obviously also don't want to encounter any "surprises" along the way.
    Can I use sn0wbreeze to load a custom 4.2.1? And I assume I should just preserve the current baseband, since that is what I want.
    Thanks in advance, and please no "guesses" or "it should work," I only want knowledgeable replies, preferably from people who have already done this. I already know "it should work," I'm looking for some verification.
    I wouldn't recommend using anybody elses custom firmware. I would simply create my own. Sn0wbreeze will do the trick for you. Preserving the baseband will not really be needed since you can't downgrade that baseband anyways but sn0wbreeze will handle that for you as well.

    Sn0wbreeze 2.2.1 Jailbreak 4.2.1 / 4.2.6 on iPhone, iPad and iPod touch | Redmond Pie

  8. #8
    This is a 3G, so I do not think I need SHSH blobs, (nor TU) since 4.2.1 is the latest for the 3G.
    Also, I agree on using my own custom firmware, I already have one that I have used recently on other 3G phones

  9. #9
    Livin the iPhone Life
    Join Date
    May 2008
    Posts
    8,021
    Thanks
    102
    Thanked 788 Times in 731 Posts

    Hmmm. I think you're right Good catch

  10. #10
    Thanks everyone for the replies. Working on updating the baseband via redsn0w right now.

    Once that's done, i'll use sn0wbreeze to make a custom restore ipsw. Mind pointing me towards any guides about which options to select? I'm not sure about things like Hacktivate, ssh, etc. thanks!

  11. #11
    Livin the iPhone Life
    Join Date
    May 2008
    Posts
    8,021
    Thanks
    102
    Thanked 788 Times in 731 Posts

    Only one option to think about -- activation. The others can occur anytime.

    If you have access to an official SIM ... use it .... fewer issues in the future.
    If not, select activate.

  12. #12
    There's an old AT&T SIM in it whose account was cancelled a long time ago. I'm out of the country anyway. I assume I should activate then?

  13. #13
    Livin the iPhone Life
    Join Date
    May 2008
    Posts
    8,021
    Thanks
    102
    Thanked 788 Times in 731 Posts

    ^Couldn't hurt - I would give it a try. Many things are 'set-up' better with an official SIM, even an old one

    If it doesn't work, can always rebuid and load another cfw with [h]activation enabled.

  14. #14
    @luckycharms,
    Actually, sn0wbreeze can do everything all in one step, including the BB to 6.15.00.

  15. #15
    thanks Mes - i'll try it without hacktivation first. good idea.

    @Alinv - the only sn0wbreeze I've found to work with iOS 4.2.1 is sn0wbreeze 2.2.1. As far as I can tell, there's no place in there to point it at the iPad firmware for baseband.

  16. #16
    Livin the iPhone Life
    Join Date
    Nov 2007
    Location
    Arkham Asylum
    Posts
    1,041
    Thanks
    12
    Thanked 104 Times in 103 Posts

    Quote Originally Posted by Alinv View Post
    @luckycharms,
    Actually, sn0wbreeze can do everything all in one step, including the BB to 6.15.00.
    Depends which version of sn0wbreeze you use. Plus hacktivating causes more problems like excessive battery drain then using an official sim.

  17. #17
    Quote Originally Posted by luckycharms View Post
    @Alinv - the only sn0wbreeze I've found to work with iOS 4.2.1 is sn0wbreeze 2.2.1. As far as I can tell, there's no place in there to point it at the iPad firmware for baseband.
    You are right Lucky charms, sorry, I just used sn0wbreeze 2.7 on a 3GS, and saw the 6.15.00 option.

  18. #18
    Quote Originally Posted by ihappy View Post
    Depends which version of sn0wbreeze you use. Plus hacktivating causes more problems like excessive battery drain then using an official sim.
    Of course, I *want* to use a non-official SIM. But, I assume that once it's both activated with the AT&T chip and unlocked, I can just put in any carrier's chip without hactivating?

  19. #19
    Livin the iPhone Life
    Join Date
    May 2008
    Posts
    8,021
    Thanks
    102
    Thanked 788 Times in 731 Posts

    Quote Originally Posted by luckycharms View Post
    ... But, I assume that once it's both activated with the AT&T chip and unlocked, I can just put in any carrier's chip without hactivating?
    Yep. That's the way it's supposed to work

  20. #20
    hmm - redsn0w 0.9.6rc16 crashing while trying to download ipad baseband. any ideas?

    edit: nevermind - trying to install Cydia first, and then baseband...
    Last edited by luckycharms; 07-28-2011 at 01:19 PM.

Page 1 of 2 12 LastLast
Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •