Results 1 to 6 of 6

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Should I upgrade my Base Band? 5.11.07 for 4.3.3

  1. #1
    Default Should I upgrade my Base Band? 5.11.07 for 4.3.3
    I have a 3GS on 3.1.2 and BB 5.11.07 and it is jailbroken/unlocked with Blackra1n/Ultrasn0w.
    Simple questions. Should I upgrade my Base Band, to any version, before using a custom ipsw and upgrading to 4.3.3?
    I have TinyUmbrella and all SHSH files for every ipsw from 3.1.2 up to and including 4.3.3.
    My concern I guess is What is the best, most functional ipsw / base band combination at or above 4.0 for the 3GS phone?
    Can I or should I leave the base band alone and upgrade with a custom ipsw to 4.3.3?
    With that BB should I choose the unlock in Sn0wbreese or just chose Jailbreak and unlock with Unltasn0w from Cydia? I do have access to an AT&T sim if that makes a difference.


    I really cant afford to lose any of the functionality of the phone (WiFi/Blutooth/gps) so I am a little concerned.
    Please help if you can.
    Thanks in advance

  2. #2
    Livin the iPhone Life
    Join Date
    May 2008
    Posts
    8,023
    Thanks
    102
    Thanked 788 Times in 731 Posts

    There is no benefit to updating your baseband. On the other hand, a lower and unlockable baseband version like yours (5.11.07) adds value during a resale.

  3. #3
    Update to a custom 4.3.3 firmware that won't update the baseband. I recently did the same thing for my iPhone 4. It's easy.

  4. #4

  5. #5
    Livin the iPhone Life
    Join Date
    May 2008
    Posts
    8,023
    Thanks
    102
    Thanked 788 Times in 731 Posts

    Quote Originally Posted by Goof View Post
    I don't think that is correct, I am sure that it does update your baseband to 5.16.
    Custom firmwares built with PwnageTool or Sn0wbreeze and (shift | option)/click/select load w/iTunes do not update the baseband on 3G/3GS. The option exists, but is greyed-out and unavailable on the current PwnageTool. Back in the 4.1 days, the dev-team released a special PwnageTool 4.1.3_Unlock_Edition which had the option to install the iPad BB.

  6. #6
    Superbad Modder-ator Simon's Avatar
    Join Date
    Nov 2007
    Location
    Bermuda
    Posts
    46,775
    Thanks
    6,979
    Thanked 15,540 Times in 7,105 Posts

    Using a custom firmware made with pwnage tool or snowbreeze will indeed preserve your baseband as Mes is saying.

    Since you have 4.0 SHSH though I would shift restore to a regular 4.0 firmware first to get the 5.13.04 baseband which is the highest baseband you can get ans still unlock. Once on 4.0 with the 5.13.04 then shift/option restore to a custom 4.3.3 firmware to preserve that baseband so that you can still unlock if you want or keep resale value higher.

    DO NOT restore to a regular 4.1 or higher firmware ever as that will update your baseband.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •