+ Reply
Results 1 to 8 of 8

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: iPhone 4 Unlock / Error 1604

is a discussion within the

Unlocking / Activation

forums, a part of the

iPhone Modding

section;
Hi Guys, I just purchased a iPhone 4 from one of my friends and wanted to Jailbreak it. The iPhone is on 4.2.1 ATT Network (baseband 03.10.01). I realize that
...
  1. #1
    What's Jailbreak?
    Join Date
    May 2011
    Posts
    4
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Question iPhone 4 Unlock / Error 1604
    Hi Guys,

    I just purchased a iPhone 4 from one of my friends and wanted to Jailbreak it. The iPhone is on 4.2.1 ATT Network (baseband 03.10.01).

    I realize that i cannot unlock this phone but ALL i wish to do is REINSTALL the OS to 4.3 so that i will be able to use the Chinese SIM to unlock the phone and be able to use all the features of 4.3 !!

    When i try to restore using iTunes - I get error 1604.

    Here are the steps i follow:
    1. I have made the change to the hosts file on my MAC
    2. I use TinyUmbrella to save SHSH and then put the device in recovery mode and then start the server.
    3. Thereafter, i use the option-restore to browse to the .ipsw file and begin.

    I have tried several times but it always gives me the 1604 error.

    Any clue on how i can get this to work ?

    Help appreciated.

  2. #2
    Livin the iPhone Life Stray's Avatar
    Join Date
    Oct 2010
    Location
    You Know...
    Posts
    14,077
    Thanks
    676
    Thanked 1,358 Times in 1,075 Posts

    You are trying to restore to 4.3.3 correct?

  3. #3
    What's Jailbreak?
    Join Date
    May 2011
    Posts
    4
    Thanks
    0
    Thanked 0 Times in 0 Posts

    No. I am just trying to upgrade to 4.3.0 so that i can get the option of Personal Hotspot on the iPhone.
    I am told that the SIM would not work beyond 4.3.

  4. #4
    Livin the iPhone Life Stray's Avatar
    Join Date
    Oct 2010
    Location
    You Know...
    Posts
    14,077
    Thanks
    676
    Thanked 1,358 Times in 1,075 Posts

    What kind of sim card is it and do u have shsh's saved

  5. #5
    What's Jailbreak?
    Join Date
    May 2011
    Posts
    4
    Thanks
    0
    Thanked 0 Times in 0 Posts

    im in INDIA and they call it the "Turbo" SIM here. Has something in chinese come up with you insert the SIM, Dial 112, disconnect and then do the Airplane Mode to get the Signal.

    I have the SHSH saved currently on 4.2.1 using Tiny umbrella.

  6. #6
    Livin the iPhone Life Stray's Avatar
    Join Date
    Oct 2010
    Location
    You Know...
    Posts
    14,077
    Thanks
    676
    Thanked 1,358 Times in 1,075 Posts

    oh so it is a gevey sim? why don't you go to 4.2.1?

  7. #7
    What's Jailbreak?
    Join Date
    May 2011
    Posts
    4
    Thanks
    0
    Thanked 0 Times in 0 Posts

    i am on 4.2.1 !!

    The phone has greenp0ison with cydia installed on it as well.

    4.2.1 does not give me the Personal hotspot option. In fact, i don't see the option of Internet Tethering at all !!

    I tried reinstalling the 4.2.1 OS ipsw file as well but it gave me the same 1604 error.

  8. #8
    My iPhone is a Part of Me
    Join Date
    Sep 2009
    Location
    CA
    Posts
    755
    Thanks
    12
    Thanked 112 Times in 79 Posts

    you can't go to ios 4.3 anymore, only io 4.3.3. undo the changes to uour hosts, restore to 4.3.3 and try the sim then, it should/may work

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts