+ Reply
Results 1 to 6 of 6

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Rebel Micro Simcard Iphone 4

is a discussion within the

Unlocking / Activation

forums, a part of the

iPhone Modding

section;
Hello everyone.Regarding the rebel micro simcard for iphone .Has anyone actually used this unlocking sim yet and what process do they use?
...
  1. #1
    iPhone? More like MyPhone
    Join Date
    Apr 2011
    Posts
    101
    Thanks
    0
    Thanked 3 Times in 3 Posts

    Default Rebel Micro Simcard Iphone 4
    Hello everyone.Regarding the rebel micro simcard for iphone .Has anyone actually used this unlocking sim yet and what process do they use?

  2. #2
    What's Jailbreak?
    Join Date
    Apr 2011
    Posts
    3
    Thanks
    0
    Thanked 0 Times in 0 Posts


  3. #3
    iPhone? More like MyPhone
    Join Date
    Apr 2011
    Posts
    101
    Thanks
    0
    Thanked 3 Times in 3 Posts

    Quote Originally Posted by lynkchiz View Post
    nice thanks

  4. #4
    iPhone? More like MyPhone
    Join Date
    May 2009
    Posts
    207
    Thanks
    7
    Thanked 3 Times in 3 Posts

    NO THIS SH!T IS DAMM FAKE. I GOT IT AND I TRIED TO USE IT AND NOTHING, DOESNT EVEN FIT IN THE PHONE, GOTTA FORCE IT IN. I READ REVIEWS AND OTHERS SAY ITS FAKE TO. I MAKE A CLAIM IN PAYPAL TO GET MY MONEY BACK BECAUSE IT DOESNT FIT AND WORK, AND SOLUTIONS POINT SAY "The item does not fit into the phone as stated" THEN WHATS THE POINT!!! ITS CRAP

  5. #5
    Super Penguin Mod i.Annie's Avatar
    Join Date
    Jun 2009
    Location
    SW Ohio
    Posts
    16,907
    Thanks
    137
    Thanked 2,202 Times in 1,924 Posts

    ...Ok then.

    Well I heard, and saw a video, that Rebel SIM doesn't work. You should probably go for a Gevey.

  6. #6
    Green Apple
    Join Date
    Jul 2010
    Posts
    46
    Thanks
    9
    Thanked 2 Times in 2 Posts

    Hi guys, I got my Rebel sim yesterday...and I really don't know how it works cuz it kinda randomly started to decide to work....

    Basically what happened was I got it, I put it in and as expected, at first it DIDN'T work. So I tried different methods to get it to work and the symptoms looked right...but randomly during one of my attempts to get it to work, it started working.. I have no explanation lol still trying to figure it out, but now whenever I turn on/off my phone it DOES automatically receive signal. However, I'm on t-mobile and so I dont have the 3g stuff on and yeah no data. It's just 2g.

    I'm still trying to work out the little obstacles with it, but sofar so good...just took FOREVER to come -.-

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts