Page 3 of 3 FirstFirst 123
Results 41 to 46 of 46

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Facetime : Waiting for activation after GEVEY unlock

  1. #41
    Quote Originally Posted by xoomph View Post
    Hi all,

    Information of my phone:

    ios : 4.3.1 (gevey)
    baseband : 4.10.01
    carrier : 10.0
    Model : MC603C ( i think that carrier is Rogers for Canada)

    I have tried so many times the SAM to fix push notification problem. However it did not work. Then i have found this post. I really wonder that can it be solution for this problem ?

    Could you please share your comments?
    Unfortunately, it did not work i have followed the instruction step by step. Also cellular data network was missing. However when i turn on the facetime, it is waiting for activation as a result, push notification is not working :/

    Is there any solution for this issue ?

  2. #42
    What's Jailbreak? msb2011's Avatar
    Join Date
    Jul 2011
    Location
    Toronto, Ontario, Canada
    Posts
    26
    Thanks
    1
    Thanked 0 Times in 0 Posts

    Humm looks like people still have issue with facetime. Since i upgraded to ios5 my FaceTime and i messages works fine even though the settings shows FT activation unsuccessful.

  3. #43
    Hello, after trying to find a solution I finally found one. I replaced a file in system/library/launchdaemons called com.apple.imagent.plist with and edited ones that has some lines removed to make it work. I would suggest making a copy of the original incase it doesnt work. I used ifile and rebooted after i replaced and it worked. This is a link to the file MEGAUPLOAD - The leading online storage and file delivery service
    I would post where i originally found the solution but they share cracked games so i cant. But google can help with that. The original post had a different edit than me. I had to remove some other lines to make it work. But the above file did it for me after 3 hours of hard work and alot of rebooting. I tried everything except restoring. I changed the DNS, reset network connection, tried fooling around with the caller ID, you name it. Nothing worked except for this.

    Good luck

  4. #44
    Would this method still work if your phone number is showing as "unknown"? My question is if it does work and somehow activates my facetime, how will facetime associate my actual number to my Iphone 4 so that people can contact me?

    Quote Originally Posted by Netcruzer View Post
    Hey. I was in the same boat, I have a Telus locked iPhone, unlocked with Gevey, trying to use on Rogers. I could do everything but activate facetime, well after 4 days trying (mitime didn't work for me), I figured out a way to get facetime working for FREE.

    First, get to your desired firmware (I'm running 4.3.3), jailbreak it (may not be necessary, but I jailbroke mine), and ensure it's properly activated and that push is working. Either use a legit sim, or SAM to activate.

    Then, use the program DISK AID, connect to the root of your iPhone.
    Navigate to System > Library > Carrier bundles > iPhone > Unknown.bundle

    Save out the carrier.plist that is in unknown.bundle. Save it to your desktop somewhere you can find it later.

    Then, navigate to your intended carrier bundle, for example, mine was Rogers, so I went into the Rogers_ca.bundle, copy the carrier.pist from here into the unknown.bundle folder.

    You have just overwritten the stock unknown carrier plist with the Rogers carrier plist.

    The reason for this is so that you can use the correct number registration used for facetime activations.

    Reboot your iPhone. Do the gevey process again. If you can't see the option to edit your "Cellular Data Network" in Settings > General > Network, then it worked. To clarify, it should be missing.

    So, now you have verified that you are using the Rogers carrier.plist. Go to Settings > Phone > and Turn ON facetime.
    It will send a text message to the proper Rogers auth number (49988) instead of the UK number the unknown carrier tried to use.

    You will be authorized! FaceTime works. Congrats.

    Now.. you could leave it as is, but you might not have wifi tethering support.

    To enable tethering, reconnect your phone to DISK AID and restore the saved unknown.bundle carrier.plist into the uknown.carrier folder.

    Reboot.
    Do Gevey process again.
    Go to Settings > General > Network > Cellular Data Network, and reset settings.
    It should clear all APNs
    Manually re-enter your carrier settings for APN, MMS and Tether.

    Exit

    Everything should now be working, Push, Facetime, Cell Data, WiFi Tether.
    You're welcome!

    NOTES: This process of swapping the carrier.plist file into the unknown bundle folder should work to enable facetime with any OFFICIAL carrier.

    You must copy the plists around because editing them is not possible, the plists on iOS 4.x are signed and cannot be changed, but you CAN move them around.

  5. #45

  6. #46
    This method works fine if your Gevey Unlock SIM (There are many versions) reports as Unknown carrier to your iPhone (Settings -> General -> Information -> Carrier) . But if it shows as Carrier Lab 11.0 then you need to replace the "carrier.plist" file in the CarrierLab.Bundle folder. Then it should work. Mine did!

Page 3 of 3 FirstFirst 123
Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •