Results 1 to 5 of 5

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: iPhone 4 unlocked: Phone and Text working; data not working. Help.

  1. #1
    Default iPhone 4 unlocked: Phone and Text working; data not working. Help.
    I've unlocked my AT&T iPhone 4 using Ultrasn0w and have a new sim card from Optus in Australia. The phone and sms functions work fine on Optus, and I have a good signal (4 bars) and 3G connection. However, I can't get data to work (no internet connection). I'm using iOS 4.0.1 and did save 4.0.1 SHSH blobs. Optus swears the setup is okay on their end. I'm new to this and am not sure what to do next. Any suggestions on how to get the data working?

  2. #2
    You will need to put the cellular data settings into your phone. Have you done it?

  3. #3
    Quote Originally Posted by westonben View Post
    You will need to put the cellular data settings into your phone. Have you done it?
    No. I'll google it, but can you provide a link to instructions or explain what you mean in a bit more detail?

    EDIT: I just reset my network settings and now things are magically working!!! Yay! Finally have a jailbroken and unlocked iPhone that is free from AT&T!
    Last edited by mwalking; 08-19-2010 at 04:19 AM.

  4. #4
    Good you got it working. Optus must have sent the settings to your phone so you didn't need to do it manually.

    If you go to unlockit.co.nz in safari on your phone, you will find a custom profile for Optus, this would have put the settings in for you and may give you the option to put in internet tethering settings too.

  5. #5
    Quote Originally Posted by mwalking View Post
    No. I'll google it, but can you provide a link to instructions or explain what you mean in a bit more detail?

    EDIT: I just reset my network settings and now things are magically working!!! Yay! Finally have a jailbroken and unlocked iPhone that is free from AT&T!
    Hi there~ i'm having the same problem, would you please tell me how did u reset you network setting~? thx

    Quote Originally Posted by westonben View Post
    Good you got it working. Optus must have sent the settings to your phone so you didn't need to do it manually.

    If you go to unlockit.co.nz in safari on your phone, you will find a custom profile for Optus, this would have put the settings in for you and may give you the option to put in internet tethering settings too.
    hi i have already try it, but will not work.. no tethering either....
    Last edited by kuroiyuki; 08-28-2010 at 11:09 PM. Reason: Automerged Doublepost

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •