Results 1 to 18 of 18

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: iPhone 3G[S] won't activate

  1. #1
    Default iPhone 3G[S] won't activate
    I have a previously jailbroken iPhone 3GS on 4.0.
    When I upgraded to 4.0 it got locked in the Connect to iTunes screen.
    I have a prepaid AT&T card and I used it to activate a couple of iPhones, but with this one, I can't.
    It says IMEI: Unknown and ICCID: Unknown, and the top left corner just says "iPhone", as in, it doesn't say there is no SIM card inserted, nor does it ask for one.
    I inserted the AT&T SIM, rebooted, and nothing happens.
    Any help please???

    Also, if I let it plugged in, it will occasionally reboot.
    The sign that appears in iTunes (while the AT&T SIM is in) says:
    There is no SIM card installed in the iPhone you are attempting to activate.
    Please disconnect and insert a SIM card in the iPhone.

    By the way, I can restore it to: 3.1.3, 4.0, 4.0.1 and 4.0.2.

    C'mon guys, almost 200 views and not a single reply?
    I really need your help, please.
    Last edited by Pauloch; 08-16-2010 at 03:06 PM. Reason: Automerged Doublepost

  2. #2
    Bump guys, I really need some help.
    I'm stuck with a non working $600 phone.

  3. #3
    I think you've got a corrupt bootloader. Google to see if you can reflash it somehow. I'll take a look as I had a similar problem a while back.

    I think your best bet is to do a factory restore to 4.0.1 and rejailbreak.
    Last edited by eyeRobot; 08-18-2010 at 07:20 AM. Reason: Automerged Doublepost

  4. The Following User Says Thank You to eyeRobot For This Useful Post:

    Pauloch (08-18-2010)

  5. #4
    Quote Originally Posted by westonben View Post
    I think you've got a corrupt bootloader. Google to see if you can reflash it somehow. I'll take a look as I had a similar problem a while back.

    I think your best bet is to do a factory restore to 4.0.1 and rejailbreak.
    Thanks for your answer, though, sadly I had already restored to 4.0.1, also 4.0 and 3.1.3 and in none of this cases was I able to activate it using the prepaid AT&T SIM card.
    What could it be??

  6. #5
    Is the phone actually asking for you to activate?

    Are you able to JB with spirit at3.1.3?

    Old or new bootrom?
    Last edited by eyeRobot; 08-18-2010 at 10:10 PM.

  7. #6
    It has the new bootrom.
    I was able to jailbreak it with Spirit on 3.1.3, but when I upgraded it to 4.0 it got locked on the Connect to iTunes screen.
    Now, no matter what firmware I up/downgrade it too, it's stuck in the Connect to iTunes screen. I insert the SIM card, reboot it/unplug-plug it and it's still stuck.

  8. #7
    Have you tried recboot?

    RELEASED: RecBoot 1.0.2

  9. #8
    Still not working :S

  10. #9
    try to jailbreak with redsn0w? it kicks it out of restore at the end

  11. #10
    try this,
    unplug the sim. leave it out but put the tray back init.
    put the iphone into DFU mode, "plug the iphone into computer, hit and hold power+home, keep holding home once u here the disconnect sound. if done right it will show a black screen, not connect to iTunes logo."
    doubble check your firmwears with a checksum or a torrent if u got them off it it. make sure no data is missing.
    then re flash it. use itunes or other prgram, i think PwnageTool can do it.
    then unplug turn off, turn on insert sim. then connect to iTunes.

    also i think the new boot rom will not allow you to unlock and jailbreak it via PwnageTool's. have to use jailbreakme.com just dont update to 4.0.2 or that wont work.

    tell me if that works.

    also apple did update their activation servers and that is why phonebook sim cards dont work... if that sim is listed on more then one iphone activation they may have blacklisted it.?? that is if they record that info. don't totally know.
    Last edited by htcuhm; 08-25-2010 at 11:06 PM. Reason: Automerged Doublepost

  12. #11
    Quote Originally Posted by amsgator View Post
    try to jailbreak with redsn0w? it kicks it out of restore at the end
    redsn0w only works on 3G, but thanks anyway.


    Quote Originally Posted by htcuhm View Post
    try this,
    unplug the sim. leave it out but put the tray back init.
    put the iphone into DFU mode, "plug the iphone into computer, hit and hold power+home, keep holding home once u here the disconnect sound. if done right it will show a black screen, not connect to iTunes logo."
    doubble check your firmwears with a checksum or a torrent if u got them off it it. make sure no data is missing.
    then re flash it. use itunes or other prgram, i think PwnageTool can do it.
    then unplug turn off, turn on insert sim. then connect to iTunes.

    also i think the new boot rom will not allow you to unlock and jailbreak it via PwnageTool's. have to use jailbreakme.com just dont update to 4.0.2 or that wont work.

    tell me if that works.

    also apple did update their activation servers and that is why phonebook sim cards dont work... if that sim is listed on more then one iphone activation they may have blacklisted it.?? that is if they record that info. don't totally know.
    Yeah, that's what I've been doing since day one.
    My SIM works perfectly, it's the phone that won't even ask for a SIM card.

  13. #12
    hum, so your perpaid at&t is not recongized in the iphone, and normaly it does not say no sim, only when u plug in the at&tsim it says their is no simcard. is this correct?

    i think you may have a hardware issue, best way to test this is if u have a friend who has an iphone/phone try using their sim in it, does not need to be connected to iTunes, it should at least regongise a sim is in it...if it does your old sim u are useing may be defective. if it is still saying no sim and u flashed it in DFU mode "very important" id say its a hardware issue. and that the iphone may have water dmg "most common issue with iphones" to the sim card reader or its just broke from heavy wear...could always try cleaning it?? turn phone off, get a stir stick with thin fabric soaked in rubbing alocheal. in the hole rub aorund repeat 3 times. dont use a lot of pressure. let dry for a min or two, can blow on it to make shure. then swich phone back on and see what it does.

    good news is they can be replaced. just cost a bit extra. and it may not be the only problem. id contact the seller and demand a refund for faulty products....

    O2nd thought, u might have flashed it with the wrong version of the firmware.. their is firmware for iphones that are locked to carriers network, and ones that arnt. maybe u mixed them up??? i know i read something about that somewhere let me try and find it...i found it but that only applys if u are flashing custom firmwares.. not need for 4.0-4.0.1 just use jailbreakme.com and ultrasnow or what not to unlock.

    sorry man but i think your phone is busted.

  14. #13
    Quote Originally Posted by Pauloch View Post
    redsn0w only works on 3G, but thanks anyway.
    no it doesn't. if you are 4.0.2 it only works on the 3G, but you said previously you can restore to 3.1.3 or 4.0 etc etc

  15. #14
    Quote Originally Posted by htcuhm View Post
    hum, so your perpaid at&t is not recongized in the iphone, and normaly it does not say no sim, only when u plug in the at&tsim it says their is no simcard. is this correct?

    i think you may have a hardware issue, best way to test this is if u have a friend who has an iphone/phone try using their sim in it, does not need to be connected to iTunes, it should at least regongise a sim is in it...if it does your old sim u are useing may be defective. if it is still saying no sim and u flashed it in DFU mode "very important" id say its a hardware issue. and that the iphone may have water dmg "most common issue with iphones" to the sim card reader or its just broke from heavy wear...could always try cleaning it?? turn phone off, get a stir stick with thin fabric soaked in rubbing alocheal. in the hole rub aorund repeat 3 times. dont use a lot of pressure. let dry for a min or two, can blow on it to make shure. then swich phone back on and see what it does.

    good news is they can be replaced. just cost a bit extra. and it may not be the only problem. id contact the seller and demand a refund for faulty products....

    O2nd thought, u might have flashed it with the wrong version of the firmware.. their is firmware for iphones that are locked to carriers network, and ones that arnt. maybe u mixed them up??? i know i read something about that somewhere let me try and find it...i found it but that only applys if u are flashing custom firmwares.. not need for 4.0-4.0.1 just use jailbreakme.com and ultrasnow or what not to unlock.

    sorry man but i think your phone is busted.
    Thanks, I will try all of that. Though I do believe I have a f*cked up phone.
    I mean, about a week ago, after constantly trying, I turned it on and it was asking for the SIM card! I put it in, and managed to activate it! I jailbroke on jailbreakme.com but when Cydia was refreshing sources, WiFi just died and never got signal again. I rebooted it (dumb) and it never worked again.
    Do you guys think that if I took it to Apple (with original package and everything) and show it's defective, they exchange it for a new 3GS ?

    Forgot to say, I bought it with no carrier from Apple.

    Is there a way I can contact Apple to tell them about this issue?
    I tried through their webpage, but the options are get are either to call them or to receive a call from them, but neither is good for me as i live in Argentina.
    Perhaps an e-mail where they can suggest a solution?
    Last edited by Pauloch; 08-28-2010 at 02:52 PM. Reason: Automerged Doublepost

  16. #15
    when u jailbreak a phone it voids it warranty, but u should just leave that part out and say it just does not work...but i think apple wont do crap. if you restored it more then once it should have worked out a bug that might have been software related... also i hard hard resetting 2 times in a row sometimes helps the machine fix little things.... it just clears its ram.... also if the phone was stoen over in the eastern side of the world i here they block IMIE numbers.... so unless u know it is not stolen maybe it got blocked and thats why its not working or activating.

    none the less, call apple or email then and do not menshion jailbreak or cydia... infact flash it to 4.0.1 and do not touch it. and ask what to do from their. they should help you. or be abel to point you in the right direction.

  17. #16
    Quote Originally Posted by htcuhm View Post
    when u jailbreak a phone it voids it warranty, but u should just leave that part out and say it just does not work...but i think apple wont do crap. if you restored it more then once it should have worked out a bug that might have been software related... also i hard hard resetting 2 times in a row sometimes helps the machine fix little things.... it just clears its ram.... also if the phone was stoen over in the eastern side of the world i here they block IMIE numbers.... so unless u know it is not stolen maybe it got blocked and thats why its not working or activating.

    none the less, call apple or email then and do not menshion jailbreak or cydia... infact flash it to 4.0.1 and do not touch it. and ask what to do from their. they should help you. or be abel to point you in the right direction.
    Yeah, that's exactly what I'll do. It was purchased form an Apple Store and I still have the receipt, so they'll know it's not stolen.
    I've already restored it to 4.0.1 and will say absolutely nothing about jailbreaking.
    I'm travelling to America at the end of September so I will see then what happens!

  18. #17
    Quote Originally Posted by htcuhm View Post
    when u jailbreak a phone it voids it warranty
    yes, but restoring it back to factory settings miraculously "un-voids" your warranty

  19. #18
    As long as it still has warranty and it won't even turn on, you can take it into an Apple store and tell them that it's not working. They will most likely take it to the back and do some "diagnostics" on it, then come out to inform you that they could not get it to work, then they will say "we'll get you a replacement since you said it stopped working, and we can't get it to work either."

    Just be sure to tell them you've tried updating, restoring, restoring with dfu mode etc. And also be sure to not mention jailbreaking.

    They'll probably ask "have you done anything in particular to this device that may void the warranty?"

    Your answer? "Nope "

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •