Results 1 to 11 of 11

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Please Help!- Problem with Tmobile Carrier Settings on Unlimited Data Plan

  1. #1
    Default Please Help!- Problem with Tmobile Carrier Settings on Unlimited Data Plan
    ok i have been trying everything possible since last night and searching all over the web to no avail.

    i have an iPhone 3G 16gb which i Jailbroke and unlocked via Blackra1n and Blacksn0w. The phone has a Tmobile Sim and is on the "Even More Plus" unlimited plan.

    i manually input the epc.tmobile.com APN and got the message "your current plan is not compatible with this device" on safari. i then put the wap.voicestream.com APN and got the same message. Internet2.voicestream.com received a "you are not currently subscribed to a data plan" message.

    next i tried installing one of the Carrier bundles from Rock your phone, none of them worked.

    i have tried restoring and rejailbreaking and doing everything again and still have not been able to get it to work. please help, my data services have been working fine for the 5 months ive been on tmobile and all of a sudden im getting this mesage.

    if anyone can at least direct me to someone who can help id appreciate it...


    Further Notes:

    The first time i jailbroke and unlocked with the blackweather apps i received the same incompatible plan message in Safari. i installed one of the carrier bundles which did not work, then removed it and input the APN manually. The data was working fine but i restored the phone once again because i wanted to get rid of cydia. i have not been able to get it to work since.

  2. #2
    the settings i used on my 3g 8gb were

    apn: general.t-mobile.uk
    user: user
    password: pass

    This works on both edge and 3g when iv got coverage. Im on flext 35 with web n walk but i think they should be the same.

    Sorry guy didnt realise you were in america.
    Last edited by macabre; 11-04-2009 at 11:58 AM.

  3. #3
    Quote Originally Posted by macabre View Post
    the settings i used on my 3g 8gb were

    apn: general.t-mobile.uk
    user: user
    password: pass

    This works on both edge and 3g when iv got coverage. Im on flext 35 with web n walk but i think they should be the same.
    im going to try adding user and pass to the US APN but it wont work with the UK APN

    **update - no luck :-/

    someone in the US please help i have tried everything i can think of. i dont understand why this is happening when i have an unlimited data plan and everything was working fine before
    Last edited by jayizratedx; 11-04-2009 at 09:43 AM.

  4. #4
    I have tmobile since two years and i had tzones on my accound it was 5.99 per month and I was using with iphone well.. yesterday I upgraded to even more plus everything now I have unlimited data plan anyway but i cannot use data service anymore.. I have same error messages like you have.. I dunno how to fix it! if i will do, I ll let u know
    Last edited by gokhan; 11-04-2009 at 11:35 AM.

  5. #5
    i was reading about people who have updated to the Even More Plus plans and it seems that everyone on the Plus plans has lost data services including G1 owners.

    the fix for the G1 is to go on the Tmobile website and select the option that says "not my phone" under my Account, then select the MyTouch3g as your phone. afterwards your supposed to go and select a data plan thats going to be listed as free.

    this has worked for many people but i have tried and the Free data plan does not show up under services. i will keep trying this method and see if i can make it work and keep the post updated

  6. #6
    I tried but did not work for me.

  7. #7
    i contacted tmobile regarding the issue and the rep said that the problem is that the plan was correct but the data service was not specified. he said he was going to correct it and asked me which phone i was using. i said i was using an unlocked iphone and he said that the iphone uses their smartphone data plan and that he would update the information.

    he told me it should be working within a couple of hours and that if i have any problems to contact them again

    ill keep you guys posted with the results

    it works!!!! looks like to fix it all you have to do is contact tmobile!! hope this thread helps everyone having similar problems!

    by the way the correct APN is epc.tmobile.com
    Last edited by jayizratedx; 11-04-2009 at 12:39 PM. Reason: Automerged Doublepost

  8. #8
    its still same for me!
    I m using epc.tmobile.com and I selected touch3g phone on tmobile web but still same..

  9. #9
    Im using the shadow unlimited plan and i wanna switch to the new plus plan

    Im using internet2.voicestream.com apn

    if i switch what is it exactly that i would have to change?



    is epc.tmobile.com faster then voicestream.com?

    does the new unlimited plan work?

    i have a 2g 16gig..

    thanks in advance for any help posted
    WHEN MY PHONE ACTS UP I GET ANGRY

  10. #10
    Now Im available to use data plan.. I went to tmobile store they called to REP and did something now its fine! thanks jayizratedx!!!

    I m using iphone 3gs and i wanted to say voicestream or epc or 3g plan or tzones all same sh*t same fast

  11. #11
    I will co-sign on this...I have everything plus unlimited data and text, and it took me calling them and them setting my flex options up differently, so before you go crazy:
    Check your settings against the ones below (NOTE: this is for t-mobile customers in the U.S.)

    --This was tested on my blackra1n unlocked iphone 3g (OS on it was 3.1.1) with t-mobile 1000 + unlmtd data and texting)

    MMS: Works fine
    Data (EDGE): Safari works fine other apps (news aim etc) also work fine
    Youtube: works fine

    THESE SETTINGS ARE FROM T-MOBILE AS OF 11/6/09

    From the Main Menu, tap Settings.
    Verify that Wi-Fi is set to Off or Disabled -- this will ensure that no wi-fi signals are interfering with your Internet access. To take advantage of local wi-fi at a later time, feel free to go back and turn this setting On; just make sure to turn it Off again when you are done using the wi-fi network.
    Tap General Settings, then tap Network.
    Turn Data Roaming On -- this will allow your iPhone to locate T-Mobile’s data network.
    If you see a setting for 3G, turn it Off -- the iPhone cannot currently connect to T-Mobile’s 3G network, and this setting will interfere with its attempt to connect to our EDGE network for service.
    Tap Cellular Data Network (this setting may be labeled EDGE instead).
    In the APN field, enter internet2.voicestream.com -- this tells T-Mobile which version of our Internet network you want to connect to. (Sometimes the internet2.voicestream.com APN does not work, you can also try using epc.tmobile.com)
    Leave the Username and Password fields blank -- T-Mobile will assign this information based on your SIM card information.
    Return to the Main Menu and open Safari to browse the Internet.

    For troubleshooting internet problems on iPhone:
    If your internet stops working first thing you would to do is check to make sure that the APN listed above is still there. If it is and internet is still not working, next go to Settings>General>Reset>Reset Network Settings (This is the ONLY option in here that will NOT erase contacts/pictures/text messages). Then we will need to type the APN back into the Cellular Data Network section.

    Please remember that it generally takes 24 to 48 hours for Internet service to begin, but it can take anywhere from 2 to 72 hours. If you have recently added T-Mobile Internet service to your account but you do not have Internet service within two days, please feel free to call us back so we can troubleshoot the issue for you.

    Picture Messaging

    If you are interested in adding Picture Messaging to your iPhone, you will need to type in the following information:

    Go to Settings -> General -> Network -> Cellular Data Network -> MMS:

    APN: wap.voicestream.com
    Username: <blank>
    Password: <blank>
    MMSC: http://216.155.174.84/servlets/mms
    MMS Proxy 216.155.165.50:8080
    MMS Max Message Size: <default>
    MMS UA Prof URL: <blank>

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •