Results 1 to 11 of 11

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: unlocked iphone 2.1 not working with itunes

  1. #1
    Default unlocked iphone 2.1 not working with itunes
    Hi,

    My unlocked iphone has 2.1 and it is not working with itunes 8 or 7.7

    Error with 8.0:
    "SIM card appears to be not supported"

    Error with 7.7 & 7.5:
    "iphone cannot be used because it requires atleast itunes 8.0 or later"

    So I am basically stuck with no way to use itunes. Please help me!!

    Thank you so much in advance
    Last edited by gkr747; 10-23-2008 at 10:57 AM.

  2. #2
    Livin the iPhone Life Poseidon79's Avatar
    Join Date
    Jan 2008
    Location
    Austin, TX
    Posts
    8,265
    Thanks
    819
    Thanked 1,681 Times in 1,159 Posts

    Download bootneuter from cydia and reflash the baseband.

  3. #3
    Do you want me to use itunes8 or earlier versions?

    I see the bootneuter is for iphone 2g and version 2.0..can I still use that as mine is 3G with version 2.1?
    Last edited by gkr747; 10-23-2008 at 11:58 AM.

  4. #4
    Livin the iPhone Life Poseidon79's Avatar
    Join Date
    Jan 2008
    Location
    Austin, TX
    Posts
    8,265
    Thanks
    819
    Thanked 1,681 Times in 1,159 Posts

    iTunes 8. Bootneuter is the program that performs the unlock on all firmwares 2.0 and above so basically you're just re-unlocking it.

    You have a first gen phone right? not a 3G with a SIM card adapter.... ?

  5. #5
    Mine is a 3G and i think there is something below the SIM card ( like a thin sheet of circuit board ) which I think maybe the SIM adapter you are asking?

  6. #6
    Livin the iPhone Life Poseidon79's Avatar
    Join Date
    Jan 2008
    Location
    Austin, TX
    Posts
    8,265
    Thanks
    819
    Thanked 1,681 Times in 1,159 Posts

    Oh ok.. makes sense now. I don't know much about the SIM unlocks and have heard so much about the unreliability of them I just ignore the subject, haha. If you don't know what kind you have then you have no way to contact the manufacturer to see if they have an update. You're last resort would be to find a new SIM adapter that you KNOW is compatible with iTunes (if any exist).

  7. #7
    what is the original service provider for your iphone, and who are u with now?

    are u using Gevey 3 G sim device with you sim card?

  8. #8
    iPhone? More like MyPhone
    Join Date
    Oct 2008
    Location
    Mumbai, India
    Posts
    272
    Thanks
    4
    Thanked 25 Times in 25 Posts

    Youll need to "hacktivate" your iPhone 3G.

    Basically, use PwnageTool/WinPwn and create a custom firmware, tick "yes" for Activation.

    Once you do that, restore the phone using the custom firmware, and use your iPhone 3G with the SIM Solution.

    iTunes wont give you the "SIM card not supported" error.

    If you need a guide. Here > http://thebigboss.org/guides/winpwn-25-guide/

    If you want to use 2.1, you going to have to find a MAC and use the latest PwnageTool.
    Last edited by Ad1tya; 10-23-2008 at 03:42 PM.

  9. #9
    pspboy1, yes I am using gevey sim and this is my new iphone...never used before...unlocked for tmobile

  10. #10
    well one solution i can think off is putting your phone on DFU when you wanna sync it with itunes, that should do the job, otherwise you just try pwning it. (google pwnage tool)

  11. #11
    is the phone working fine?
    If yes then put the phone in DFU mode before you hook it up to itunes.

    This is probably caused my some unlock sim. If you put the phone in DFU itunes will skip checking the sim and you should be fine.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •