Alright, I have some questions. If these have been answers, please just link me.
  1. If you used IPSF to unlock in 1.0.2, can you just upgrade?
  2. Does IPSF unlock 1.1.2 phones if you downgrade to 1.1.1, unlock, then upgrade?