So I went about unlocking the 5th iPhone on my iMac when I got the dreaded (1602) error. Fixed this by reinstalling iTunes, clearing Sync history, deleting iPhone firmware downloads, and reinstalling iSync.
Now the phone is updating as it should (last step where iNdependence does it's "Pre-1.1.1 upgrade" thing), but iNdependence gives me a "Couldn't connect to iPhone" error while iTunes is performing the update.
The result is I DO have 1.1.1, but it's locked, well basically it's as new. If I want to jailbreak in iNdependence again I get the whole "restore to 1.0.2" thing again.
My solution for now (I need a phone) is downgrading to 1.0.2 and unlock it using AnySim there. I don't have any other Macs or windows boxes available.

Is there any way I can still upgrade this phone to 1.1.1 or do I need to wait for the virginize tool to come out?