+ Reply
Results 1 to 6 of 6

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Group MMS problems on iPhone 4 AT&t

is a discussion within the

AT&T

forums, a part of the

iPhone Modding

section;
I looked all over and have not seen anyone else with this issue. I have an iPhone 4 jailbroken on iOS 5.0.1. Any assistance/advice would be greatly appreciated. I can
...
  1. #1
    What's Jailbreak?
    Join Date
    Jun 2010
    Posts
    11
    Thanks
    1
    Thanked 0 Times in 0 Posts

    Default Group MMS problems on iPhone 4 AT&t
    I looked all over and have not seen anyone else with this issue. I have an iPhone 4 jailbroken on iOS 5.0.1. Any assistance/advice would be greatly appreciated. I can send and receive group mms from or to multiple iMessage users without any problems. I cannot send or receive group mms messages if there are both iMessage and non-imessage users in the same group. If you look at photo #1 it shows the picture I am sending all looks well. Then if I exit the messages app and go back the picture disappears but it still looks as though it is trying to send (photo #2), If you look at the progress bar it never goes past this point. If I hit edit in the screen (photo#3) you will see that the line that the photo was on is still there. Photo #4 shows what it looks like when someone sends me a group mms when there is also a non-imessage user in the same group. The blue and white arrow comes up but not photo. If i tap the blue and white arrow an all black image comes up(blank). I hope this makes sense. Thanks for any help in advance. Also note, I can send and receive mms to any single person without issue. It is only on group mms.
    Attached Thumbnails Attached Thumbnails Group MMS problems on iPhone 4 AT&t-1.png   Group MMS problems on iPhone 4 AT&t-2.png   Group MMS problems on iPhone 4 AT&t-3.png   Group MMS problems on iPhone 4 AT&t-4.png  
    Last edited by starops777; 01-13-2012 at 11:53 AM.

  2. #2
    My iPhone is a Part of Me
    Join Date
    Sep 2007
    Posts
    860
    Thanks
    9
    Thanked 51 Times in 47 Posts

    did you recently put your ATT sim into a iphone 2G? perhaps ATT thinks your on a 2G iphone and MMS is turned off. when you used iMessage successfully, was that on wifi or 3G?

  3. #3
    What's Jailbreak?
    Join Date
    Jun 2010
    Posts
    11
    Thanks
    1
    Thanked 0 Times in 0 Posts

    Quote Originally Posted by daytonaviolet View Post
    did you recently put your ATT sim into a iphone 2G? perhaps ATT thinks your on a 2G iphone and MMS is turned off. when you used iMessage successfully, was that on wifi or 3G?
    I can send mms to iMessage or non-imessage users over 3g without any issues. It is strictly Group MMS. Do you see how the picture disappears when I exit the messages app? Could it have anything to do with restoring from an ios4 backup? Could it be a permissions problem possibly?

  4. #4
    What's Jailbreak?
    Join Date
    Jun 2010
    Posts
    11
    Thanks
    1
    Thanked 0 Times in 0 Posts

    OK looks like I solved it myself and it was a permissions problem. I went to var/mobile/library/SMS Folder and applied the 777 permissions to the whole hierarchy and it worked. Looks like for some reason it was not allowing the photo to save there in order to be sent.

  5. #5
    My iPhone is a Part of Me
    Join Date
    Sep 2007
    Posts
    860
    Thanks
    9
    Thanked 51 Times in 47 Posts

    Quote Originally Posted by starops777 View Post
    OK looks like I solved it myself and it was a permissions problem. I went to var/mobile/library/SMS Folder and applied the 777 permissions to the whole hierarchy and it worked. Looks like for some reason it was not allowing the photo to save there in order to be sent.
    great find. but, how did it change permissions? what was it before you set it to 777?

  6. The Following User Says Thank You to daytonaviolet For This Useful Post:

    starops777 (01-13-2012)

  7. #6
    What's Jailbreak?
    Join Date
    Jun 2010
    Posts
    11
    Thanks
    1
    Thanked 0 Times in 0 Posts

    Quote Originally Posted by daytonaviolet View Post
    great find. but, how did it change permissions? what was it before you set it to 777?
    The SMS folder itself was already set to the correct permissions. It must have been something in the folder that was not. So I went on to ifile and switched on the apply to hierarchy button and that did it. I am not sure which specific file had the wrong permissions but nonetheless it is fixed!

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts