+ Reply
Page 1 of 2 12 LastLast
Results 1 to 20 of 37

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: APN settings for ATT gophone data plan not working

is a discussion within the

AT&T

forums, a part of the

iPhone Modding

section;
Hi, I have an iPhone 4 and i'm using it as a gophone. I added the 500mb data package feature. I then went on unlockit.co.nz and tried each of the
...
  1. #1
    What's Jailbreak?
    Join Date
    Sep 2011
    Posts
    6
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default APN settings for ATT gophone data plan not working
    Hi,

    I have an iPhone 4 and i'm using it as a gophone. I added the 500mb data package feature. I then went on unlockit.co.nz and tried each of the APN settings but none of them work and I am unable to access my data service.

    Can anyone help me with this?

  2. #2
    Super Penguin Mod i.Annie's Avatar
    Join Date
    Jun 2009
    Location
    SW Ohio
    Posts
    16,907
    Thanks
    137
    Thanked 2,202 Times in 1,924 Posts

    The right one should be wap.cingular

    Make sure that's the one you have selected when going to unlockit.co.nz. Try network settings first, then installing the correct apn. To do this, go to settings, general, reset, network settings.

  3. #3
    What's Jailbreak?
    Join Date
    Sep 2011
    Posts
    6
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Thanks for replying so promptly to my dilemma.

    I tried the wap.cingular as the APN settings however this still didn't work, any ideas on what I could be doing wrong or leaving out?

  4. #4
    Super Penguin Mod i.Annie's Avatar
    Join Date
    Jun 2009
    Location
    SW Ohio
    Posts
    16,907
    Thanks
    137
    Thanked 2,202 Times in 1,924 Posts

    Did you do the network settings reset?

  5. #5
    What's Jailbreak?
    Join Date
    Sep 2011
    Posts
    6
    Thanks
    0
    Thanked 0 Times in 0 Posts

    yeah I did the network settings reset

  6. #6
    Super Penguin Mod i.Annie's Avatar
    Join Date
    Jun 2009
    Location
    SW Ohio
    Posts
    16,907
    Thanks
    137
    Thanked 2,202 Times in 1,924 Posts

    I did some research on old threads about this topic and it seems that there are mixed responses. So, I'm not sure what's going on.

    Do you have ultrasn0w installed (you shouldn't)?

    Does the phone make and receive calls?

    Have you tried accessing the internet without an APN installed?

    Is cellular data turned on?

  7. #7
    What's Jailbreak?
    Join Date
    Sep 2011
    Posts
    6
    Thanks
    0
    Thanked 0 Times in 0 Posts

    I don't have ultrasn0w but I do use the Gevey Ultra sim. The phone can make and receive calls etc. I just tried it without an APN installed and it didnt work and cellular data is turned on.

  8. #8
    Super Penguin Mod i.Annie's Avatar
    Join Date
    Jun 2009
    Location
    SW Ohio
    Posts
    16,907
    Thanks
    137
    Thanked 2,202 Times in 1,924 Posts

    You should probably take the Gevey SIM out

  9. #9
    What's Jailbreak?
    Join Date
    Jul 2009
    Posts
    5
    Thanks
    0
    Thanked 0 Times in 0 Posts

    I am having the same problem. I have an unlocked iPhone 3G running IOS 4.0, with a brand-new AT&T SIM card. I reset the APN using unlockit, but I still have no data connectivity without wifi (I can send and receive calls just fine). I don't have either of the extra things mentioned in prior posts installed. Have I done something wrong? Why would this workaround that seems to work for most people not work for me?

    Could AT&T have recently plugged this hole somehow? The posts I find online from people saying it doesn't work are mostly quite recent.

    Thanks for any suggestions!

  10. #10
    Super Penguin Mod i.Annie's Avatar
    Join Date
    Jun 2009
    Location
    SW Ohio
    Posts
    16,907
    Thanks
    137
    Thanked 2,202 Times in 1,924 Posts

    Take the unlock off of it.

  11. The Following User Says Thank You to i.Annie For This Useful Post:

    greengoddess (02-13-2013)

  12. #11
    What's Jailbreak?
    Join Date
    Jul 2009
    Posts
    5
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Quote Originally Posted by i.Annie View Post
    Take the unlock off of it.
    Thanks for the quick response. Turns out I of course did have Ultrasn0w, I just completely forgot since it was forever ago that I unlocked it. I uninstalled Ultrasn0w, and now my phone doesn't recognize the AT&T SIM card at all. No network connection beyond wifi. Essentially, it has become an iPod Touch.

    Any thoughts? I'd hate to have to do a complete restore.

    ----------------------------

    Edited to add: I just did a full restore (using my custom .ipsw file), and there is still no recognition of the AT&T SIM (it knows there is a card in there, but it does not show the AT&T signal). This is a disaster.
    Last edited by BerlinerNYC; 09-05-2011 at 03:24 PM.

  13. #12
    Super Penguin Mod i.Annie's Avatar
    Join Date
    Jun 2009
    Location
    SW Ohio
    Posts
    16,907
    Thanks
    137
    Thanked 2,202 Times in 1,924 Posts

    Is your phone locked to AT&T

  14. #13
    What's Jailbreak?
    Join Date
    Jul 2009
    Posts
    5
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Quote Originally Posted by i.Annie View Post
    Is your phone locked to AT&T
    No, my phone is jailbroken and unlocked. I was using an AT&T prepaid SIM card, which worked for everything but data. At your suggestion, I deleted Ultrasn0w, and now the phone has no connection at all and has apparently never heard of AT&T.

    --------------------------

    Update: I reinstalled Ultrasn0w, and it is now recognizing the AT&T connection again. Still no 3G data connection, but at least I have a working phone again. I guess I need to give up on data without wifi, because removing Ultrasn0w was a big mistake.
    Last edited by BerlinerNYC; 09-05-2011 at 04:31 PM.

  15. #14
    What's Jailbreak?
    Join Date
    Sep 2011
    Posts
    6
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Quote Originally Posted by i.Annie View Post
    You should probably take the Gevey SIM out
    I can't take the Gevey SIM out because I rely on it for an unlock. Also, I don't think that it is the Gevey Sim because when I was using a different carrier with different APN settings my data plan was working fine.

  16. #15
    Super Penguin Mod i.Annie's Avatar
    Join Date
    Jun 2009
    Location
    SW Ohio
    Posts
    16,907
    Thanks
    137
    Thanked 2,202 Times in 1,924 Posts

    Quote Originally Posted by BerlinerNYC View Post
    No, my phone is jailbroken and unlocked. I was using an AT&T prepaid SIM card, which worked for everything but data. At your suggestion, I deleted Ultrasn0w, and now the phone has no connection at all and has apparently never heard of AT&T.

    --------------------------

    Update: I reinstalled Ultrasn0w, and it is now recognizing the AT&T connection again. Still no 3G data connection, but at least I have a working phone again. I guess I need to give up on data without wifi, because removing Ultrasn0w was a big mistake.
    No I meant is the phones original carrier AT&T

    Quote Originally Posted by 09goddess View Post
    I can't take the Gevey SIM out because I rely on it for an unlock. Also, I don't think that it is the Gevey Sim because when I was using a different carrier with different APN settings my data plan was working fine.
    Why do you need to unlock if you're using AT&T? Is your iPhone 4 not originally locked to AT&T?

  17. #16
    What's Jailbreak?
    Join Date
    Sep 2011
    Posts
    6
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Why do you need to unlock if you're using AT&T? Is your iPhone 4 not originally locked to AT&T?[/QUOTE]
    Because i'm using the phone as a gophone and the iphone 4 will only work with AT&T contract plan

  18. #17
    What's Jailbreak?
    Join Date
    Jul 2009
    Posts
    5
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Quote Originally Posted by i.Annie View Post
    No I meant is the phones original carrier AT&T
    The phone's carrier was AT&T years ago when it was under contract and belonged to a friend of mine. When his contract was up, he upgraded to the iPhone 4 and gave me his old 3G, and I took it to Germany, jailbroke it, and unlocked it to use with a Deutsche Telekom SIM card. It worked fine there. Now I'm back in the US for a while and need a phone, so I'm using a prepaid AT&T SIM card. I would like data to work, but at least the phone is up and runnning as a phone again. I thought uninstalling Ultrasn0w might make it default back to AT&T somehow (is that written deep in the phone's memory somewhere?), but that clearly was not the case, since it wouldn't connect to AT&T.

  19. #18
    What's Jailbreak?
    Join Date
    Sep 2011
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    I have found my solution to this matter...
    I am on an iPhone 4 tethered 4.3.5 firmware but using redsn0w_win_0.9.8b4 with 4.3.4 firmware to DFU restart.
    Currently on GoPhone data plan 100MB.
    Recently i ran into the same 3G network problem with it not loading webpages and the only thing that works was Google.com
    To resolve this, I went ahead and removed from Setting>General>Profile... then went to unlockit.co.nz switched the APN from regular US - AT&T to "US - AT&T (wap.cingular)" because it states under this forum found here... AT&T Wireless- PDP and APN Types
    NEXT, I did a RESET NETWORK under my iphone. Setting>General>Reset>"Reset Network Setting"
    Once resetted, we MUST reboot, for me i have 4.3.5 tethered so i went ahead and did DFU got into redsn0w_win_0.9.8b4 with 4.3.4 firm and boot tethered now. Basically a hard reboot, not just respring.
    I got back into the iphone, turned on my 3G network for AT&T and cheers! i got my 3G network back
    The only small problem was... I have to re-add all of my WiFi

    This 3G not loading problem might have occurred recently because we switch the unlockit.co.nz settings somehow and forgot to reset network and reboot? or/and you could have added US - AT&T regular from unlockit.co.nz and it's been working but then it stopped.
    The problem if you followed moderator i.Annie, maybe it will not work if you Reset first, then change APN. Because basically you reset while you are on US-AT&T. My method was just the opposite... change APN first, then reset network.

    FYI, no Gevey is required for me. I'm on Prepay AT&T.
    My GF uses Gevey because she's with T-Mobile.
    Last edited by psyco4japan; 09-17-2011 at 09:13 PM. Reason: typo

  20. #19
    What's Jailbreak?
    Join Date
    Jul 2009
    Posts
    5
    Thanks
    0
    Thanked 0 Times in 0 Posts

    This did not work at all, after multiple tries. If you do a "Reset Network Settings," aren't you undoing the change you just made and reverting to the factory settings? In any case, it certainly didn't work, which meant I had to keep re-entering my (very long, very secure) wifi password to connect to the internet at all. I don't understand why the unlockit workaround isn't working with a jailbroken phone, when it seems to work for everyone else...

  21. #20
    What's Jailbreak?
    Join Date
    Sep 2011
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Not necessarily reset APN, but WiFi and everything else does go back to original factory settings. For me it works if I change APN to the correct one first, then reset network settings, then reboot at the end.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts