Mine won't go though since I updated it to 4.3.1