Results 1 to 5 of 5

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Loyal T-Mobile user with iPhone 4, iOS 5.1.1. No carrier update to get visual voicemail

  1. #1
    Question Loyal T-Mobile user with iPhone 4, iOS 5.1.1. No carrier update to get visual voicemail
    I'm a loyal T-Mobile customer, and I've been using unlocked iPhones on their network for years.

    I currently have an iPhone 4 which I bought a year ago used (it was from AT&T). It was out-of-contract so I got it factory unlocked via AT&T, so it's permanently unlocked. It works fine on T-Mobile and I've used other GSM networks in other countries and it worked fine. However, visual voicemail has never worked (it would just call the voicemail number, old-school).

    I was fine with this, until I learned that T-Mobile now sells the iPhone 4 as well as the 4S and 5. So why does visual voicemail work for those other iPhone 4 customers but not me?

    On Friday, the official launch date of the T-Mobile iPhone 5, I called T-Mobile to make sure I was on one of their brand-new data plans. But I still don't have visual voicemail, they said to wait until Tuesday. I called them again on the phone today (Tuesday) and they mentioned a "Carrier Update" that was supposed to be via Settings>General>About, which never appeared. They said to try updating via iTunes.

    Now I'm concerned. I have iOS 5.1.1 on purpose, specifically because I insist on having the original Maps app (I just like it better, I've tried the new Google and Apple iOS6 Maps and I don't like them).

    Is there a way to get this Carrier Update without giving up iOS 5.1.1?

    Any info appreciated.
    Thanks

  2. #2
    Goto settings
    Then general
    Then about
    Then the carrier update will automatically install. If this does not work then u have to update your iOS

  3. #3
    I said this in the original post: "they mentioned a "Carrier Update" that was supposed to be via Settings>General>About, which never appeared." The carrier update did *not* automatically install.

    So you're saying I have to update my iOS. Which iOS — the latest 6.1.3, the OS version where Apple made downgrading to iOS 5.1.1 impossible?

    Thanks for your reply but it did not answer my question.

  4. #4
    T-mobile carrier update supports iOS 6.1.x only. Apple iOS Software Overview: iPhone Support | T-Mobile

    Unfortunately, tmonews site is down; otherwise it would give clearer info

    http://www.tmonews.com/2013/04/carri...hone-5-models/

  5. #5
    ^ none of those options will work unless you're above 6.0 fw.
    anyways, to get the official ipcc from tmobile
    http://www.tmonews.com/2013/03/how-t...e-5-right-now/

    plug in the iphone, press-hold Shift (if on windows) and press restore, and select the ipcc file.
    reboot the iphone and all your settings will work just fine. you will lose personal hot spot but get tetherme app to enable native hotspot.

    i've tested this out on my old iphone 4 5.1.1 and it works fine.

    edit: here ya go, everything you need
    http://www.idownloadblog.com/2013/04...arrier-bundle/
    Last edited by nrgonline; 04-16-2013 at 09:16 PM.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •