+ Reply
Results 1 to 3 of 3

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: iPhone 3G 4.2.1 tmobile jailbreak help.

is a discussion within the

T-mobile

forums, a part of the

iPhone Modding

section;
First I'd like to sorry if this is wrong section, just started here so I have a iPhone 3G with baseband 5.15.04 and iOS 4.2.1 official firmware. For some odd
...
  1. #1
    What's Jailbreak?
    Join Date
    Sep 2012
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default iPhone 3G 4.2.1 tmobile jailbreak help.
    First I'd like to sorry if this is wrong section, just started here so I have a iPhone 3G with baseband 5.15.04 and iOS 4.2.1 official firmware. For some odd reason I can use tmobile with this baseband on official 4.2.1, which I know should not be. But whenever I jailbreak(install Cydia) it does not keep the setting that let's me use tmobile. I have tried sn0wbreeze baseband preservation, I've tried greenp0ison normal jb, I've tried redsn0w ipad baseband(6.15.00) but none of them work. They all install Cydia well, but redsn0w doesn't install the iPad baseband. So as far as I know I have tried everything! Can any please tell me the reason for any of this??? I have a new bootrom I believe. I am up to trying anything besides paying money because it would be a hassle to try to get money back from the fail jailbreak, I am up to Trying anything. I can tell u anything u need on request. Just recap I'm not jail broken at the moment. Thanks in advance

  2. #2
    iPhone? More like MyPhone
    Join Date
    Oct 2007
    Posts
    154
    Thanks
    6
    Thanked 14 Times in 12 Posts

    First of all there is no new or old bootrom with a 3g. Which version of redsnow are you using? You sure you downloaded the 3G firmware and not the 3GS?

    Im a little confused? Are you saying the phone works with tmobile before cydia but not after?

    Anyways, where are you erroring out at? At the updating baseband step? Do it in two separate steps. Jailbreak first (just select install cydia) and then run redsnow again and only select install ipad baseband.

  3. #3
    Superbad Modder-ator Simon's Avatar
    Join Date
    Nov 2007
    Location
    Bermuda
    Posts
    46,270
    Thanks
    6,647
    Thanked 14,866 Times in 6,897 Posts

    If it is working on 4.2.1 with 5.15.04 baseband then the phone is factory unlocked. Do not install the iPad baseband. And when jail breaking make sure the phone is activated and working properly first. Do not use snowbreeze or any other custom firmware. No need on a factory unlocked phone.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts