Results 1 to 10 of 10

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Help to enable Cellular Data network - iphone4 ver4.2.1

  1. #1
    Default Help to enable Cellular Data network - iphone4 ver4.2.1
    after jb/unlock the iphone 4 version 4.2.1, the cellular data network, where you enter wap.tmobile for EDGE is missing. I try most every method that I can find on the net but no luck at all. Anyone please help

  2. #2
    iPhoneaholic reddawg's Avatar
    Join Date
    Sep 2008
    Location
    Massachusetts, USA
    Posts
    430
    Thanks
    39
    Thanked 71 Times in 59 Posts

    Try "Reset Network Settings" and reboot. If that doesn't work, try:

    1. Open Cydia
    2. Goto Manage -> Sources
    3. Add source for: cydia.pushfix.info
    4. Install "Carrier Reset fix"
    5. Remove sim, re-insert....voila! your network settings should be back!

    If this doesn't fix your problem, then post what jailbreak software (PwnageTool, Sn0wbreez, Greenpois0n) you used jailbreak your iPhone 4 and what baseband you are running.
    "When I die, I want to go peacefully in my sleep like my grandfather did...not kicking and screaming like the passengers in his car." -- Unknown

  3. #3
    iPhone? More like MyPhone MoDaLoT's Avatar
    Join Date
    Mar 2011
    Location
    Iowa
    Posts
    163
    Thanks
    12
    Thanked 10 Times in 9 Posts

    Quote Originally Posted by reddawg View Post
    Try "Reset Network Settings" and reboot. If that doesn't work, try:

    1. Open Cydia
    2. Goto Manage -> Sources
    3. Add source for: cydia.pushfix.info
    4. Install "Carrier Reset fix"
    5. Remove sim, re-insert....voila! your network settings should be back!

    If this doesn't fix your problem, then post what jailbreak software (PwnageTool, Sn0wbreez, Greenpois0n) you used jailbreak your iPhone 4 and what baseband you are running.
    Be care full :Reset Network Settings: it took my FaceTime icon away in the phone settings.

  4. #4
    I am using Mac Pwnage tool to JB from 4.0.1 to 4.2.1 and unlocked with Ultralsn0w.Basebase 01.59.00. Everything works fine accept for the option APN where i can go in there to put info. in for t-zone EDGE is missing. When I tap on NETWORK from setting, it took like 45 second to display the menu in there but there is no APN option.
    when I do Pwnage tool to JB, I have the ATT sim in there. is this a problem then ?

    Originally Posted by reddawg
    Try "Reset Network Settings" and reboot. If that doesn't work, try:

    1. Open Cydia
    2. Goto Manage -> Sources
    3. Add source for: cydia.pushfix.info
    4. Install "Carrier Reset fix"
    5. Remove sim, re-insert....voila! your network settings should be back!

    If this doesn't fix your problem, then post what jailbreak software (PwnageTool, Sn0wbreez, Greenpois0n) you used jailbreak your iPhone 4 and what baseband you are running.
    I did what you said. went into network, here what in there
    Enable 3r OFF
    Cellular Data ON
    Data Roaming OFF
    Internet Tetering OFF
    VPN Not connected
    WI-Fi Hamster
    Last edited by vietkool; 03-11-2011 at 08:35 AM.

  5. #5
    iPhoneaholic reddawg's Avatar
    Join Date
    Sep 2008
    Location
    Massachusetts, USA
    Posts
    430
    Thanks
    39
    Thanked 71 Times in 59 Posts

    Quote Originally Posted by MoDaLoT View Post
    Be care full :Reset Network Settings: it took my FaceTime icon away in the phone settings.
    I believe you are thinking of "Reset All Settings". "Reset Network Settings" is quite safe.

    Quote Originally Posted by vietkool View Post
    I am using Mac Pwnage tool to JB from 4.0.1 to 4.2.1 and unlocked with Ultralsn0w.Basebase 01.59.00. Everything works fine accept for the option APN where i can go in there to put info. in for t-zone EDGE is missing. When I tap on NETWORK from setting, it took like 45 second to display the menu in there but there is no APN option.
    when I do Pwnage tool to JB, I have the ATT sim in there. is this a problem then ?
    When you created your custom firmware in PwnageTool, did you select or unselect 'Activate the phone'? I assume you were using the AT&T SIM card to activate your iPhone 4 in iTunes and not hacktivate using PwnageTool. This is always the best method because it does not break "Push Notifications". For unlocking carriers here are the two methods:

    Method 1: Activation in iTunes
    1) Create a custom firmware and make sure 'Activate the phone' is not selected.
    2) Restore custom firmware in iTunes.
    3) Activate your iPhone 4 using iTunes and set up your iPhone 4 as a Brand New Phone, not from backup.
    4) Remove the AT&T SIM card
    5) Run Cydia for 1st time and update "Essential packages" and select “User (Graphical Only)” when prompted "Who you are".
    6) In Cydia, install the following "OpenSSH", "SBSettings" and "Ultrasn0w".
    7) Turn off "Enable 3G".
    8) Insert "T-Mobile" SIM or non-official carrier SIM.

    Method 2: Hacktivation in PwnageTool
    1) Create a custom firmware and make sure 'Activate the phone' is selected.
    2) Restore custom firmware in iTunes.
    3) Set up your iPhone 4 as a Brand New Phone, not from backup.
    4) Remove the AT&T SIM card
    5) Run Cydia for 1st time and update "Essential packages" and select “User (Graphical Only)” when prompted "Who you are".
    6) In Cydia, install the following "OpenSSH", "SBSettings" and "Ultrasn0w".
    7) Turn off "Enable 3G".
    8) Insert "T-Mobile" SIM or non-official carrier SIM.


    Quote Originally Posted by vietkool
    I did what you said. went into network, here what in there
    Enable 3G OFF
    Cellular Data ON
    Data Roaming OFF
    Internet Tetering OFF
    VPN Not connected
    WI-Fi Hamster
    These look fine.
    Last edited by reddawg; 03-11-2011 at 12:06 PM.
    "When I die, I want to go peacefully in my sleep like my grandfather did...not kicking and screaming like the passengers in his car." -- Unknown


  6. #6
    I dont remember which method I use but I remember I did select "activate the phone" before it created the customer iswp, then after that the pwnage tool do the rest. All I have to do is follow what the tool say.
    What I just foud out is I turn off the wi-fi. then open apple store to install facebook and yahoo apps. it downloads and install the apps . so It's seem like the t-zone info. was embedded some how in the fone already. The only down side is the phone doesnt show the option "Celluar data network" so I can not go there to change t-zone info.
    Do you think I should JB again with pwnage tool using method 1 ?

  7. #7
    iPhoneaholic reddawg's Avatar
    Join Date
    Sep 2008
    Location
    Massachusetts, USA
    Posts
    430
    Thanks
    39
    Thanked 71 Times in 59 Posts

    Quote Originally Posted by vietkool View Post
    I dont remember which method I use but I remember I did select "activate the phone" before it created the custom iswp, then after that the pwnage tool do the rest. All I have to do is follow what the tool say.

    Do you think I should JB again with pwnage tool using method 1 ?
    I would jailbreak again using method 1. I have attached a PDF document that outlines the steps in much greater detail.

    HowTo Jailbreak an iPhone 4 using Custom 4.2.1 Firmware & Unlock for T-Mobile USA.pdf

    Here is a PwnageTool guide that shows how to create a custom firmware in Expert Mode.

    How to Jailbreak iPhone 4 to 4.2.1 with PwnageTool.pdf
    "When I die, I want to go peacefully in my sleep like my grandfather did...not kicking and screaming like the passengers in his car." -- Unknown

  8. #8
    thanks for those info. very helpful. I am kindda scare abit if I jb again and the "cellular data network" tab won't show then I don't know how to enter the t-zone info.
    I restore and jb again everything seem to be ok but the set up on t-zone using ecp.tmbile.com seem to be slower than wap.voicestreams.com. Do you have a copmplete setup info for wap.voicestreams.com ?
    Last edited by vietkool; 03-11-2011 at 10:01 PM.

  9. #9
    usually I stay at the network tab in settings, and pull the sim out and put it back in, maybe a couple times, but the cell data tab will pop up.

    and its epc.tmobile.com

  10. #10
    thanks for comment. Finally I did a jb again then using the att SIM to activated and pop in T-mobile in, then I saw the "cellular data network" tab now. Test emais, text, browser are working good now. Haven't try the mms yet. Hopefully it works.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •