+ Reply
Page 1 of 2 12 LastLast
Results 1 to 20 of 24

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Mms fix, iPhone 4 4.2.1

is a discussion within the

T-mobile

forums, a part of the

iPhone Modding

section;
I have an iPhone 4 j/b and unlocked. I've installed the t mobile mms fix for iOS 4 from Cydia.pushfix. The camera button shows up in messages, but it never
...
  1. #1
    Green Apple
    Join Date
    Jun 2010
    Posts
    43
    Thanks
    10
    Thanked 4 Times in 2 Posts

    Default Mms fix, iPhone 4 4.2.1
    I have an iPhone 4 j/b and unlocked. I've installed the t mobile mms fix for iOS 4 from Cydia.pushfix. The camera button shows up in messages, but it never sends the messages. The progress bar gets almost to the end, but can't finish. I've searched all over looking for a similar situation. I've even tried the mms iOS 4 fix from sinfuliphonerepo. Same result. Tried removing each package, reinstalling. Rebooting several times. Hopefully im just missing something. Please help.

  2. #2
    iPhone? More like MyPhone
    Join Date
    Jul 2009
    Location
    seattle
    Posts
    113
    Thanks
    2
    Thanked 8 Times in 8 Posts

    Quote Originally Posted by mmracing1981 View Post
    I have an iPhone 4 j/b and unlocked. I've installed the t mobile mms fix for iOS 4 from Cydia.pushfix. The camera button shows up in messages, but it never sends the messages. The progress bar gets almost to the end, but can't finish. I've searched all over looking for a similar situation. I've even tried the mms iOS 4 fix from sinfuliphonerepo. Same result. Tried removing each package, reinstalling. Rebooting several times. Hopefully im just missing something. Please help.
    after you install the tmobie mms fix from pushfix you have to go to setting>general>network>celluar data> under mms APN: try wap.voicestream.com or epc.tmobile.com.reboot your phone each time you change.

  3. #3
    Green Apple
    Join Date
    Jun 2010
    Posts
    43
    Thanks
    10
    Thanked 4 Times in 2 Posts

    Quote Originally Posted by vimm View Post
    after you install the tmobie mms fix from pushfix you have to go to setting>general>network>celluar data> under mms APN: try wap.voicestream.com or epc.tmobile.com.reboot your phone each time you change.
    I deleted the sinfulniphone mms fix, rebooted. Downloaded pushfix mms fix, rebooted. Tried epc.Tmobile.com: no luck. Changed APN to wap.voicestream.com and rebooted. Still no luck. Progress bar gets stuck right near the end when (I assume) it is actually sending the message. So it mus be one of those settings. My wife's 3GS works with wap.voicestream.com and my 3GS worked with it also. Any other ideas? I guess I could try restoring as new. I just really hate doing that.

  4. #4
    iPhone? More like MyPhone
    Join Date
    Jul 2009
    Location
    seattle
    Posts
    113
    Thanks
    2
    Thanked 8 Times in 8 Posts

    try reset fist and reboot.Reboot using power butt to turn off/on.

  5. The Following User Says Thank You to vimm For This Useful Post:

    mmracing1981 (01-30-2011)

  6. #5
    iPhone? More like MyPhone
    Join Date
    Oct 2007
    Posts
    154
    Thanks
    6
    Thanked 14 Times in 12 Posts

    You need to patch your commcenter

  7. #6
    Green Apple
    Join Date
    Jun 2010
    Posts
    43
    Thanks
    10
    Thanked 4 Times in 2 Posts

    I have no idea how to patch a comm center. Can you explain?

  8. #7
    iPhone? More like MyPhone
    Join Date
    Oct 2007
    Posts
    154
    Thanks
    6
    Thanked 14 Times in 12 Posts


  9. The Following User Says Thank You to k1653d For This Useful Post:

    mmracing1981 (01-30-2011)

  10. #8
    Green Apple
    Join Date
    Jun 2010
    Posts
    43
    Thanks
    10
    Thanked 4 Times in 2 Posts

    Quote Originally Posted by k1653d View Post
    Thanks for the link. It looks like that will solve my problem, but the carrier bundle link page is down right now, will try back later.

    As for searching, I am beginning to think there is something wrong with the way i search for things in this forum. No matter what i search for, it always returns 0 results. I ALWAYS search for an answer to my problems on several forums and with google before I post a question. I'm just glad you found this thread and could help me out with an answer. I couldnt find it anywhere else.

  11. #9
    iPhone? More like MyPhone
    Join Date
    Jul 2009
    Location
    Nashville, TN
    Posts
    232
    Thanks
    7
    Thanked 14 Times in 14 Posts

    You have an iPhone 4 unlocked on 4.2.1? Uh...how?

  12. #10
    Green Apple
    Join Date
    Jun 2010
    Posts
    43
    Thanks
    10
    Thanked 4 Times in 2 Posts

    Quote Originally Posted by ThaNatrix View Post
    You have an iPhone 4 unlocked on 4.2.1? Uh...how?
    It was on 4.0, i made a custom fw to preserve the 1.59.00 baseband. I was forced into it because i didnt have shsh's saves for 4.0.

  13. #11
    iPhone? More like MyPhone
    Join Date
    Jul 2009
    Location
    Nashville, TN
    Posts
    232
    Thanks
    7
    Thanked 14 Times in 14 Posts

    I didn't think the baseband could be preserved in 4.2.1, even with Pwnage or Tiny Umbrella?

  14. #12
    Green Apple
    Join Date
    Jun 2010
    Posts
    43
    Thanks
    10
    Thanked 4 Times in 2 Posts

    Quote Originally Posted by ThaNatrix View Post
    I didn't think the baseband could be preserved in 4.2.1, even with Pwnage or Tiny Umbrella?
    I used the latest pwnage tool. Used a custom fw bundle i found here on modmyi. It was simple.

  15. #13
    Green Apple
    Join Date
    Nov 2009
    Posts
    87
    Thanks
    2
    Thanked 10 Times in 5 Posts

    +1 confirmed it works for me too (4.2.1) sometimes I have to reboot 3-5 times for service though.

  16. #14
    What's Jailbreak?
    Join Date
    Oct 2007
    Posts
    12
    Thanks
    2
    Thanked 0 Times in 0 Posts

    How do you activate without an at&t sim?

  17. #15
    iPhone? More like MyPhone
    Join Date
    Jul 2009
    Location
    Nashville, TN
    Posts
    232
    Thanks
    7
    Thanked 14 Times in 14 Posts

    Quote Originally Posted by karl184 View Post
    How do you activate without an at&t sim?
    Jailbreaking it with Greenpois0n should do the trick...worked on my bro n law's 3gs.

  18. #16
    What's Jailbreak?
    Join Date
    Jul 2010
    Location
    florida
    Posts
    13
    Thanks
    1
    Thanked 1 Time in 1 Post
    Here is my situation... I finally got an iPhone 4 on 4.0.2 and jailbroke it using limra1n. I have an unlimited talk and text plan and I have an unlimited webtogo data plan. I originally tried the usual mms fixes like the pushfix tmobile IOs 4.0 fix with no luck and I did try typing in the various APN settings but with very little success and I did reboot everytime. So , finally I did the commcenter patch and now my I have Internet and I can send and receive text messages but I can't send picture messages. When I send them the progress bar gies to the very end and it doesn't go through. So I'm at a wall like yourself . I have tried installing the pushfix tmobile fix on top of the commcenter patch but it just messes everything up. So please don't suggest or try it because you will have to start over. I would also like to add that I can receive picture messages but it sometimes takes 2-3 hours to go through before I actually get it.. So until we can find a solution for this I guess I have a phone that takes great pictures but I can't share them with anyone unless I email them..I have been searching for days through countless threads on various forums and have come up with no fix..

  19. #17
    Green Apple
    Join Date
    Dec 2010
    Posts
    77
    Thanks
    0
    Thanked 10 Times in 9 Posts

    I've had this problem before, i4 on 4.0.2, same as you.

    Follow the instructions on here:

    T-Mobile USA Carrier Bundles - 140 Characters Are Not Enough

    This fixed my MMS + EDGE, It'll fix yours too.

  20. #18
    Green Apple
    Join Date
    Sep 2007
    Posts
    51
    Thanks
    5
    Thanked 4 Times in 3 Posts

    im too have iphone 4 4.2.1 firmware baseband 1.59

    and sometimes mms works and sometimes doesnt.

    facetime for me works.

    edge is iffy as well..

    i have wap in the cell data part
    and i have epc in the mms part

    i might just go back down to 4.1 where it was doing fine...


    EDIT....i think i know mine wasnt sending...

    i was sending HDR quality pics...they are like 3-4megs each i believe...so i changed my photo settings to save both reg and hdr and i just test sent one to myself and it went through!!
    Last edited by madehtsobi; 02-17-2011 at 04:00 PM.

  21. #19
    What's Jailbreak?
    Join Date
    Jul 2010
    Location
    florida
    Posts
    13
    Thanks
    1
    Thanked 1 Time in 1 Post
    Quote Originally Posted by madehtsobi View Post
    im too have iphone 4 4.2.1 firmware baseband 1.59

    and sometimes mms works and sometimes doesnt.

    facetime for me works.

    edge is iffy as well..

    i have wap in the cell data part
    and i have epc in the mms part

    i might just go back down to 4.1 where it was doing fine...


    EDIT....i think i know mine wasnt sending...

    i was sending HDR quality pics...they are like 3-4megs each i believe...so i changed my photo settings to save both reg and hdr and i just test sent one to myself and it went through!!
    How did you get FaceTime to work? And how do you change the camera settings?

  22. #20
    Green Apple
    Join Date
    Sep 2007
    Posts
    51
    Thanks
    5
    Thanked 4 Times in 3 Posts

    Quote Originally Posted by johnee View Post
    How did you get FaceTime to work? And how do you change the camera settings?
    facetime has to be working back on 4.0 i believe and when you run facetime it say will firmware restore will be OK...

    camera settings are in your settings/photos part.

    so yeh its been a few days now and mms still sometimes work sometimes doesn't...

    very weird!!!!!

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts