+ Reply
Results 1 to 7 of 7

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Tmobile unlock issue? HELP!!!

is a discussion within the

T-mobile

forums, a part of the

iPhone Modding

section;
hey all, so i have jailbroken and unlocked my iphone 3g 4.0 but when i put the new tmobile sim card in all it does is say no service i
...
  1. #1
    What's Jailbreak?
    Join Date
    Oct 2010
    Posts
    3
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Unhappy Tmobile unlock issue? HELP!!!
    hey all,

    so i have jailbroken and unlocked my iphone 3g 4.0
    but when i put the new tmobile sim card in all it does is say no service i called tmobile and they say i have service its just not showing up on the iphone, i have tried everything i erased the phone 3 times and jailbroken it and unlocked it 3 times,idk what the problem is i cant figure it out, although when i put the tmobile sim in the first time it keeps telling me i have a voicemail, so idk if its recognizing the sim and theres just some stoopid thing blocking it from giving me all the service or what idk, i don't have a cell right now because of this so im going crazy! please please if u can help me it would be greatly appreciated!


    Thank You Thank You!

  2. #2
    iPhone? More like MyPhone
    Join Date
    Sep 2010
    Posts
    201
    Thanks
    17
    Thanked 12 Times in 11 Posts

    Maybe you sim card is bad

  3. #3
    What's Jailbreak?
    Join Date
    Oct 2010
    Posts
    3
    Thanks
    0
    Thanked 0 Times in 0 Posts

    yea idk im goin to the tmobile store in a bit to find out if it is..if it isnt then idk whats goin on

    thanks

  4. #4
    Green Apple wing103's Avatar
    Join Date
    May 2009
    Location
    Boston MA
    Posts
    97
    Thanks
    3
    Thanked 4 Times in 4 Posts

    did you turn off 3g under setting?
    what software you use for jailbreak & unlock?

  5. #5
    What's Jailbreak?
    Join Date
    Oct 2010
    Posts
    3
    Thanks
    0
    Thanked 0 Times in 0 Posts

    hey thanks for the help...but i just gave in and got at&t service...i couldnt figure out the whole unlock tmobile thing...

    cheers

  6. #6
    iPhoneaholic dotFIVE's Avatar
    Join Date
    Sep 2010
    Location
    California
    Posts
    494
    Thanks
    9
    Thanked 82 Times in 79 Posts

    Sometimes it will show up as no service and all you have to do is reboot your phone via SBSettings and it should recognize the T-Mobile SIM and give you service. I get No Service sometimes and a reboot does the trick. Not sure if this would've solved your problem but hopefully this may help someone else.

  7. #7
    iPhone? More like MyPhone Rinnycoop121's Avatar
    Join Date
    May 2008
    Location
    Texas
    Posts
    278
    Thanks
    26
    Thanked 24 Times in 18 Posts

    i would say it the 3g was active that is why no service

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts