Page 1 of 2 12 LastLast
Results 1 to 20 of 22

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: i4 Data/MMS issue unless SIM is removed and inserted again after reboot

  1. #1
    Default i4 Data/MMS issue unless SIM is removed and inserted again after reboot
    Anyone face this issue where after a reboot Data/MMS stops working unless you remove and then insert the SIM from the phone and then it works again? After that everything works I try and avoid rebooting but it would be nice if it just worked after a reboot. I am currently using a patched commcenter and tmobile carrier bundle

    iPhone 4 (ultrasn0w 1.1.1)
    Data APN - internet2.voicestream.com
    MMS APN - wap.voicestream.com
    MMSC http://216.155.174.84/servlets/mms

    Curious if anyone has this same issue and has worked it out?
    Last edited by alpineflip; 08-18-2010 at 05:18 PM.

  2. #2
    At one time I didn't have this issue but after I upgraded ultrasnow to 1.0.1 it came about where I had to reinsert the sim to fix it but i havnt looked at it much since.

  3. #3
    iPhone? More like MyPhone mindblown's Avatar
    Join Date
    Jun 2010
    Location
    HAWAII
    Posts
    258
    Thanks
    9
    Thanked 11 Times in 11 Posts

    get a new sim card, it helped for me
    i had the similar situation but it was about the unlock not working after turning off the phone and turning it back on. i had to reboot couple of times and reinsert the sim card (I had an old sim card at that time) i also had the mms settings and data settings installed from the tmobile mms fix package from cydia but i couldnt receive or send mms (also had old sim card at that time), i left those settings alone and didn't change anything, so i went to tmobile and ask them for a new sim card, got it, made it to a micro sim, inserted it my iphone and everything works (mms and Data).

    ohh btw, i didn't patch my commcenter nor add a carrier bundle
    Last edited by mindblown; 08-18-2010 at 06:18 PM.

  4. #4
    Do u guys need to have Edge/Data on to receive and send a MMS? thats my problem.

  5. #5
    Quote Originally Posted by mindblown View Post
    get a new sim card, it helped for me
    i had the similar situation but it was about the unlock not working after turning off the phone and turning it back on. i had to reboot couple of times and reinsert the sim card (I had an old sim card at that time) i also had the mms settings and data settings installed from the tmobile mms fix package from cydia but i couldnt receive or send mms (also had old sim card at that time), i left those settings alone and didn't change anything, so i went to tmobile and ask them for a new sim card, got it, made it to a micro sim, inserted it my iphone and everything works (mms and Data).

    ohh btw, i didn't patch my commcenter nor add a carrier bundle
    I have considered the new SIM, mine is only a year or two old but it could possibly help, so after reboots you have no issues Data/MMS works right away? As far as the no signal after a few reboots I have the same issue but I think that's an ultrasn0w problem, doesn't happen often but I did experience it. I will go get a new sim and give it a shot

    Quote Originally Posted by NYzJatt View Post
    Do u guys need to have Edge/Data on to receive and send a MMS? thats my problem.
    I don't think so sense it has its own apn settings but it does work everyone has a different working solution though :/

  6. #6
    Well my apn settings are the following:
    Cellular Data:
    Nothing for all of them

    MMS:
    APN: wap.voicestream.com
    MMSC: http://mms.msg.eng.t-mobile.com/mms/wapenc
    MMS Proxy: 216.155.165.50:8080
    MMS Max Message Size: 1048576
    MMS UA Prof URL: http://www.apple.com/mms/uaprof.rdf

    Btw my edge works fine and im on the smartphone plan.

  7. #7
    Quote Originally Posted by NYzJatt View Post
    Well my apn settings are the following:
    Cellular Data:
    Nothing for all of them

    MMS:
    APN: wap.voicestream.com
    MMSC: http://mms.msg.eng.t-mobile.com/mms/wapenc
    MMS Proxy: 216.155.165.50:8080
    MMS Max Message Size: 1048576
    MMS UA Prof URL: http://www.apple.com/mms/uaprof.rdf

    Btw my edge works fine and im on the smartphone plan.
    This is what I use


    MMS: wap.voicestream.com
    MMSC: http://216.155.174.84/servlets/mms
    MaxMessageSize: 1048576
    Proxy: 216.155.165.50:8080

    It works for me plus Data except after every reboot I have to eject the sim and then put it back

  8. #8
    iPhone? More like MyPhone mindblown's Avatar
    Join Date
    Jun 2010
    Location
    HAWAII
    Posts
    258
    Thanks
    9
    Thanked 11 Times in 11 Posts

    Quote Originally Posted by alpineflip View Post
    I have considered the new SIM, mine is only a year or two old but it could possibly help, so after reboots you have no issues Data/MMS works right away? As far as the no signal after a few reboots I have the same issue but I think that's an ultrasn0w problem, doesn't happen often but I did experience it. I will go get a new sim and give it a shot



    I don't think so sense it has its own apn settings but it does work everyone has a different working solution though :/
    yes, after the reboots theres no issues with data/mms and also the unlock, they work right away. i also have the same apn settings as NYzJatt and they work for me

  9. #9
    Quote Originally Posted by mindblown View Post
    yes, after the reboots theres no issues with data/mms and also the unlock, they work right away. i also have the same apn settings as NYzJatt and they work for me
    Cool I will head over to Tmobile tomorrow and get a new sim can't hurt Thanks for the info

  10. #10
    iPhone? More like MyPhone mindblown's Avatar
    Join Date
    Jun 2010
    Location
    HAWAII
    Posts
    258
    Thanks
    9
    Thanked 11 Times in 11 Posts

    no problem, it doesnt hurt to try lol
    btw make sure you cut the sim good


    now all i need is facetime then im good to go
    however waiting patiently for it, im not in a rush haha
    Last edited by mindblown; 08-19-2010 at 12:12 AM.

  11. The Following User Says Thank You to mindblown For This Useful Post:

    alpineflip (08-19-2010)

  12. #11
    Quote Originally Posted by mindblown View Post
    no problem, it doesnt hurt to try lol
    btw make sure you cut the sim good


    now all i need is facetime then im good to go
    however waiting patiently for it, im not in a rush haha
    Heading over to Tmobile today I'll repost how a new sim works out

  13. #12
    Quote Originally Posted by mindblown View Post
    yes, after the reboots theres no issues with data/mms and also the unlock, they work right away. i also have the same apn settings as NYzJatt and they work for me
    Do you need Data/Edge on for MMS to work? This is the only thing bugging me.

  14. #13
    Quote Originally Posted by mindblown View Post
    no problem, it doesnt hurt to try lol
    btw make sure you cut the sim good


    now all i need is facetime then im good to go
    however waiting patiently for it, im not in a rush haha
    Thanks for the tip about a new sim, just got back from Tmobile and I no longer have to pull the sim out after reboots, they actually had sims that had the same chip size as the ATT just had to cut it but I already have a SIM cutter and bam Data/MMS works everytime on reboots without having to take the SIM out.


    Quote Originally Posted by NYzJatt View Post
    Do you need Data/Edge on for MMS to work? This is the only thing bugging me.
    No my friend doesn't have Data and can still receive MMS, data is not required it has it's own apn
    Last edited by alpineflip; 08-19-2010 at 04:48 PM.

  15. #14
    What fixes and apn settings does your friend have?

  16. #15
    Quote Originally Posted by NYzJatt View Post
    What fixes and apn settings does your friend have?
    He uses the same APN settings as me in the first post and I think he uses the mms override preference mod, he manually did it, I use the carrier bundle but in the end you we both have the same settings

  17. #16
    Which carrier bundle is it???

    Oh and did you install the commcenter patch from cydia? if so can you tell me the repo, cant find it anymore.

  18. #17
    Quote Originally Posted by NYzJatt View Post
    Do you need Data/Edge on for MMS to work? This is the only thing bugging me.
    you need it on i think, but you dont have to have a plan

  19. #18
    Quote Originally Posted by cybereclipse View Post
    you need it on i think, but you dont have to have a plan
    The reason I don't want it on is because I think it drains battery

  20. #19
    Quote Originally Posted by NYzJatt View Post
    The reason I don't want it on is because I think it drains battery
    Data doesn't drain battery, it only runs when you start using it. Also if you are on an i4 turn off FaceTime which will prevent it from constantly trying to activate until a working solutions comes about like Pushfix's fix

    Quote Originally Posted by NYzJatt View Post
    Which carrier bundle is it???

    Oh and did you install the commcenter patch from cydia? if so can you tell me the repo, cant find it anymore.
    I used wortels commcenter patch or you can buy TehterMe for $2 on cydia, wortels patch is not in cydia you can google for the link though and for the carrier bundle if you look at one of the Sticky Threads in this Section Titled: T-Mobile USA Carrier Bundles: Bluetooth, Internet, MMS, & Tethering (2G/3G/3GS/4) you will see 2 download links for iOS3 and 4 bundles
    Last edited by alpineflip; 08-19-2010 at 05:58 PM. Reason: Automerged Doublepost

  21. The Following User Says Thank You to alpineflip For This Useful Post:

    NYzJatt (08-19-2010)

  22. #20
    I tried it with TetherMe and the tmobile legacy bundle but still i got the same result, i have to have edge on.

Page 1 of 2 12 LastLast
Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •