+ Reply
Results 1 to 6 of 6

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: iPhone 4 MMS doesnt work tried everything!

is a discussion within the

T-mobile

forums, a part of the

iPhone Modding

section;
Hey guys I got an iphone which was activated with at&t and was running the carrier settings at&t 7.0 with ios 4.0.1 I used jailbreakme.com to jailbreak Installed ultrasn0w 1.1-1
...
  1. #1
    What's Jailbreak?
    Join Date
    May 2009
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default iPhone 4 MMS doesnt work tried everything!
    Hey guys I got an iphone which was activated with at&t and was running the carrier settings at&t 7.0 with ios 4.0.1

    I used jailbreakme.com to jailbreak
    Installed ultrasn0w 1.1-1
    Reset network settings
    Installed the wortel.deb patch for commcenter (via SSH with WinSCP used putty to run the deb file)
    installed carrier settings for T-mobile 7.0

    Edge works great but no MMS, no Cellular Data Network tab

    I installed Tmobile mms fix from pushfix.info, didnt work, uninstalled it and installed mms fix from sinful repo that didnt work either, I also tried the beta.leimobile repo and the mms fix there but to no avail.

    I have no clue why MMS is not working or the Cellular Data Network is not showing up. I dont know what else to try.

    Any help will be appreciated, thanks!
    Last edited by scyphus; 08-17-2010 at 10:13 PM.

  2. #2
    My iPhone is a Part of Me
    Join Date
    Mar 2008
    Posts
    850
    Thanks
    12
    Thanked 85 Times in 85 Posts

    To get the tab to show up, just download supreme preferences 3.0. Make sure it's 3.0, the other ones won't work. It's on cydia

  3. #3
    iPhone? More like MyPhone
    Join Date
    Oct 2007
    Posts
    154
    Thanks
    6
    Thanked 14 Times in 12 Posts

    I did the same thing and installed all the fixes from all those different repos. Your carrier file is probably messed up by now.

    Restore, jailbreak, unlock, wortel.deb patch for commcenter, update carrier setting with spooky's carrier bundle. Thats it.

    If the mms doesnt work take out the sim card and put it back in. If that doesnt work reboot the phone, take out the sim card and put it back in.

  4. #4
    iPhone? More like MyPhone
    Join Date
    Oct 2007
    Posts
    122
    Thanks
    1
    Thanked 19 Times in 17 Posts

    Quote Originally Posted by k1653d View Post
    I did the same thing and installed all the fixes from all those different repos. Your carrier file is probably messed up by now.

    Restore, jailbreak, unlock, wortel.deb patch for commcenter, update carrier setting with spooky's carrier bundle. Thats it.

    If the mms doesnt work take out the sim card and put it back in. If that doesnt work reboot the phone, take out the sim card and put it back in.
    This. You patched commcenter and overwrote the ipcc. Then used the mms override three times over. Something got mucked up along the way.

  5. #5
    What's Jailbreak?
    Join Date
    May 2009
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    thanks for all your replies you all are a great help, i will try the supreme preferences if that doesnt work then i have no choice but to restore and start over, i fear that if i restore and start over, then when i sync will it carry over all those settings along with the apps and mess up the ipcc again?

    I will post my findings here!
    ps. once i use supreme preferences to show the tab, can i uninstall it or will i have to keep it to keep the tab visible?

    also if i try to restore it would make me restore it to 4.0.2 correct? and that patched the jailbreakme vulnerability right?

    thanks again!
    Last edited by scyphus; 08-18-2010 at 06:41 PM.

  6. #6
    My iPhone is a Part of Me
    Join Date
    Mar 2008
    Posts
    850
    Thanks
    12
    Thanked 85 Times in 85 Posts

    I'm pretty sure you can uninstall supreme preferences once you enable it, try it out, if it doesn't work just install it again. Use tiny umbrella to back up ur shsh, then run TSS server to shift restore to 4.0.1. There Should be instructions on this all over google.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts