Results 1 to 6 of 6

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: 10$ Data Plan not working for IOS4?

  1. #1
    Default 10$ Data Plan not working for IOS4?
    Hi,
    I had the 10$ data plan from tmobile. Never had an issue before, but since i updated to IOS4, when i go on safari its telling me that i need to upgrade to the 30 dollar plan because my device isnt compatible with the 10 dollar plan. Does anyone have a solution to this. Is there something I need to do? any help would be greatly appreciated.

  2. #2
    Livin the iPhone Life adp's Avatar
    Join Date
    Jan 2009
    Location
    South FL
    Posts
    1,789
    Thanks
    32
    Thanked 460 Times in 321 Posts

    Make sure your APN is internet2.voicestream.com
    If I helped you out, please use the Thanks button ------------------------->

  3. #3
    Did tmobile tells you that you need to get the $30 data plan?
    Everytime I make a call to tmobile customer service I put my sim card on a tmobile phone first so they would not know that I'm using iPhone.

  4. #4
    Like adp said, make sure your APN for Cellular Data is internet2.voicestream.com

    One thing that I have though, is that on T-Mobile in order for me to even GET the $10 plan I had to change my phone into an older cell. I used to use the RIZR Z3 so i switched it to that, then I got the $10 plan available, and been using it fine ever since.
    iPhone 32GB 3GS - iOS 4.2.1 - BB: 5.11.07
    iPhone 16GB 3G - 3.1.3 - BB: 4.28.08

  5. #5
    Livin the iPhone Life adp's Avatar
    Join Date
    Jan 2009
    Location
    South FL
    Posts
    1,789
    Thanks
    32
    Thanked 460 Times in 321 Posts

    Yea you should call from a dumbphone, but it's a lot easier to initiate a CS Chat session - they don't recognize the phone you're currently using. Works every time, except for those who actually SAY they have an iPhone
    If I helped you out, please use the Thanks button ------------------------->

  6. #6
    **facepalm**

    I am such a moron. I totally forgot that was the correct APN. I was putting in the wrong one. Thanks so much. That was really helpful.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •