Results 1 to 11 of 11

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Invalid Sim/SIM Failure

  1. #1
    Unhappy Invalid Sim/SIM Failure
    Details:

    Iphone 3gs 32gb
    Ver: 3.1 (7C144)
    Firmware: 05.11.07
    jailbroken/unlocked using Blackrain
    Itunes 9.1.1.12
    3G/Roaming Turned off

    Please someone comfort me

    I've been using this iphone jailbroken for about 6 months now, no major complaints (other than having to toggle wi-fo on/off).

    I was watching a game on tv and was "playing" around and took out the sim. STUPID STUPID STUPID.

    I must have put it in and out a couple of times... (i have no idea why)... After one of those times I got an "Invalid SIM" message and NO SERVICE.

    Here's what I've tried so far...

    1. I took sim and put it in another tmobile phone I had, service hooked right up and I could make calls (much older phone), back in the Iphone, still Invalid SIM.

    2. I assumed I screwed up the SIM. I had another SIM (2nd), never activated and decided to call TMobile, give them the SIM number and switch the SIMS. After switching SIMS, placed it in Iphone, still same failure/invalid msg. Placed second SIM in old phone and it worked in old phone just like 1st SIM.

    3. Using 2nd SIM, tried, turning on Airplane mode, turning off phone, turning back on, turning off Airplane mode... no change, same message.

    4. Using 2nd SIM tried running blackrain again, no change.

    Please someone tell me it's not the phone/it's fixable...

    (*and if it's not what can I do with it*)

    John

  2. #2
    Livin the iPhone Life adp's Avatar
    Join Date
    Jan 2009
    Location
    South FL
    Posts
    1,789
    Thanks
    32
    Thanked 460 Times in 321 Posts

    I'm assuming you've tried restarting your phone. If that doesn't do it then insert the sim and go to cydia and install blacksn0w.

    As a last resort try re-jailbreaking and re-unlocking

  3. #3
    If by restarting you mean powering off/on, yes I did that in each step. Blacksnow is already installed, and can't reinstall without service (since wi-fi doesn't seem to work without service) and I've already tried downloading the RC3 blackrain from the web and re-jailbreaking it... no change.

    Any other ideas?

  4. #4
    Livin the iPhone Life adp's Avatar
    Join Date
    Jan 2009
    Location
    South FL
    Posts
    1,789
    Thanks
    32
    Thanked 460 Times in 321 Posts

    Restore your phone from backup
    Last edited by adp; 05-19-2010 at 07:13 AM.
    If I helped you out, please use the Thanks button ------------------------->

  5. #5
    Okay, now is that a backup that I have with ITunes? I found the restore button with ITunes but it wanted to to restore and "upgrade" which in my case would be bad since my baseband is 5.11.07 ... how do I restore without upgrade?

    Ahh I found a guide ... trying it now...

    well... I followed the modmyi restore guide using the 3.1 firmware download and while the process looked like it worked, after my phone rebooted it now says "slide for emergency".... help?
    Last edited by jeo92109; 05-18-2010 at 07:59 PM. Reason: Automerged Doublepost

  6. #6
    Livin the iPhone Life adp's Avatar
    Join Date
    Jan 2009
    Location
    South FL
    Posts
    1,789
    Thanks
    32
    Thanked 460 Times in 321 Posts

    Now you have to rejailbreak and re unlock
    Last edited by adp; 05-19-2010 at 08:47 AM.
    If I helped you out, please use the Thanks button ------------------------->

  7. #7
    Yup, guess that and it worked... (*wiping sweat from forehead) also managed to get all apps backing using appbackup and aptbackup ... wow... THANK YOU!!!

  8. #8
    Livin the iPhone Life adp's Avatar
    Join Date
    Jan 2009
    Location
    South FL
    Posts
    1,789
    Thanks
    32
    Thanked 460 Times in 321 Posts

    No problem, glad it worked
    Last edited by adp; 05-19-2010 at 08:47 AM.
    If I helped you out, please use the Thanks button ------------------------->

  9. #9
    Which guide did you use?

  10. #10
    I have an unlocked Iphone 3gs 32G version 3.1.3 (7E18) Firmware 05.12.01 and can't get my T-mobile SIM card to work. Any help?

  11. #11
    Livin the iPhone Life adp's Avatar
    Join Date
    Jan 2009
    Location
    South FL
    Posts
    1,789
    Thanks
    32
    Thanked 460 Times in 321 Posts

    See PM
    If I helped you out, please use the Thanks button ------------------------->

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •