+ Reply
Page 1 of 2 12 LastLast
Results 1 to 20 of 21

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Need Help getting T-Mobile as carrier

is a discussion within the

T-mobile

forums, a part of the

iPhone Modding

section;
I've jailbroken my phone and followed the instructions to install ultrasn0w but I don't know how to setup T-Mobile as my carrier.. I even tried yellowsn0w but have had no
...
  1. #1
    What's Jailbreak?
    Join Date
    Sep 2009
    Posts
    24
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default Need Help getting T-Mobile as carrier
    I've jailbroken my phone and followed the instructions to install ultrasn0w but I don't know how to setup T-Mobile as my carrier..

    I even tried yellowsn0w but have had no luck.

    Can ANYONE please help me and tell me what to do?


    I have an iPhone 3G with 3.0.1.


    Thanks!

  2. #2
    Green Apple
    Join Date
    Aug 2009
    Posts
    52
    Thanks
    0
    Thanked 4 Times in 4 Posts

    All you have to do is put in your tmobile sim and it will pick it up... Do you have a tmobile plan?
    BOOBAH!

  3. #3
    Green Apple
    Join Date
    Jul 2009
    Posts
    51
    Thanks
    0
    Thanked 2 Times in 2 Posts

    turn 3g off

  4. #4
    What's Jailbreak?
    Join Date
    Sep 2009
    Posts
    24
    Thanks
    0
    Thanked 0 Times in 0 Posts

    I have 3G turned off and I have a standard tmobile plan. The lady at tmobile said I should be able to at least be able to get calls and send texts but it's not working Any ideas?

  5. #5
    Livin the iPhone Life SharpieBandit's Avatar
    Join Date
    Sep 2008
    Location
    Alexandria, Louisiana
    Posts
    1,454
    Thanks
    53
    Thanked 74 Times in 61 Posts

    Is it picking up signal at all?

  6. #6
    What's Jailbreak?
    Join Date
    Sep 2009
    Posts
    24
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Ok I got it to recognize the iPhone and tmobile then all of a sudden it said no sim. Is there any fix for this so that I don't lose service??? This will suck if I can't use it whenever without losing service??

  7. #7
    iPhone? More like MyPhone
    Join Date
    Jul 2009
    Posts
    147
    Thanks
    42
    Thanked 7 Times in 7 Posts

    Just for the heck of it have you rebooted the phone a few times? Put in anouther sim? On some voice plan on tmobile?

  8. #8
    What's Jailbreak?
    Join Date
    Sep 2009
    Posts
    24
    Thanks
    0
    Thanked 0 Times in 0 Posts

    I just re booted and still it says no sim. Is there any fix for this ??

  9. #9
    iPhone? More like MyPhone
    Join Date
    Jul 2009
    Posts
    147
    Thanks
    42
    Thanked 7 Times in 7 Posts

    Does the sim register in an offical tmobile phone?

  10. #10
    iPhone? More like MyPhone
    Join Date
    Nov 2008
    Posts
    141
    Thanks
    1
    Thanked 21 Times in 18 Posts

    Which instructions have you followed? What program did you use to do all this? Since your on a 3G with 3.01 what is the version that shows you using on ultrasn0w in Cydia?

  11. #11
    What's Jailbreak?
    Join Date
    Sep 2009
    Posts
    24
    Thanks
    0
    Thanked 0 Times in 0 Posts

    I followed the instructions to Jailbreak and Unlock my phone from a site called Redmond Pie ..

    Here's the link for unlocking:

    Unlock iPhone 3.0.1 with ultrasn0w | Redmond Pie



    For ultrasn0w, it shows version 0.91-1


    Today, for 5 hours, it worked great - no problems. Then when I got home it all of a sudden came up and said No Sim.

    I rebooted the phone about 4 or 5 times and then finally it showed T-Mobile again... then 20 minutes later said No Sim again... rebooted again and it came back...

    In the last 2 hours it's came up with No Sim about 3 - 4 times, forcing me to reboot MULTIPLE times to get it back.

    Right now it shows me on the T-Mobile network but who knows how long that'll last

    UPDATE - 2:18PM CST ---- Just came up with No Sim again. I was on the phone with my wife then I went to the settings really quick and it came up saying No Sim.


    Going to reboot the phone a few times to see what happens...

    UPDATE - 2:23PM CST --- Turned off the phone, back on and No Sim.... turned it off, let it sit for a minute then back on and now it shows T-Mobile again.
    Last edited by dotFRAG; 09-18-2009 at 01:24 PM. Reason: Automerged Doublepost

  12. #12
    iPhone? More like MyPhone
    Join Date
    Jul 2009
    Posts
    147
    Thanks
    42
    Thanked 7 Times in 7 Posts

    naw don't worry wait till the dev-team to get the 3.1 and all should be good. i'm still running 3.0 and waiting because of all these problems i keep hearing for non-att phone

  13. #13
    What's Jailbreak?
    Join Date
    Sep 2009
    Posts
    24
    Thanks
    0
    Thanked 0 Times in 0 Posts

    So ......


    Just keep doing what I'm doing to get service back then??


    Is anyone else having these kinds of problems with T-Mobile?

  14. #14
    iPhone? More like MyPhone
    Join Date
    Jul 2009
    Posts
    147
    Thanks
    42
    Thanked 7 Times in 7 Posts

    yep. some afternoons my service keep dropping and reconnecting. so i just use the SBSetting to turn on the airplane mod and use the wifi for a few hours. i don't know what it is about my area or just my house but it's the way it is for me at my area.

    but once your phone is pretty solid dont' do any major changes. only a little a time. like i said 3.0 is perfect for me so i'll skip 3.01 and 3.1 (from what i hearing) until i "need" the update

    oh ya the @tmobile_usa twitter post every other day of 3g roll outs so maybe there playing around with the towards in your area? who knows.

    but good luck.

  15. #15
    What's Jailbreak?
    Join Date
    Sep 2009
    Posts
    24
    Thanks
    0
    Thanked 0 Times in 0 Posts

    What's SBSetting? Does that restore your phone service?

    Also ... should I try restoring my phone back to 3.0 (not 3.0.1) and see if that works....

    or just stick with what I have?

  16. #16
    iPhone? More like MyPhone
    Join Date
    Jul 2009
    Posts
    147
    Thanks
    42
    Thanked 7 Times in 7 Posts

    oh check cydia for it. and i'm sorry the SBSetting let you quickly turn on wi-fi, rotation, brightness, etc. it does not restore you phone. sorry about that.

    naw don't downgrade. i hear it's a pain. but i'm just sharing my experiences with my iphone. the other day it was not working and i wanted to toss it out the car. the GPS and EDGE would not load maps for me!! but others here probably have 2 or 3 Iphones with more experience and could give you a better answer or solution.

    also check out the normal forum for unlocking and what not. the iphone modding area. iPhone Modding

    good luck
    Attached Thumbnails Attached Thumbnails Need Help getting T-Mobile as carrier-iphone-044.png  

  17. #17
    iPhone? More like MyPhone
    Join Date
    Nov 2008
    Posts
    141
    Thanks
    1
    Thanked 21 Times in 18 Posts

    3.01 is essentially 3.0 but with an SMS patch. Are you able to make a phone call when it says no sim? I know there is an issue where it will not say t-mobile but there will be signal. I dare say something did not take and you may have to try reinstalling 3.0.1 again but there is no big difference with 3.0 and 3.01. Now 3.1 there is a world of difference they are still working on those issues too. I personalty am sticking to 3.01 even with me being on a 2G All i know is it works fine and 3.1 didn't seem like a big deal to me anyway.

  18. #18
    iPhone? More like MyPhone
    Join Date
    Jul 2009
    Posts
    147
    Thanks
    42
    Thanked 7 Times in 7 Posts

    Quote Originally Posted by LrdBane View Post
    . Are you able to make a phone call when it says no sim? I know there is an issue where it will not say t-mobile but there will be signal.
    nope. that's doesn't work for me. it has to say t-mobile for it to work for me.
    Are You Not Entertained! Are You Not Entertained! Is this not why you are HERE!!!!"

  19. #19
    iPhone? More like MyPhone
    Join Date
    Nov 2008
    Posts
    141
    Thanks
    1
    Thanked 21 Times in 18 Posts

    Someone asked earlier but i didn't see an answer. Have you tried another sim chip? tmobile or ATnT or both? Maybe friends or fam or anyone who would be willing to swap the chip for a few moments to test it. Have you used any other firmware before and it worked fine or is this a new phone? OR is this a new phone to you? did you buy it 2nd hand/3rd hand?? COULD be hardware related. Either the sim chip or the phone, heck even a bit of dirt could do it on the sim or inside the phone where the sim goes.

    Sorry for all the questions but I need details...

  20. #20
    What's Jailbreak?
    Join Date
    Sep 2009
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts

    I have tmobile on my 3g iPhone. I ordered a turbo sim card and inserted it along with my tmobile sim. With the turbo u don't need 3g. Also had to tweak my tmo plan and add a data plan (I originally had a sidekick) to have full service. Now I do occasionally experience the " no sim" MSG but it's usually if I run into a dead zone, am underground, etc. I just switch to airport mode and switch back instead of resetting the phone. Also try internet2.voicestream.com as ur apn. With tmobile you have to talk to a rep from "tier 3" LOL good luck

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts