View Poll Results: 2.2.1 or 3.0 FW on my 2G iPhone?!

Voters
8. You may not vote on this poll
  • JB and Unlock with 2.2.1 FW QuickPWN

    0 0%
  • Restore to 3.0.1 or 3.0 and JB and Unlock with 3.0FW Redsn0w

    8 100.00%
Results 1 to 6 of 6

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: 2.2.1 or 3.0 FW on my NEW 2G iPhone?!

  1. #1
    Default 2.2.1 or 3.0 FW on my NEW 2G iPhone?!
    After getting another brand new 2G iPhone can not decide what firmware to put on this 2G iPhone and JB and Unlock it to use with my tmobile SIM. I JB and Unlocked my wife 2G with quickpwn and put 2.2.1 on it and she still has it, using it without any issues at all, it was quick and painless process to JB the phone. When I bought myself a 2G and try to do redsnow 0.8 using Shift restore 3.0 and then JB and Unlocking with 3.0 FW file it did not work, phone JB but SIM was not seen, iphone and itunes did not see my SIM, still said no SIM. I could not find a solution for it, so now with this new phone I want some suggestions of what route to take. I have a 2 year old Tmobile SIM card, I read somewhere that older SIM card could have been the issue why it did not see it, since I did everything right. But I read that many people also had same issues and kept 2.2.1 on their 2G phones, and that some who did upgrade and JB and Unlocked the 2G iPhones with 3.0 FW had issues with phone freezing up, bad battery life, etc.. What do you think?!

  2. #2
    I was using 2.2.1 on my 2G (I used Pwange to jailbreak/unlock) for awhile after 3.0 was released. Originally I didnt upgrade because certain apps like Swirly and PdaNet were not yet updated for 3.0. Finally I decided to get a 3G and sell the 2G so I went ahead and put 3.0 on it (using redsn0w 0.7.2) and I used it for like a month before selling it and it worked the exact same as it did on 2.2.1 so I say upgrade.No reason to stay on an older firmware. Alot of apps are starting to have upgrades only available to 3.0 users so might as well put 3.0 it sooner than later.

    That said I have a 3G and probably will never upgrade to 3.1 unless I have to do a restore. but thats only becasue there is no dramatic difference between 3.0 and 3.1 but there is a difference between 2xx and 3.0.

  3. #3
    Retired Moderator StealthBravo's Avatar
    Join Date
    Jan 2008
    Location
    TX  Follow me @StealthBravo
    Posts
    32,477
    Thanks
    44
    Thanked 5,328 Times in 3,113 Posts

    Just wait for 3.1. 3.1 > 2.2.1

  4. #4
    I installed 8.0.2 iTunes to JB with quickpwn, plugged in iphone, itunes tells me I need 8.2 or higher itunes to see the iphone, my T-Mobile SIM was inside of iphone. Does that mean this iphone has 3.0 FW on it now?! Since 3.0 FW needs 8.2 itunes to see the phone and also do redsn0w JB?! I know with another iphone 2G I had I had an issue to downgrade from 3.0 to 2.2.1 when my redsn0w JB did not work and 2G did not see my T-Mobile SIM. Is there a code on iphone in emergency screen I can type in to see what firmware is on theis Brand NEW iPhone before i proceed with Shift restore and JB process?!

    anyone guys?
    Last edited by PaneraiLover; 09-14-2009 at 10:38 AM. Reason: Automerged Doublepost

  5. #5
    no disrespect to the original poster, but i really hate these threads of should i upgrade or not from 2.2.1. i hated them since the older days when people asked "should i go to 2.0 or stay on 1.1.4". but what the hell does my opinion matter for that fact....but back to the topic...no there is no code that tells you what firmware your on...just look at the mmost recent .ipsw on your downloads and that should be it if u didnt do a shift restore....
    [IMG]http://img829.imageshack.us/img829/9703/modu.gif[/IMG]

  6. #6
    well as you read the post I JB 20 times with redsn0w and it did not see my t-mobile sim thats why I ask the question

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •