+ Reply
Results 1 to 2 of 2

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: No service!! Plz help!

is a discussion within the

T-mobile

forums, a part of the

iPhone Modding

section;
I have a jailbroken/unlocked 3g iphone with 2.2.1 firmware. I accidently upgraded to newest 3.0 version in itunes, since then I get no service or no sim card sign on
...
  1. #1
    What's Jailbreak?
    Join Date
    Mar 2009
    Posts
    5
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default No service!! Plz help!
    I have a jailbroken/unlocked 3g iphone with 2.2.1 firmware.
    I accidently upgraded to newest 3.0 version in itunes, since then I get no service or no sim card sign on it.
    So I downgraded back to 2.2.1 and unlocked it again but it still gives me no service and I am stuck right now.
    It now works with at&T simcard but gives me no service with t-mobile simcard with turbo sim.
    Can anyone please give me a solution?? I alreay spent more six hours of serching for solutions today but came up with nothing.
    Please help!
    Last edited by davetj; 07-12-2009 at 05:20 PM.

  2. #2
    What's Jailbreak?
    Join Date
    Jul 2009
    Posts
    6
    Thanks
    2
    Thanked 0 Times in 0 Posts

    Ok here is what you need to do

    1. Go back to 3.0 (Do a fresh installation on everything)
    2. Jailbreak the device either using Quickpwn or redsnow or pwnagtools
    3. Add the Ultrasn0w repo in cydia
    4. install ultrasn0w
    5. get rid of turbosim....you dont need it just put the tmobile sim card
    6. and you should be set to go

    there are isntructions all over the place on how to do this. google "Dev team blog" and it will take you their site which tells you a bit more detailed explanation.

    Hope this helps

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts