Page 93 of 103 FirstFirst ... 43 839192939495 ... LastLast
Results 1,841 to 1,860 of 2044

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: T-Mobile USA Carrier Bundles: Bluetooth, Internet, MMS, & Tethering (2G/3G/3GS/4)

  1. #1841
    Will there be a new version for iOS 4.2.1? Or is the 4.1 ipcc compatible with 4.2.1?

    I'm running iPhone 3G iOS 4.2.1 jailbroken with 06.15.00 baseband unlocked on T-Mobile USA.

  2. #1842
    Quote Originally Posted by ceevee View Post
    Will there be a new version for iOS 4.2.1? Or is the 4.1 ipcc compatible with 4.2.1?

    I'm running iPhone 3G iOS 4.2.1 jailbroken with 06.15.00 baseband unlocked on T-Mobile USA.
    I'm wondering the same thing. But I'm sure Spooky will give us an update as soon as anything is available

  3. #1843
    iPhone Model: iphone4 running 4.0.2
    Carrier Bundle Used: T-Mobile Legacy, standard works too
    Voice Plan: Family Time 700 (Old plan)
    Data Plan: Blackberry Unlimited (BIS - not the enterprise one)
    SMS: Pay per use
    Time with T-Mobile: 5 years
    Last Plan Change: 2 years ago
    Problem: I can see TMOBILE service on the PHONE setting screen. Seems to work for phone call, but I cannot get DATA/INTERNET to use on the safari. If I reboot, I get invalid SIM after REBOOT. I will need to remove UltraSn0w, and reset network. Then reinstall Ultrasnow to get it working again. But Data never work.
    Last edited by ndkone; 11-29-2010 at 08:03 PM. Reason: Automerged Doublepost

  4. #1844
    Quote Originally Posted by ceevee View Post
    Will there be a new version for iOS 4.2.1? Or is the 4.1 ipcc compatible with 4.2.1?

    I'm running iPhone 3G iOS 4.2.1 jailbroken with 06.15.00 baseband unlocked on T-Mobile USA.
    Quote Originally Posted by kmmxracer View Post
    I'm wondering the same thing. But I'm sure Spooky will give us an update as soon as anything is available
    I have made the iOS 4.2.1 bundle 8 days ago. I have been holding off to release it in conjuncture with Creamsn0w and PwnageTool.

    Quote Originally Posted by ndkone View Post
    iPhone Model: iphone4 running 4.0.2
    Carrier Bundle Used: T-Mobile Legacy, standard works too
    Voice Plan: Family Time 700 (Old plan)
    Data Plan: Blackberry Unlimited (BIS - not the enterprise one)
    SMS: Pay per use
    Time with T-Mobile: 5 years
    Last Plan Change: 2 years ago
    Problem: I can see TMOBILE service on the PHONE setting screen. Seems to work for phone call, but I cannot get DATA/INTERNET to use on the safari. If I reboot, I get invalid SIM after REBOOT. I will need to remove UltraSn0w, and reset network. Then reinstall Ultrasnow to get it working again. But Data never work.
    Upgrade to 4.1 using PwnageTool to retain you 4.0 baseband. Install ultrasn0w, the patch from the first post, reboot, then install the carrier bundle.
    Last edited by SpookyET; 11-29-2010 at 11:18 PM. Reason: Automerged Doublepost

  5. The Following User Says Thank You to SpookyET For This Useful Post:

    kmmxracer (11-29-2010)

  6. #1845
    Holy Crap you doing another Creamsn0w!!!! I freaking love you Spooky. I hate Cydia crapware. Thankyou so much

  7. #1846
    I've been reading about your creamsn0w, will there be anyway to use it with windows

  8. #1847
    Quote Originally Posted by kmmxracer View Post
    Holy Crap you doing another Creamsn0w!!!! I freaking love you Spooky. I hate Cydia crapware. Thankyou so much
    Creamsn0w has always been available.

    Quote Originally Posted by Butchiem1 View Post
    I've been reading about your creamsn0w, will there be anyway to use it with windows
    No, it's Mac OS X only. There will never be a Windows version made by me. But, someone can make you a custom firmware that you can restore on Windows.
    Last edited by SpookyET; 11-29-2010 at 11:37 PM. Reason: Automerged Doublepost

  9. #1848
    Will this work for 4.2.1?

  10. #1849
    Quote Originally Posted by Butchiem1 View Post
    Will this work for 4.2.1?
    I have done the creamsn0w for 4.2.1; I just haven't tested it; so, I haven't published it.

  11. #1850
    Quote Originally Posted by SpookyET View Post
    I have made the iOS 4.2.1 bundle 8 days ago. I have been holding off to release it in conjuncture with Creamsn0w and PwnageTool.



    Upgrade to 4.1 using PwnageTool to retain you 4.0 baseband. Install ultrasn0w, the patch from the first post, reboot, then install the carrier bundle.
    Thanks for your reply and suggestion, what you are saying is that the problem is isolated on IOS 4.0.2 and not on 4.1?

  12. #1851
    Ya but what was the last firmware and Pwnage Tool Creamsn0w worked on?

  13. #1852
    Quote Originally Posted by ndkone View Post
    Upgrade to 4.1 using PwnageTool to retain you 4.0 baseband. Install ultrasn0w, the patch from the first post, reboot, then install the carrier bundle.
    I still have problem... same problem on iphone4 with 4.1/bb1.59 (got tmobile working for voice call only the first time after a 'reset - network' but rebooting it will lose the carrier, data do not work from beginning). If I put the sim to a 3GS, it works without any commcenter or ipcc addition on 4.0.1.

    Maybe I'm doing this wrong?

    Here is what I did in the exact order ( I tried to do this 3 times and exactly the same result):
    - Remove SIM card
    - PwnageTool 4.1.3: create ios 4.1 and keep BB 1.59
    - PwnageTool 4.1.3: ENTER DFU mode
    - Tiny Umbrella 4.21: start TSS with SHSH for 4.1
    - iTune 10.1: shift-restore, select custom ipsw ios 4.1+keep BB1.59
    - restore done, restart IP
    - run setting, setup WIFI
    - run Cydia, update Cydia, reboot IP
    - run Cydia, install UltraSn0w, reboot IP
    - run Cydia, install openSSH
    - ssh to IP and put CommCenter deb package in /private/var/root/Media/Cydia/AutoInstall (need to create Cydia and AutoInstall directory)
    - restart IP twice (per commCenter patch note)
    - run this on itune: iTunes.exe /setPrefInt carrier-testing 1
    - run itune, shift-update, select t-mobile_us__standard.ipcc
    - restart IP
    - PUT in SIM card (t-mobile), No carrier (just empty with 1 bar)
    - SETTING/GENERAL - reset network
    - Tmobile carrier show up, EDGE data does not work
    - restart IP
    - Tmobile does not show up, No carrier (just empty with 1 bar)
    - reset network will make it work again.
    * I can repeat the whole process or just the network reset to get voice call. But no data

    Any help appreciated. Sorry for the long post. Just want to provide all the info I have.
    Last edited by ndkone; 12-01-2010 at 01:21 PM. Reason: Automerged Doublepost

  14. #1853
    Quote Originally Posted by ndkone View Post
    I still have problem... same problem on iphone4 with 4.1/bb1.59 (got tmobile working for voice call only the first time after a 'reset - network' but rebooting it will lose the carrier, data do not work from beginning). If I put the sim to a 3GS, it works without any commcenter or ipcc addition on 4.0.1.

    Maybe I'm doing this wrong?

    Here is what I did in the exact order ( I tried to do this 3 times and exactly the same result):
    - Remove SIM card
    - PwnageTool 4.1.3: create ios 4.1 and keep BB 1.59
    - PwnageTool 4.1.3: ENTER DFU mode
    - Tiny Umbrella 4.21: start TSS with SHSH for 4.1
    - iTune 10.1: shift-restore, select custom ipsw ios 4.1+keep BB1.59
    - restore done, restart IP
    - run setting, setup WIFI
    - run Cydia, update Cydia, reboot IP
    - run Cydia, install UltraSn0w, reboot IP
    - run Cydia, install openSSH
    - ssh to IP and put CommCenter deb package in /private/var/root/Media/Cydia/AutoInstall (need to create Cydia and AutoInstall directory)
    - restart IP twice (per commCenter patch note)
    - run this on itune: iTunes.exe /setPrefInt carrier-testing 1
    - run itune, shift-update, select t-mobile_us__standard.ipcc
    - restart IP
    - PUT in SIM card (t-mobile), No carrier (just empty with 1 bar)
    - SETTING/GENERAL - reset network
    - Tmobile carrier show up, EDGE data does not work
    - restart IP
    - Tmobile does not show up, No carrier (just empty with 1 bar)
    - reset network will make it work again.
    * I can repeat the whole process or just the network reset to get voice call. But no data

    Any help appreciated. Sorry for the long post. Just want to provide all the info I have.
    I've looked at the iPhone 4 carrier bundles. They are identical across all iPhone iOS4 devices. Do you get data if you manually input your APN in the Cellular Data Network menu when you don't have a carrier bundle installed?

  15. #1854
    Quote Originally Posted by SpookyET View Post
    I've looked at the iPhone 4 carrier bundles. They are identical across all iPhone iOS4 devices. Do you get data if you manually input your APN in the Cellular Data Network menu when you don't have a carrier bundle installed?
    When I have unknown bundle, I tried EPC.tmobile.com, internet2.voicestream.com, and wap.voicestream.com. none of them work. But this is only on iphone 4. If I put the SIM card to the iphone 3gs, 3gs with ultrasn0w unlock and no commCenter or ipcc works (voice+data).

    I was going to change the carrier.plist to see if I can try different settings. But I see this in the directory, why do I have different bundle for Carrier Bundle vs Operator.bundle? Maybe this is the core problem that somehow the system is not reading the Carrier ID correctly for tmobile SIM for 310260 so it is UNKNOWN.bundle instead of using the IPCC I installed? but I don't understand why the OPERATOR bundle get it right.


    lrwxr-xr-x 1 mobile mobile 46 Dec 1 21:14 Carrier Bundle.bundle -> /System/Library/Carrier Bundles/Unknown.bundle
    lrwxr-xr-x 1 mobile mobile 42 Dec 1 21:32 Operator Bundle.bundle -> /var/mobile/Library/Carrier Bundles/310260

    I tried to manually repoint the link but it changes back to the UNKNOWN after reboot.

    Just to confirm, I restored the iphone4 again and go through the process once more, that UNKNOWN.bundle is what I use for Carrier only.

    If I put the SIM back to my iphone 3GS, I will get BOTH carrier and operator on UNKNOWN carrier and voice+data both work without any APN info for the BIS plan. So, I know the SIM card and my plan works.
    Last edited by ndkone; 12-01-2010 at 10:11 PM.

  16. #1855
    Quote Originally Posted by ndkone View Post
    When I have unknown bundle, I tried EPC.tmobile.com, internet2.voicestream.com, and wap.voicestream.com. none of them work. But this is only on iphone 4. If I put the SIM card to the iphone 3gs, 3gs with ultrasn0w unlock and no commCenter or ipcc works (voice+data).

    I was going to change the carrier.plist to see if I can try different settings. But I see this in the directory, why do I have different bundle for Carrier Bundle vs Operator.bundle? Maybe this is the core problem that somehow the system is not reading the Carrier ID correctly for tmobile SIM for 310260 so it is UNKNOWN.bundle instead of using the IPCC I installed? but I don't understand why the OPERATOR bundle get it right.


    lrwxr-xr-x 1 mobile mobile 46 Dec 1 21:14 Carrier Bundle.bundle -> /System/Library/Carrier Bundles/Unknown.bundle
    lrwxr-xr-x 1 mobile mobile 42 Dec 1 21:32 Operator Bundle.bundle -> /var/mobile/Library/Carrier Bundles/310260

    I tried to manually repoint the link but it changes back to the UNKNOWN after reboot.

    Just to confirm, I restored the iphone4 again and go through the process once more, that UNKNOWN.bundle is what I use for Carrier only.

    If I put the SIM back to my iphone 3GS, I will get BOTH carrier and operator on UNKNOWN carrier and voice+data both work without any APN info for the BIS plan. So, I know the SIM card and my plan works.
    Yours is a curious case. If the carrier bundle was not installed, and one of the APNs worked, it would have been a carrier bundle bug, but that's not the case. Have you also uninstalled the CommCenter patch and rebooted before you tested the APNs? By not working, do you mean that you get a no data connection pop up, or are you redirected to the T-Mobile up sell page?

    Both Carrier Bundle.bundle and Operator Bundle.bundle should point to the T-Mobile bundle. You can clear out the contents of /var/mobile/Library/Carrier Bundles/ and delete Operator Bundle.bundle and Carrier Bundle.bundle and unzip the Payload directory of the IPCC into /System/Library/Carrier Bundles/iPhone. It probably won't make a difference, but it won't hurt trying.

    Lastly, do you have any Cydia crapware installed?

  17. #1856
    Quote Originally Posted by SpookyET View Post
    Yours is a curious case. If the carrier bundle was not installed, and one of the APNs worked, it would have been a carrier bundle bug, but that's not the case. Have you also uninstalled the CommCenter patch and rebooted before you tested the APNs? By not working, do you mean that you get a no data connection pop up, or are you redirected to the T-Mobile up sell page?

    Both Carrier Bundle.bundle and Operator Bundle.bundle should point to the T-Mobile bundle. You can clear out the contents of /var/mobile/Library/Carrier Bundles/ and delete Operator Bundle.bundle and Carrier Bundle.bundle and unzip the Payload directory of the IPCC into /System/Library/Carrier Bundles/iPhone. It probably won't make a difference, but it won't hurt trying.

    Lastly, do you have any Cydia crapware installed?
    I only install the Cydia/openssh/UltraSn0w - i did a complete update when i first start the Cydia the first time. Will that install Crapware? Maybe I can try the minimal update next.

    I have a iphone 3gs also unlocked so I know the SIM/plan works (same SIM that is cutted to the size and I use an adapter to go between. I also try pwnageTool that do not activate on the custom IPSW and then install and use my original ATT sim card to activate the phone. the att account is disabled already but it can use to activate the phone. I will get a the phone is activate message and another message saying data is not activated.

    I think the iOS is trying to get something to activate the account for voice and data and put some kind of signature, maybe?

    This last time of the restore and setup, since I use ATT to activate the phone, the carrier bundle looks like it is LOCKed on the ATT 310410 bundle and operator change to unknown when I put the Tmobile SIM in.

    lrwxr-xr-x 1 mobile mobile 46 Dec 1 22:07 Carrier Bundle.bundle -> /System/Library/Carrier Bundles/310410
    lrwxr-xr-x 1 mobile mobile 42 Dec 1 22:11 Operator Bundle.bundle -> /var/mobile/Library/Carrier Bundles/Unknown.bundle

    I have just restored again and only use the hackivation/openssh/ultraSnow.... this time I put in the tmobile sim card after ultrasnow and there is no carrier bundle but operator bundle is there

    lrwxr-xr-x 1 mobile mobile 42 Dec 1 21:32 Operator Bundle.bundle -> /var/mobile/Library/Carrier Bundles/Unknown.bundle

    I suspect something is LOCKING or stopping the carrier bundle being setup or changed or read entirely.

    Any suggestion?
    Thanks for your help and willingness to check on this for me.

  18. #1857
    Quote Originally Posted by ndkone View Post
    I only install the Cydia/openssh/UltraSn0w - i did a complete update when i first start the Cydia the first time. Will that install Crapware? Maybe I can try the minimal update next.

    I have a iphone 3gs also unlocked so I know the SIM/plan works (same SIM that is cutted to the size and I use an adapter to go between. I also try pwnageTool that do not activate on the custom IPSW and then install and use my original ATT sim card to activate the phone. the att account is disabled already but it can use to activate the phone. I will get a the phone is activate message and another message saying data is not activated.

    I think the iOS is trying to get something to activate the account for voice and data and put some kind of signature, maybe?

    This last time of the restore and setup, since I use ATT to activate the phone, the carrier bundle looks like it is LOCKed on the ATT 310410 bundle and operator change to unknown when I put the Tmobile SIM in.

    lrwxr-xr-x 1 mobile mobile 46 Dec 1 22:07 Carrier Bundle.bundle -> /System/Library/Carrier Bundles/310410
    lrwxr-xr-x 1 mobile mobile 42 Dec 1 22:11 Operator Bundle.bundle -> /var/mobile/Library/Carrier Bundles/Unknown.bundle

    I have just restored again and only use the hackivation/openssh/ultraSnow.... this time I put in the tmobile sim card after ultrasnow and there is no carrier bundle but operator bundle is there

    lrwxr-xr-x 1 mobile mobile 42 Dec 1 21:32 Operator Bundle.bundle -> /var/mobile/Library/Carrier Bundles/Unknown.bundle

    I suspect something is LOCKING or stopping the carrier bundle being setup or changed or read entirely.

    Any suggestion?
    Thanks for your help and willingness to check on this for me.
    iOS4 will NOT accept an unsigned carrier bundle without the CommCenter patch, and I can't sign them since I'm not Apple. The CommCenter patch is absolutely necessary. Maybe, there is something wrong with the jailbreak. I don't know. I do know it's not the carrier bundle. I cannot dismiss the CommCenter patch yet. You should be able to manually input the APN in the Cellular Data Network menu and for data to work.

    You can try browsing the Hackint0sh forum. More advanced users hang out there. Maybe, you'll find something relevant.

  19. #1858
    I read through a lot of posting... and I come up with a solution/workaround.

    I restored to ios4.1 and then install openssh+ultrasn0w without sim card.
    I put the tmobile sim in and operator bundle is created, no carrier bundle. I manually created the link for the carrier bundle, like to the unknown bundle. I took the sim card out and shutdown.

    I power it up then and both the carrier and operator bundle stays, I can now put in att sim or tmobile sim, it will always use the unknown bundle for carrier. I see operator bundle change between 310410 and unknown. Just the carrier bundle do not change. But the unknown bundle allow me to edit APN. I tried epc.tmobile, wap.voicestream, both work.

    I have a working phone for voice and data now, but I cannot change the sim card. If I change sim card, I will need to do a reset network.

    Something is wrong but it is usable for now. I wonder what other people has and if anyone have this issue. Or they always have the same SIM card so it is not a problem.

  20. #1859
    Quote Originally Posted by ndkone View Post
    I read through a lot of posting... and I come up with a solution/workaround.

    I restored to ios4.1 and then install openssh+ultrasn0w without sim card.
    I put the tmobile sim in and operator bundle is created, no carrier bundle. I manually created the link for the carrier bundle, like to the unknown bundle. I took the sim card out and shutdown.

    I power it up then and both the carrier and operator bundle stays, I can now put in att sim or tmobile sim, it will always use the unknown bundle for carrier. I see operator bundle change between 310410 and unknown. Just the carrier bundle do not change. But the unknown bundle allow me to edit APN. I tried epc.tmobile, wap.voicestream, both work.

    I have a working phone for voice and data now, but I cannot change the sim card. If I change sim card, I will need to do a reset network.

    Something is wrong but it is usable for now. I wonder what other people has and if anyone have this issue. Or they always have the same SIM card so it is not a problem.
    Is your SIM card new? Normally, T-Mobile has the code 310260, where 310 is the Mobile Country Code (MCC) for United States and 260 is the Mobile Network Code (MNC). However, there are more network codes. Thus far, they have been dormant. See: List of mobile network codes in the United States and Mobile Network Code.

  21. #1860
    Quote Originally Posted by SpookyET View Post
    Is your SIM card new? Normally, T-Mobile has the code 310260, where 310 is the Mobile Country Code (MCC) for United States and 260 is the Mobile Network Code (MNC). However, there are more network codes. Thus far, they have been dormant. See: List of mobile network codes in the United States and Mobile Network Code.
    You are right, I have 310260 for operator bundle when I put in my tmobile sim card. When I put in the att sim card, the operator bundle switch to 310410. That seems to me the software is working correctly to "see" the SIM card.

    However, the problem is the carrier bundle is not switching. I suspect it is stuck at the first SIM CARD I put in. So, when I unlock the phone, it has NO bundle. So, the SIM card in the first time after unlock and first reboot cannot find the carrier. I can reboot many times and it will not pick up a new carrier bundle (by a link on the /private/var/mobile/Library directory.

    So, my solution is to create that link to UNKNOWN bundle the first time it creates the operator bundle (that points to UNKNOWN) and let it locks there.

    I have try to do the same with patched commCenter and the IPCC you created with the same manual link method, but then I only get voice and as soon as I rebooted, the second reboot will lose the carrier again since the link for carrier will not stay.

    This is a new iphone 4 I have just got as a replacement for a broken one. It comes with 4.0.2 BB 1.59 when I get it a week ago. My original iphone 4 has 4.0.1 and used the PDF hack/unlock and it was working beautifully. So, is my iphone 3GS with 4.0.1. I suspect something is different on the iphone or the IOS combination.....

    If there is anything you would like to know about the phone, I can get you any info you like. But at least I found a way to get it to work for both voice and data (for now).

    By the way, for whatever it worth.... I have the Tmobile BIS plan, unlimited BB message over the web and internet (not the enterprise BB plan). It seems to only work on APN with epc.tmobile.com. If you are creating future IPCC bundle, you may want to add one more for BIS plan. It will help a lot of BB conversion.
    Last edited by ndkone; 12-02-2010 at 09:57 AM.

Page 93 of 103 FirstFirst ... 43 839192939495 ... LastLast
Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •