+ Reply
Page 5 of 8 FirstFirst ... 34567 ... LastLast
Results 81 to 100 of 141

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: How to: t-zones without using proxy.pac file

is a discussion within the

T-mobile

forums, a part of the

iPhone Modding

section;
Originally Posted by dunkavenger Freshster, I did the steps that you mentioned for the 2.0 firmware, but I still can't connect to the internet. I signed up for tzones 5.99
...
  1. #81
    Green Apple
    Join Date
    Oct 2007
    Posts
    71
    Thanks
    1
    Thanked 22 Times in 15 Posts

    Quote Originally Posted by dunkavenger View Post
    Freshster,
    I did the steps that you mentioned for the 2.0 firmware, but I still can't connect to the internet. I signed up for tzones 5.99 last week in case you're wondering.
    Usually right after configuring the proxy I have to be patient and open multiple things before it starts working. I start with opening the Weather app, then I open the Stocks app, and finally Safari. When trying to connect in Safari for the first time, it usually takes a couple of tries.

    Also, make sure your reboot the iphone after making these changes; then go into the EDGE settings and make sure that the APN is set correctly to wap.voicestream.com. If all looks good after rebooting the iphone, then you should be able to connect (with a bit of patience). It is usually only stubborn connecting after the initial configuration and reboot. Sometimes it can be stubborn after a regular reboot as well.

    This seems to happen with all versions of the proxy hack, not just this one. Good luck and let us know how you do.

  2. #82
    What's Jailbreak?
    Join Date
    Jul 2008
    Posts
    7
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Do I put the preference.plist in the same directory as stated before for 1.1.4 firmware because I have 2.0. I just did what you mentioned and it still isn't working. I hope my case isn't an unusual and rare case after seeing so many people got theirs to work either with Tzones hack or the way you mentioned.

    For some weird reason my ssh password for the iPhone is no longer dottie so I couldn't log in, but I was able to access and make the preferences.plist changes with iPhoneBrowser. What was weird was that after making the necessary changes that Freshster suggested and rebooting the iPhone, the preferences.plist wasn't the same as it was when I modified it when I went to check the file again. Is there anyway for me to make the pref.plist change permanent without it changing everytime i turn it off or reboot it?
    I tried finding a way to change the password and found this Generating New Root Password For Your iPhone which generates a code for new password but I don't know how to get the file etc/master.passwd on my Windows. Yea..it's taking more work than it should to just get Tzones to work. Any help/suggestions/feedback would be appreciated.
    Last edited by dunkavenger; 07-23-2008 at 10:42 PM. Reason: Automerged Doublepost

  3. #83
    What's Jailbreak?
    Join Date
    Jun 2008
    Location
    CHITOWN
    Posts
    5
    Thanks
    7
    Thanked 0 Times in 0 Posts

    I have been dealing with this for a few days, so I thought I'd share my findings.

    Thanks to freshster's detailed instructions I changed the preferences file. My WinSCP would not take password to save the file so I opened Notepad, copy/paste the original pref. file, edited according to instructions and then I copied it/overwrote the original file on the phone.

    My APN shows wap.voicemail.com and User and Pass are guest.

    Here is the kicker... I rebooted the phone and nothing. Waited a few minutes turned off my Wi-Fi and tried again. Everything seems to work but no Edge icon. WTF, right!?!

    In addition, to all of you out there- I have a first gen. winpwned on FW 2.0. May be I misunderstood but my pref. file looked like the one on 1.1.3/4 instead of the one on 2.0 from Mr. Freshster's first post. Needless to say I edited it according to the first part of the post and it WORKED!!!

    I'd like anyone's input on what could be the reason for the E not being displayed. If I could tweak that I'd be an even happier camper/iphoner.

    Big ups to Mr. Freshster once again for taking time and PM me elaborating further on the whole process.

  4. #84
    Green Apple
    Join Date
    Oct 2007
    Posts
    71
    Thanks
    1
    Thanked 22 Times in 15 Posts

    Quote Originally Posted by dunkavenger View Post
    Do I put the preference.plist in the same directory as stated before for 1.1.4 firmware because I have 2.0. I just did what you mentioned and it still isn't working. I hope my case isn't an unusual and rare case after seeing so many people got theirs to work either with Tzones hack or the way you mentioned.
    Yes, put the preferences.plist file in the same location. 1.1.4 and 2.0 are located in the same place.
    The only advice I can give you is to be patient when connecting for the first time after the hack is in place. Sometimes it takes a bit, and sometimes I have to reboot the phone before it starts working. Like I have said before, I think that T-Mobile proxy has to cache your connection before it will connect and work. If you keep having problems, then you might have a rare case on your hands.

    Quote Originally Posted by dunkavenger View Post
    For some weird reason my ssh password for the iPhone is no longer dottie so I couldn't log in, but I was able to access and make the preferences.plist changes with iPhoneBrowser. What was weird was that after making the necessary changes that Freshster suggested and rebooting the iPhone, the preferences.plist wasn't the same as it was when I modified it when I went to check the file again. Is there anyway for me to make the pref.plist change permanent without it changing everytime i turn it off or reboot it?
    I have had the preferences.plist file reset back to default once or twice, but only happened right after I applied the modifications. It could have been my fault in the technique I used to make the changes. But most of the time this problem does not occur and the modified preferences.plist file stays intact after the reboot. Let us know if you are experiencing that problem everytime.

    Quote Originally Posted by dunkavenger View Post
    I tried finding a way to change the password and found this Generating New Root Password For Your iPhone which generates a code for new password but I don't know how to get the file etc/master.passwd on my Windows. Yea..it's taking more work than it should to just get Tzones to work. Any help/suggestions/feedback would be appreciated.
    I am not sure why your password changed, but be careful dealing with the passwd file, you can lock yourself out of the iPhone and have to do a restore to fix it.

    Quote Originally Posted by da_juice View Post
    I have been dealing with this for a few days, so I thought I'd share my findings.

    Thanks to freshster's detailed instructions I changed the preferences file. My WinSCP would not take password to save the file so I opened Notepad, copy/paste the original pref. file, edited according to instructions and then I copied it/overwrote the original file on the phone.

    My APN shows wap.voicemail.com and User and Pass are guest.

    Here is the kicker... I rebooted the phone and nothing. Waited a few minutes turned off my Wi-Fi and tried again. Everything seems to work but no Edge icon. WTF, right!?!

    In addition, to all of you out there- I have a first gen. winpwned on FW 2.0. May be I misunderstood but my pref. file looked like the one on 1.1.3/4 instead of the one on 2.0 from Mr. Freshster's first post. Needless to say I edited it according to the first part of the post and it WORKED!!!

    I'd like anyone's input on what could be the reason for the E not being displayed. If I could tweak that I'd be an even happier camper/iphoner.

    Big ups to Mr. Freshster once again for taking time and PM me elaborating further on the whole process.
    That is strange, usually the internet will NOT work when the edge icon (E) is not present. It seems yours is working without the presence of the (E)?
    Again, I have not heard of this before, but maybe someone else has experienced this and can help you...
    Good luck.

  5. #85
    iPhone? More like MyPhone
    Join Date
    Sep 2007
    Location
    Pasadena, Tx
    Posts
    176
    Thanks
    89
    Thanked 22 Times in 11 Posts

    Any updates to this since tmobile changed the ip address for t-zones?

  6. #86
    Green Apple
    Join Date
    Oct 2007
    Posts
    71
    Thanks
    1
    Thanked 22 Times in 15 Posts

    Quote Originally Posted by 96hondaex View Post
    Any updates to this since tmobile changed the ip address for t-zones?
    The IP subnet change by T-Mobile does not affect this method, because this method does not use a proxy.pac file for proxy determination.

    This configuration has continued to work for me without any problem.

  7. The Following User Says Thank You to freshster For This Useful Post:

    96hondaex (08-29-2008)

  8. #87
    iPhone? More like MyPhone
    Join Date
    Sep 2007
    Location
    Pasadena, Tx
    Posts
    176
    Thanks
    89
    Thanked 22 Times in 11 Posts

    Quote Originally Posted by freshster View Post
    The IP subnet change by T-Mobile does not affect this method, because this method does not use a proxy.pac file for proxy determination.

    This configuration has continued to work for me without any problem.
    Quote Originally Posted by 96hondaex View Post
    Well I am on 2.01 and it stopped working today.
    It just started working at about 2am all of a sudden.

    Thanks for your help.
    Last edited by 96hondaex; 08-29-2008 at 01:48 AM. Reason: Automerged Doublepost

  9. #88
    Green Apple
    Join Date
    Oct 2007
    Posts
    71
    Thanks
    1
    Thanked 22 Times in 15 Posts

    Quote Originally Posted by 96hondaex View Post
    It just started working at about 2am all of a sudden.

    Thanks for your help.
    Glad to see it is working for you.

  10. #89
    What's Jailbreak?
    Join Date
    Feb 2008
    Posts
    27
    Thanks
    11
    Thanked 0 Times in 0 Posts

    Followed this post, 1.1.4 tzones 5.99 hack works great. no tzones hack through installer, just edited preferences.plist file. Thanks
    Last edited by coolusername; 08-29-2008 at 09:10 AM.

  11. #90
    What's Jailbreak?
    Join Date
    Aug 2008
    Posts
    5
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Hi,
    I was wondering if someone can help me. I was told to reset the network on my iphone 1.1.4 cause of the ip change for t zones. I was still getting my e mail even though nothing else worked (safari, stocks, etc) now nothing works. I use it as a business phone, thats why I need it to work. It says cannot find server, you are not subscribed to Edge. My phone has worked flawless until about last week. Someone please help. Thanks in advance!

  12. #91
    Green Apple
    Join Date
    Oct 2007
    Posts
    71
    Thanks
    1
    Thanked 22 Times in 15 Posts

    Quote Originally Posted by oh anthony View Post
    Hi,
    I was wondering if someone can help me. I was told to reset the network on my iphone 1.1.4 cause of the ip change for t zones. I was still getting my e mail even though nothing else worked (safari, stocks, etc) now nothing works. I use it as a business phone, thats why I need it to work. It says cannot find server, you are not subscribed to Edge. My phone has worked flawless until about last week. Someone please help. Thanks in advance!
    When you reset the network settings on the iphone, it overwrites the preferences.plist file with a default copy which no longer includes the T-Zones hack modifications. That is why your T-Zones no longer works.

    You can try my method documented in the first post of this thread.
    It should work on all firmware versions without having to bother with a proxy.pac script.

    If you have any problems we will try and help.
    Let us know how it goes.
    Last edited by freshster; 08-30-2008 at 09:00 PM. Reason: Added further explaination.

  13. #92
    What's Jailbreak?
    Join Date
    Aug 2008
    Posts
    5
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Quote Originally Posted by freshster View Post
    When you reset the network settings on the iphone, it overwrites the preferences.plist file with a default copy which no longer includes the T-Zones hack modifications. That is why your T-Zones no longer works.

    You can try my method documented in the first post of this thread.
    It should work on all firmware versions without having to bother with a proxy.pac script.

    If you have any problems we will try and help.
    Let us know how it goes.
    Freshster,
    Thanks for your reply! I'm not sure how to start by getting that onto my computer to type it in. I'm not too computer savvy. Is there a way you'd be able to kind of walk me through it when you get a chance? I'd really appreciate it!

  14. #93
    What's Jailbreak?
    Join Date
    Jul 2008
    Posts
    19
    Thanks
    6
    Thanked 3 Times in 2 Posts

    I read through ALL the post I still cannot the E to appear! at all!
    I went into Open SSH and edited the preference list, but after that the E completely dissapeared! like it never existed I still cannot get it to work i'm really fustrated because i tried the modifying the proxy and that didn't work so i uninstalled it and tried THIS way and it still doesn't work.
    I've done all the steps and everything I'll reset my network and try to edit everything again and reboot my phone to see if it works! ;/

  15. #94
    Green Apple
    Join Date
    Oct 2007
    Posts
    71
    Thanks
    1
    Thanked 22 Times in 15 Posts

    benben,
    It should work after you edit the preferences.plist file then reboot. Like I said in previous posts, be patient when tryIng to connect the first time.
    Let us know what happens when you try again.

  16. #95
    What's Jailbreak?
    Join Date
    Jul 2008
    Posts
    19
    Thanks
    6
    Thanked 3 Times in 2 Posts

    thanks for the quick reply I've done it three times now!
    I've reset the network then gone in through Open SSH and edited just like the first post and reset the phone! but still no E showing up at all!
    The Tzone hacked has been removed prior to the three tries!
    Everything i open says cannot connect to server.. :/

  17. #96
    Green Apple
    Join Date
    Oct 2007
    Posts
    71
    Thanks
    1
    Thanked 22 Times in 15 Posts

    Benben,
    What happens when you try Weather app or Stocks app?

    Did you check in settings and make sure your APN is set correctly to wap.voicestream.com ?

  18. #97
    What's Jailbreak?
    Join Date
    Jul 2008
    Posts
    19
    Thanks
    6
    Thanked 3 Times in 2 Posts

    I'm talking with the Tmobile rep they instantly said I had an Iphone and i told them I borrowed my friends iphone cause mine fell in water and I believe she's resetting it I'll let you know the results! :/ hopefully this will work or else I'll just have to upgrade to 2.0 and lose my picture text messaging they just activated it because my tzone didn't work on my razr!!! :/!!!

  19. #98
    Green Apple
    Join Date
    Oct 2007
    Posts
    71
    Thanks
    1
    Thanked 22 Times in 15 Posts

    oh Anthony,
    What point are you at?

    The quick steps are:
    1. Install OpenSSH on iPhone.
    2. From Windows PC, download WinSCP utility.
    3. Use WinSCP to connect to iPhone over WiFi.
    4. Locate preferences.plist file. (different locations between 1.1.4 or 2.0.x.
    5. Edit preferences.plist file as described for your firmware version and save to iPhone.
    6. Reboot iPhone.
    7. Check APN in Settings; make sure correctly set to wap.voicestream.com
    8. Turn off WiFi.
    9. Try Weather and Stocks app first.
    10. Then try Safari.

    Report your result here, or let us know if you get stuck on any step.
    Good Luck.

  20. The Following User Says Thank You to freshster For This Useful Post:

    xxbenbenxx (08-31-2008)

  21. #99
    What's Jailbreak?
    Join Date
    Jul 2008
    Posts
    19
    Thanks
    6
    Thanked 3 Times in 2 Posts

    AH thanks so much! everything works now after that lady resetted the status at tmobile! do you think i should change my IMEM number? to make it match with tmobile so they don't disable my internet again?

  22. #100
    Green Apple
    Join Date
    Oct 2007
    Posts
    71
    Thanks
    1
    Thanked 22 Times in 15 Posts

    I wouldn't mess with changing the imei.
    There should be no reason for T-Mobile to disable your T-Zones. You are paying for of and it shouldn't matter if you have an iPhone or not. I would suggest for you to leave it as it is and see if anything else happens.

    Keep in mind, no E showing normally suggests a problem with service or APN.

+ Reply
Page 5 of 8 FirstFirst ... 34567 ... LastLast
Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts