Results 1 to 2 of 2

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Reversing a change isn't working!

  1. #1
    Default Reversing a change isn't working!
    Oh lord - how i get myself into these situations, i don't know .....

    OK, so i wanted to do some cleanup of some old issues from my old themes and basically see if there was updates to these issues and maybe they are solved.
    I had TWO black icons with black backgrounds, you know the issue .... Facebook and Twitter icons.
    ok, so i followed the common instructions ....

    Use ssh, iFile or similar and navigate to
    System/Library/PrivateFrameworks/MobileIcons.framework
    On iOS6+ rename .....
    AppIconMask@2x~iphone.png
    SmallAppIconMask@2x~iphone.png
    [email protected]
    [email protected]
    to
    BAK_AppIconMask@2x~iphone.png
    BAK_SmallAppIconMask@2x~iphone.png
    [email protected]
    [email protected]

    (As i was using ifunbox, i didn't rename, i just dumped the four files onto my desktop and left them untouched)

    Respring your device using WinterBoard.
    Now the black background has been removed.

    I knew i was simply checking out the tradeoff, i knew i would get some square icons, but i decided that the dozens of square icons wasn't justified to fix TWO black background icons, and simply went back to ifunbox, and copied the four files back to the same directory.

    Respring and ...... i still got SQUARE icons!
    I've cleaned cache, switch off themes, hard reboot, you name it, those icons are staying square.

    On top of that, figuring i could fool it, i placed those four files into my theme at MyTheme\Bundles\com.apple.mobileicons.framework and that didn't help, so i also tried MyTheme\Folders\MobileIcons.framework
    and that also didn't work. I don't want this solution and would rather the OS have it's files acting correctly and not winterboard trying to fix.

    I'm at a loss to why this will not undo, I've use icleaner to remove cache as well as manually deleting all files
    var/mobile/Library/Caches/com.apple.IconsCache without my winterboard theme active.
    I even applied a total NEW theme (buuf) and the icons remained square (the ones that wasn't included in the buuf package like Camera+

    I know the appmask must be working again cause when i select an icon i see it darken when it wasn't when i experimented.

    What am i possibly missing here?

    Oh gawd, please tell me you know how to help me ....

  2. #2
    Crisis averted - AppIconMask issue; unable to restore to the original correctly

    Sorry to the people i bothered
    Last edited by Aiban; 04-19-2013 at 12:42 AM.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •