Results 1 to 7 of 7

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: UIImages Problem

  1. #1
    Default UIImages Problem
    Why is it that every time I try to theme uibuttonbar buttons in UIImages they always come out only white..when I SSH a colored image with these names they still come out as white..
    If anyone doesn't know what these buttons are, they are the bottom bar buttons in the safari app photos app and mail app...Is there any way around this??

    UIButtonBarPlay
    UIButtonBarAction
    UIButtonBarArrowLeft
    UIButtonBarArrowRight
    UIButtonBarBookmarks

  2. #2
    .artwork assassin Jato_BZ's Avatar
    Join Date
    Jan 2012
    Location
    New Zealand
    Posts
    3,169
    Thanks
    3,315
    Thanked 6,514 Times in 2,146 Posts

    I had a look at this. I too found that these images continued to be displayed white. It is displaying the modded image but appears white. I also I took off the "@2x" part of the file name to check it was displaying the modded image and the image size was increased confirming the WB theme overriding the Apple UIkit. Could this be an issue with Winterboard or perhaps a style code applied via the apple iOS? I thought it might have been a caching issue but I don't believe it is.

    Another option is to pack your own images and encrypt them via Dave Pecks tool and put it back into your phone to replace the default [email protected] file. Only problem is the themed images need to be exactly the same file size for it to work.
    Last edited by Jato_BZ; 04-18-2012 at 10:33 PM.
    Twitter ID: @Jato_BZ
    .artwork Assassin / Emoji Extractor

  3. #3
    .artwork assassin Jato_BZ's Avatar
    Join Date
    Jan 2012
    Location
    New Zealand
    Posts
    3,169
    Thanks
    3,315
    Thanked 6,514 Times in 2,146 Posts

    UPDATE: managed to put those 5 images in with the Shared@2x png directory and then encrypt as a "artwork" file SSHed that file back into my phone BUT still no luck with changing the colour of those UIButtonBar images...someone must know the answer to this...
    Twitter ID: @Jato_BZ
    .artwork Assassin / Emoji Extractor

  4. #4
    I always thought that maybe there is a UIImage that gives uibuttonbar buttons a white overlay so I've been trying to look for a white image in The artwork...but no luck....maybe it's true but idk..

  5. #5
    .artwork assassin Jato_BZ's Avatar
    Join Date
    Jan 2012
    Location
    New Zealand
    Posts
    3,169
    Thanks
    3,315
    Thanked 6,514 Times in 2,146 Posts

    I also had a look. It's hard to say really. Seems odd tho that I replaced my original [email protected] file with the modded UI buttons and they still displayed white. Yet this png will theme "[email protected]" just via Winterboard. Maybe it's a white overlay like u said but I couldn't find it.
    Twitter ID: @Jato_BZ
    .artwork Assassin / Emoji Extractor

  6. #6
    Man this is a mystery..SOmEONE must have an answer to this..Anyone??

  7. #7

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •