Page 2 of 2 FirstFirst 12
Results 21 to 39 of 39

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: 4.1 Help!

  1. #21
    iOS4.1 uses the FolderSwitcherBG.png now instead of the [email protected] so just change your [email protected] to FolderSwitcherBG.png & remove com.apple.SpringBoard.folderSwitcherLinen and you all set to go.
    Apple are Control freaks we need to stop them before they take over the world!!

  2. #22
    Livin the iPhone Life iNT3Rv3NTiONZz's Avatar
    Join Date
    Feb 2010
    Location
    Cambridge, U.K
    Posts
    1,512
    Thanks
    57
    Thanked 123 Times in 101 Posts

    Quote Originally Posted by rocky5 View Post
    iOS4.1 uses the FolderSwitcherBG.png now instead of the [email protected] so just change your [email protected] to FolderSwitcherBG.png & remove com.apple.SpringBoard.folderSwitcherLinen and you all set to go.
    No, iPhone 4 uses the @2x image, the other ones are for older devices, as you can see on my comment to make it work on 4.1 on iphone4 you need to clear "FolderSwitcherBG@2x aswell

  3. #23
    Quote Originally Posted by iNT3Rv3NTiONZz View Post
    No, iPhone 4 uses the @2x image, the other ones are for older devices, as you can see on my comment to make it work on 4.1 on iphone4 you need to clear "FolderSwitcherBG@2x aswell
    Dude I own an iphone4 I know they use @2x but for some reason on mine it uses FolderSwitcher.png try it remove [email protected] and clear cache respring and the image is still there, remove folderswitcher.png and it vanishes black background.

    I also don't have com.apple.SpringBoard.FolderSwitcher@2x in cache only the other one.

    And it was a clean install of 4.1 JB'in with Limerain.
    Last edited by rocky5; 10-13-2010 at 05:29 AM.

  4. #24
    Livin the iPhone Life iNT3Rv3NTiONZz's Avatar
    Join Date
    Feb 2010
    Location
    Cambridge, U.K
    Posts
    1,512
    Thanks
    57
    Thanked 123 Times in 101 Posts

    Quote Originally Posted by rocky5 View Post
    Dude I own an iphone4 I know they use @2x but for some reason on mine it uses FolderSwitcher.png try it remove [email protected] and clear cache respring and the image is still there, remove folderswitcher.png and it vanishes black background.

    I also don't have com.apple.SpringBoard.FolderSwitcher@2x in cache only the other one.

    And it was a clean install of 4.1 JB'in with Limerain.
    Hmmm I wondered y when I replaced the @2x image it also changed the normal one, thanks for that I'm sorry I doubted you
    Either way the above tutorial still works when you use @2x

  5. #25
    It's cool hope I don't have to restore again lol pain in the ***, I'm not entirely sure why mine is using the none @2x version.

    All other images use @2x

    Iphone4 32GB iOS4.1 JB'in - LimeRain

    OK restoring will let you know if it fixes its self.

    Update: Restored to stock 4.1 JB with greenposi0n and still mine uses FolderSwitcher.png lol so guess I'm going to system link the two that way one uses the other.
    Last edited by rocky5; 10-13-2010 at 07:16 AM.

  6. #26
    I have an iPhone 4, and this is what my file looks like, and I ran it, and it still didn't fix it.


    #!/bin/bash
    rm -f /private/var/mobile/Library/Caches/com.apple.springboard-imagecache*
    rm -rf /private/var/mobile/Library/Caches/SpringBoardIconCache
    rm -rf /private/var/mobile/Library/Caches/SpringBoardIconCache-small
    rm -rf /private/var/mobile/Library/Caches/com.apple.SpringBoard.folderSwitcherLinen
    rm -rf /private/var/mobile/Library/Caches/com.apple.SpringBoard.folderSwitcherBG@2x
    /usr/bin/killall SpringBoard

  7. #27
    Livin the iPhone Life iNT3Rv3NTiONZz's Avatar
    Join Date
    Feb 2010
    Location
    Cambridge, U.K
    Posts
    1,512
    Thanks
    57
    Thanked 123 Times in 101 Posts

    Err dno that's strange, have you replaced the image in springboard.app or are you relying on a theme?

  8. #28
    I have not replaced it, I'm simply using a theme. The strange thing is, the folder icons show the correct background, but when I open the folder, the default one is used.

  9. #29
    Livin the iPhone Life iNT3Rv3NTiONZz's Avatar
    Join Date
    Feb 2010
    Location
    Cambridge, U.K
    Posts
    1,512
    Thanks
    57
    Thanked 123 Times in 101 Posts

    Try replacing the actual image @ system/library/coreservices/springboard.app
    It should work then

  10. #30
    Aww, there's no other way?

    I've even deleted "private/var/mobile/Library/Caches/com.apple.SpringBoard.folderSwitcherLinen"

    and still no luck. ugh.

  11. #31
    Quote Originally Posted by iNT3Rv3NTiONZz View Post
    Here's a screeny just in case you don't believe me
    Thanks, this solve my problem from not showing the multitasking/folder background.

    But I have another question, I can see in your picture that when you click on a folder the backgrounded icons have the auto-create images of your theme, in mine, I click on a folder, the background from the folder change, but the other icons outside the folder change to the original icons from apple, is there something I need to do?

  12. #32
    Quote Originally Posted by bren132409 View Post
    Aww, there's no other way?

    I've even deleted "private/var/mobile/Library/Caches/com.apple.SpringBoard.folderSwitcherLinen"

    and still no luck. ugh.
    rename the [email protected] to FolderSwitcher.png in the theme then remove private/var/mobile/Library/Caches/com.apple.SpringBoard.folderSwitcherLinen and resring you be on the same boat as me and my brother.

    both our iphone 4 32gbs use FolderSwitcher.png instead of the @2x version.
    Apple are Control freaks we need to stop them before they take over the world!!

  13. The Following User Says Thank You to rocky5 For This Useful Post:

    bren132409 (10-13-2010)

  14. #33
    Quote Originally Posted by rocky5 View Post
    rename the [email protected] to FolderSwitcher.png in the theme then remove private/var/mobile/Library/Caches/com.apple.SpringBoard.folderSwitcherLinen and resring you be on the same boat as me and my brother.

    both our iphone 4 32gbs use FolderSwitcher.png instead of the @2x version.
    Awesome thanks! That worked!!

  15. #34
    Thank U Guys 2000% !!!!!!

  16. #35
    Quote Originally Posted by rocky5 View Post
    rename the [email protected] to FolderSwitcher.png in the theme then remove private/var/mobile/Library/Caches/com.apple.SpringBoard.folderSwitcherLinen and resring you be on the same boat as me and my brother.

    both our iphone 4 32gbs use FolderSwitcher.png instead of the @2x version.
    For some reason my iPhone 4 let me delete that cache one time and now ifile keeps telling me it can't be deleted. Guess I'll try iwipe.

  17. #36
    Default Problem 4.1 Background Multi Task Folder Problem
    Hello,

    This is the first time I am posting my problem at MMI. I have an iPhone 4 running on 4.1, jailbroken with pwnage for Mac. I have read and done all the fixes mentioned in this thread but had no joy.
    I can live with the multitask folder being grey but the half of the multitask bar is blacked out and I don't know how to fix it. See the attached pic.
    I initially replaced the FolderSwitcherBG.png (640x720) and [email protected] files at Coreservices/springboard.app.
    Cleared the cache. When I did this the attached pic is how my multitask folder looked like. Tried to replace the files with the original png files, deleted the @2x.png file but the problem remained after deleting the cache and using iwipe with the added two extra program lines.
    Hoping someone could shed some magic solution to my problem.
    Attached Thumbnails Attached Thumbnails -img_1261.png   -img_1262.png  

  18. #37
    Hi,
    It's me again. I did all the step by step instructions again on previous pages and I don't know what I did but my problem is now fixed!I have customised by multitask bar and folder!!

  19. #38
    Quote Originally Posted by iNT3Rv3NTiONZz View Post
    If this doesn't work for anyone on an iphone4 try doing exactly the same but then add this line
    rm -rf /private/var/mobile/Library/Caches/com.apple.SpringBoard.folderSwitcherBG@2x
    And it should work
    P.S make sure you add the line
    with "Linen" in as stated in flybritn's instructions
    Any fix for iphone4 on 4.2.1?
    I manually deleted the new 4 switcher linens but i cant get it to work with iwipe?

  20. #39
    Livin the iPhone Life iNT3Rv3NTiONZz's Avatar
    Join Date
    Feb 2010
    Location
    Cambridge, U.K
    Posts
    1,512
    Thanks
    57
    Thanked 123 Times in 101 Posts

    Quote Originally Posted by iJa1lbreak View Post
    Any fix for iphone4 on 4.2.1?
    I manually deleted the new 4 switcher linens but i cant get it to work with iwipe?
    Sorry I havnt been using winterboard since 4.2. Um the only reason I can think of as to why it won't still work is that the caches location may have changed or the folderswitcherlinen has a new name.. Go to the cache directory and have a look at the files.
    If they are still the same then it is incompatibility issues between iwipe and 4.2.1
    Hope this helps

Page 2 of 2 FirstFirst 12
Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •