+ Reply
Results 1 to 8 of 8

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: I can't get downloaded themes to work with Winterboard (I'm new at this)

is a discussion within the

Skinning / Themes Discussion

forums, a part of the

Design and Media For the iPhone / iPod Touch

section;
First of all, I'd like to apologize if you're not supposed to ask questions like this in this forum. I'm having a terrible time navigating ModMyi. Anyways, my problem: because
...
  1. #1
    What's Jailbreak? TheSmartGuy's Avatar
    Join Date
    Jul 2010
    Posts
    27
    Thanks
    16
    Thanked 2 Times in 1 Post
    Default I can't get downloaded themes to work with Winterboard (I'm new at this)
    First of all, I'd like to apologize if you're not supposed to ask questions like this in this forum. I'm having a terrible time navigating ModMyi.

    Anyways, my problem: because browsing Cydia for themes kills me, I tried downloading Winterboard themes from this site instead and spent about an hour trying to figure out how to move them to my jailbroken iPhone 2G (i.e. the first one). I finally decided to use DiskAid, which lets me browse through the iPhone without a SSH connection.

    My problem: Even after I move a ModMyi theme folder into "/private/var/stash/themes.*****", the theme doesn't work when I choose it on Winterboard. The themes that I installed on my iPhone with Cydia work fine, and as far as my mediocre computer skills can tell, they have virtually the same buildup as the themes that I installed from here. For example, these themes (from Cydia) work:



    But this theme from ModMyi doesn't work for me:




    I'm new at this, so what the hell am I doing wrong? I followed the guides on this site as best as I could (they weren't particularly helpful because I don't know anything about Macs or SSH). But the themes don't work - on one of them, I managed to get the background working, and that was it. Am I putting the themes in the wrong place? Is there something else that I have to do to get them to work?

    Also, yes, I have Summerboard turned on. And I've rebooted and reinstalled and respringed and everything. :P

    EDIT: I just downloaded another theme from here, and it worked with my iPhone (WOOO!). But why don't any of the other themes work?
    Last edited by TheSmartGuy; 07-16-2010 at 10:34 AM.

  2. #2
    Retired Moderator soulthoughts's Avatar
    Join Date
    Sep 2007
    Location
    Tacoma, WA
    Posts
    3,097
    Thanks
    333
    Thanked 603 Times in 506 Posts

    Sounds silly but are the themes checked and moved to the top of Winterboard?

  3. #3
    What's Jailbreak? TheSmartGuy's Avatar
    Join Date
    Jul 2010
    Posts
    27
    Thanks
    16
    Thanked 2 Times in 1 Post
    Quote Originally Posted by soulthoughts View Post
    Sounds silly but are the themes checked and moved to the top of Winterboard?
    Yes, yes they are. Give me some credit here. :P

    After all, I have gotten a FEW themes downloaded from here to work- it's just that a lot of them don't (even though look nearly identical in buildup on DiskAid).
    Last edited by TheSmartGuy; 07-16-2010 at 10:31 AM.

  4. #4
    What's Jailbreak?
    Join Date
    Jul 2010
    Posts
    4
    Thanks
    0
    Thanked 0 Times in 0 Posts

    open ssh the themes you downloaded from cydia over to your computer and look at the way they're structured. just try the best you can to reproduce what you know works.

    EDIT: what about the theme isnt working?

  5. #5
    What's Jailbreak? TheSmartGuy's Avatar
    Join Date
    Jul 2010
    Posts
    27
    Thanks
    16
    Thanked 2 Times in 1 Post
    Quote Originally Posted by locketheleisz View Post
    open ssh the themes you downloaded from cydia over to your computer and look at the way they're structured. just try the best you can to reproduce what you know works.

    EDIT: what about the theme isnt working?
    Well, the point of using DiskAid was so that I don't have to use SSH. I couldn't figure SSH out, and the guides on this site weren't much help, since they were for a Mac-only program.

    Entire themes aren't working. When I drag the theme folder of this theme into theme.xxx with DiskAid and activate it on Winterboard, after the respring, no part of the homescreen changes. It's just the standard springboard; you wouldn't even be able to tell that the phone was jailbroken. For this theme, after I transferred and activated it (I had a hard time figuring out which folders were the themes), the homescreen gets a background, but the customized app icons and other features don't show up.

    I think the problem might be that I can't recognize which folders are themes (the latter theme had a couple of random folders). Or that my iPhone is just too old. I don't know if the themes are compatible with all models(?).

  6. #6
    Green Apple jdmss1's Avatar
    Join Date
    Jun 2010
    Posts
    77
    Thanks
    21
    Thanked 13 Times in 13 Posts

    I am somewhat new to this too, so pardon this question, but is it possible that some of the themes won't work with the 2G or your current firmware? Just wondering if that's possible

  7. #7
    What's Jailbreak?
    Join Date
    Jul 2010
    Posts
    15
    Thanks
    19
    Thanked 0 Times in 0 Posts

    Here is a try. Put .theme at the end of the theme.

  8. #8
    Super Duper Moderator blkcadi's Avatar
    Join Date
    Aug 2008
    Location
     Valley of the Sun, ARIZONA ♥♥♥
    Posts
    30,602
    Thanks
    3,745
    Thanked 9,669 Times in 5,934 Posts

    Perhaps try iWipeCache from Cydia and run it, you may have a theme that was installed that had auto-create icons.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts