Results 1 to 17 of 17

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: illumine them "issue" ???

  1. #1
    Default illumine them "issue" ???
    First off, I want to say that I absolutely love the illumine theme, but i noticed this little thing the other day. no matter what i install, even if I dont have the illumine theme checked in winterboard, the icons from cydia and app store become illumine'ed. I can even go to the app store and view the apps on there in illumine icons!?! its weird. right now its not a huge issue because i keep my phone for the most part on the illumine theme, but if i uncheck it, icons that arent covered in the theme i choose, look like illumine theme. its like forever themed onto everything!! anyone else notice this??-camera-roll-6.jpg
     White iPhone 3Gs - 32Gb 

  2. #2
    bumpy bumpy
     White iPhone 3Gs - 32Gb 

  3. #3
    iPhoneaholic eatjello's Avatar
    Join Date
    Nov 2008
    Location
    Leesburg, Virginia
    Posts
    329
    Thanks
    9
    Thanked 56 Times in 41 Posts

    holy crap i didnt even notice, i got the theme last night, and i just saw this lol. just SSH into the phone and delete the theme and icons

  4. #4
    ^ but i like the theme! lol, i just want to be able to change to a different theme from time to time. Theres no way that the creator of this theme has done EVERY ICON EVER, is there? Its just weird!
     White iPhone 3Gs - 32Gb 

  5. #5
    iPhoneaholic eatjello's Avatar
    Join Date
    Nov 2008
    Location
    Leesburg, Virginia
    Posts
    329
    Thanks
    9
    Thanked 56 Times in 41 Posts

    he updates it regularly.. the one from the mac themes repo gets updated like every other day, if you SSH into your phone, and go to the icons folder of the theme.. you'll see how many icons there are... 1800+

  6. #6
    My iPhone is a Part of Me iTJ's Avatar
    Join Date
    Apr 2009
    Location
    North Augusta, SC
    Posts
    527
    Thanks
    33
    Thanked 287 Times in 196 Posts

    I had this problem once before with a different theme. For some reason my iPhone wigged out and all my icons were stuck with that theme. I even tried to SSH to remove the theme, but it kept reappearing in WinterBoard. I removed WinterBoard and my icons changed to normal, but as soon as I reinstalled it, the icons were back to the theme. I was beta testing several different things at the same time, so I think that's what caused the wigout, but it resulted in a restore.
    New MacBook Pro - $1199.99
    New iPhone 3Gs - $199.99
    AT&T iPhone Plan - $89.99/month

    Modding your new iPhone against Apple's wish with friends on MMi - Priceless

  7. #7
    thats pretty wierd, considering I mostly always use the illumine theme and my app store icons are fine!

  8. #8
    Livin the iPhone Life
    Join Date
    Oct 2007
    Location
    Alaska
    Posts
    1,021
    Thanks
    41
    Thanked 116 Times in 113 Posts

    ive been using illumine theme for a couple weeks with no problems. I can change themes fine and app store apps show up as stock icons.

  9. #9
    I think the issue is with the icon mask being used. I added the icon mask so even if an ILLUMINE icon wasnt available, it would display the original with a glow. You can simply remove the icon mask files from the theme folders below (be aware that the original icons for some apps may be worse then having the glow on the Appstore.)

    /UIImages/AppIconMask.png
    /UIImages/AppIconOverlay.png
    /UIImages/AppIconShadow.png

    More updates at my site: http://projects.soundpostmusic.com/
    Last edited by interstink; 08-08-2009 at 10:48 PM.

  10. #10
    Super Duper Moderator blkcadi's Avatar
    Join Date
    Aug 2008
    Location
     Valley of the Sun, ARIZONA ♥♥♥
    Posts
    31,791
    Thanks
    4,109
    Thanked 10,458 Times in 6,372 Posts

    A reason I like this theme so much is because of those UIImages, and yes I never really noticed that either.

  11. #11
    Removing the mask wont make ILLUMINE glow disappear altogether, ONLY on icons that are not made (In the icons folder) or miss-spelled.

  12. #12
    Super Duper Moderator blkcadi's Avatar
    Join Date
    Aug 2008
    Location
     Valley of the Sun, ARIZONA ♥♥♥
    Posts
    31,791
    Thanks
    4,109
    Thanked 10,458 Times in 6,372 Posts

    ^ yup +1

  13. #13
    Well now in 3.1 the mask doesnt work for icons on springboard lol but if you really do not want them like that just delete the mask then restart the phone then they are gone =P but i REALLY want them back in 3.1 cause a new theme i am working on depends on this lol

  14. #14
    Quote Originally Posted by interstink View Post
    I think the issue is with the icon mask being used. I added the icon mask so even if an ILLUMINE icon wasnt available, it would display the original with a glow. You can simply remove the icon mask files from the theme folders below (be aware that the original icons for some apps may be worse then having the glow on the Appstore.)

    /UIImages/AppIconMask.png
    /UIImages/AppIconOverlay.png
    /UIImages/AppIconShadow.png

    More updates at my site: http://projects.soundpostmusic.com/
    Actually, I believe the issue is not caused by the UIImages but simply the icon cache itself. Try deleting the contents of /var/mobile/Library/Caches/SpringBoardIconCache. I am will to bet this will correct the icons to the current theme you are trying to use; assuming the three files of that theme are made correctly.
    /UIImages/AppIconMask.png
    /UIImages/AppIconOverlay.png
    /UIImages/AppIconShadow.png
    At the very least it should remove the mask of the old theme. I hope all this makes sense.

  15. The Following User Says Thank You to GopherTee For This Useful Post:

    zoblue (11-04-2009)

  16. #15
    Quote Originally Posted by GopherTee View Post
    Actually, I believe the issue is not caused by the UIImages but simply the icon cache itself. Try deleting the contents of /var/mobile/Library/Caches/SpringBoardIconCache. I am will to bet this will correct the icons to the current theme you are trying to use; assuming the three files of that theme are made correctly.
    /UIImages/AppIconMask.png
    /UIImages/AppIconOverlay.png
    /UIImages/AppIconShadow.png
    At the very least it should remove the mask of the old theme. I hope all this makes sense.

    SpringBoardIconCache delete...That helps with icons not getting themed.
    The above issue was about appstore icons getting themed from my Icon mask. Removing the mask will then show normal icons in the appstore but also cause icons not in the Illumine theme to show "Large" normal sized icons. I would leave the Mask alone.

  17. #16
    Oh i kno, i hate that. Ilove illumine but i want to change some things, but the icons still stay. someone needs to email the guy who made it

  18. #17
    Quote Originally Posted by interstink View Post
    I think the issue is with the icon mask being used. I added the icon mask so even if an ILLUMINE icon wasnt available, it would display the original with a glow. You can simply remove the icon mask files from the theme folders below (be aware that the original icons for some apps may be worse then having the glow on the Appstore.)

    /UIImages/AppIconMask.png
    /UIImages/AppIconOverlay.png
    /UIImages/AppIconShadow.png

    More updates at my site: http://projects.soundpostmusic.com/
    Where did you get these files? my theme doesn't have them. I have quite the opposite of this problem. I had all of my icons (even ones without ILLUMINE icons, as well as app store icons) illumin themed. I restored with a newer firmware and reinstalled everything, and now i have mismatched icons, as well as all app store icons in their original format. How do I theme EVERYTHING back?

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •