+ Reply
Results 1 to 10 of 10

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Really weird problem when replacing AppStore icons...

is a discussion within the

Skinning / Themes Discussion

forums, a part of the

Design and Media For the iPhone / iPod Touch

section;
this is only happening when i replace icons for apps from the AppStore... not anything else like phone, mail, etc, or ones from Cydia.. only AppStore ones. when i replace
...
  1. #1
    iPhone? More like MyPhone
    Join Date
    Nov 2007
    Posts
    258
    Thanks
    1
    Thanked 16 Times in 14 Posts

    Default Really weird problem when replacing AppStore icons...
    this is only happening when i replace icons for apps from the AppStore... not anything else like phone, mail, etc, or ones from Cydia.. only AppStore ones.

    when i replace the icon with one of my choice, the top cresent part of the icon which is normally just slightly brighter than the bottom, is WAY brighter than normal.

    I can view it on my computer and it looks fine, but then as soon as i put it on the phone it makes the top portion of the icon right about the bended split line like most icons have, much much brighter...

    if i put the icon on the phone, it does this, and then pull it back off and view it, its right back to normal.

    what the hell would cause this? i find it really weird....

    anyone else replaced and AppStore app icon and had this happen?

    heres what im talking about... look at the WeatherBug and VNC icons. I replaced those with the ones i wanted, and compare them to the original icons and how they normally look.... see how much brighter on top they are??

    What would cause this?? and like i said it ONLY happens to AppStore apps i replace icons for. No other ones.



    Last edited by stylin97; 07-23-2008 at 10:23 PM. Reason: Automerged Doublepost

  2. #2
    What's Jailbreak?
    Join Date
    Oct 2007
    Posts
    10
    Thanks
    0
    Thanked 2 Times in 2 Posts

    Hey, i'm not sure about that, but just an idea , in the app dir , theres a plist , with a field with something like Icon Shine or soomething like that, change it to false...should work..

  3. #3
    iPhone? More like MyPhone
    Join Date
    Nov 2007
    Posts
    258
    Thanks
    1
    Thanked 16 Times in 14 Posts

    Quote Originally Posted by adajet51 View Post
    Hey, i'm not sure about that, but just an idea , in the app dir , theres a plist , with a field with something like Icon Shine or soomething like that, change it to false...should work..
    how do i view/edit plist files on a windows PC??

  4. #4
    iPhone? More like MyPhone
    Join Date
    Aug 2007
    Location
    Bay Area, CA
    Posts
    217
    Thanks
    20
    Thanked 33 Times in 26 Posts

    Yeah, I have the same shine in my icons as well. I don't really see the field mentioned but what adajet51 is saying sounds logical... May your Icon's shine on you!!

  5. #5
    iPhone? More like MyPhone
    Join Date
    Nov 2007
    Posts
    258
    Thanks
    1
    Thanked 16 Times in 14 Posts

    Quote Originally Posted by y0haan View Post
    Yeah, I have the same shine in my icons as well. I don't really see the field mentioned but what adajet51 is saying sounds logical... May your Icon's shine on you!!
    is yours only doing it with AppStore installed app icons as well?

    Ok now ive ran into another problem...

    it seems replacing the icons for AppStore apps causes the app to no longer work. I read somewhere that the icons are signed to the app and thats why they arent working.

    Is there any way around this??
    Last edited by stylin97; 07-24-2008 at 07:30 AM. Reason: Automerged Doublepost

  6. #6
    Theme Creator Doreen's Avatar
    Join Date
    Jul 2007
    Location
    Southern California
    Posts
    2,585
    Thanks
    2,696
    Thanked 2,469 Times in 1,164 Posts

    I've tried "everything" a few times I thought I got it and was able to swap out the icons for my app store programs but after you reboot your iphone "then" suddenly your app will no longer launch. =(

    Seems the icons are now hardcoded into the app or something?

  7. #7
    iPhone? More like MyPhone
    Join Date
    Nov 2007
    Posts
    258
    Thanks
    1
    Thanked 16 Times in 14 Posts

    i figured out how to change the icons.

    save the original icon, use Fix PNG to convert it so you can actually view/edit it, open it in photoshop or whatever else and just lay the new icon you want to use over top of it. Works great and keeps the app working.

    i still cant figure out how to get rid of the extra shine tho.

  8. #8
    Theme Creator Doreen's Avatar
    Join Date
    Jul 2007
    Location
    Southern California
    Posts
    2,585
    Thanks
    2,696
    Thanked 2,469 Times in 1,164 Posts

    iphonebrowser will actually convert the .png automatically so that is exactly what I did w/ the icon after I edited it and transfered it back to my phone it "seemed" to work just fine, the app launched few times "until" I rebooted my phone then the app would not launch again.

  9. #9
    What's Jailbreak?
    Join Date
    Apr 2008
    Posts
    6
    Thanks
    0
    Thanked 0 Times in 0 Posts

    If the app doesn't want to start after u replaced the icon, follow these instructions:

    http://www.modmyi.com/forums/skinnin...d-working.html

    But the shine is really a big problem . Some apps have an information stored somewhere, which gives the icon this shine on top. Because it is only on some of them, there must be a way to deactivate this shine option. I was told that something like this is stored in the original .ipa file, some say it's in the info.plist. Whatever, i can't edit both of these proberly. So any suggestions?

  10. #10
    What's Jailbreak?
    Join Date
    Apr 2008
    Posts
    6
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Got it guys!

    Simply install WinterBoard through Cydia and in "Library/Themes/" u create a folder (doesn't matter what). Mine is called "Custom.theme". Now in "Library/Themes/Custom.theme" you create a new folder called "Icons". And in that folder u can put whatever icon you like, but make sure you name it after the app's name. After that you start WinterBoard and select your "Custom" Theme. You also may reboot your iPhone/iPod.

    This method works for me.
    Let me know, if you still have problems

    Malte

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts