+ Reply
Results 1 to 2 of 2

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Data service not working on jailbroken iPhone

is a discussion within the

redsn0w

forums, a part of the

Jailbreak / Downgrading / Upgrading

section;
This is a long post, but if anyone could help me out that would be marvelous. I just got my iPhone 4s last week and everything worked just fine. When
...
  1. #1
    What's Jailbreak?
    Join Date
    Sep 2012
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default Data service not working on jailbroken iPhone
    This is a long post, but if anyone could help me out that would be marvelous.

    I just got my iPhone 4s last week and everything worked just fine. When I got home I went on iClarified and jailbroke my phone with redsn0w 0.9.12b2. I have iPhone 4s version 5.1.1 with firmware 2.0.12.

    The jailbreak was successful but for a reason that I cannot fathom I keep getting this message "Could not activate cellular data network. You are not subscribed to a cellular data service." However, I have a data plan that I'm paying an arm and a leg for.

    I've tried restoring with the shsh blobs but when I put it in pwned DFU mode it says 4s isn't compatible. I tried the APN thing and it says I have more than one profile (I don't), and I called my service provider (Fido) and they say everything is in order and they don't know why it isn't working.

    Now I really really REALLY don't want to restore and update to iOS 6, I don't even know if that would work. Any ideas on what I could possibly do to get the 3G and data to work?

    PS
    I read somewhere that a person purposely disabled their phone and went to Apple and got a new one. Is that too risky?

  2. #2
    EVO
    EVO is offline
    Super EVO Moderator EVO's Avatar
    Join Date
    Dec 2009
    Posts
    3,519
    Thanks
    107
    Thanked 803 Times in 489 Posts

    and you have already called FIDO to confirm the correct APN and that correct APN was properly configured on your phone?

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts