+ Reply
Results 1 to 13 of 13

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: [FIX] - 4.3.1 HTTP/1.1 404 Not Found Errors in Cydia

is a discussion within the

redsn0w

forums, a part of the

Jailbreak / Downgrading / Upgrading

section;
I have seen many complaints over the past few days indicating after upgrade to 4.3.1 with redsn0w, that Cydia now reports HTTP/1.1 404 Not Found for several of the default
...
  1. #1
    What's Jailbreak?
    Join Date
    Mar 2011
    Posts
    10
    Thanks
    0
    Thanked 10 Times in 6 Posts

    Default [FIX] - 4.3.1 HTTP/1.1 404 Not Found Errors in Cydia
    I have seen many complaints over the past few days indicating after upgrade to 4.3.1 with redsn0w, that Cydia now reports HTTP/1.1 404 Not Found for several of the default repositories. For the life of me, I don't know why this happens, but I do know how to fix it (essentially reset Cydia). Using this method, I have restored Cydia to normal working condition on both my iPhone and iPad. Some folks will say that this is a pain in the *** compared to using apps like Cyfix, but this works and Cyfix does not (for this case).

    General notes:

    1.) Do not delete any directories *ever* (just files) or Cydia will fail to open
    2.) Write down your custom repos as Cydia will restart with only the default installed
    3.) If you can't find iFile (bigboss?), you will have to use mobile terminal or ssh


    Here is the step-by-step:

    1.) Download iFile from Cydia (not app store). It is $4, but has a free trial. Well worth it if you are uncomfortable with the command line (has a very nice GUI).
    2.) Open iFile and navigate to /var/lib/apt/lists/partial/
    3.) Delete all files in the directory (leave the directory or Cydia will crash)
    4.) Navigate up one dir to /var/lib/apt/lists/
    5.) Delete all files in this directory (the only thing this directory should contain is the empty partial folder)
    6.) Navigate to /var/lib/cydia
    7.) Delete metadata.plist
    8.) Navigate to /etc/apt/sources.list.d/
    9.) Delete all files in here including cydia.list
    10.) Exit and respring
    11.) Start Cydia and rejoice at the lack of 404 errors


    Hope this helps...

  2. The Following 5 Users Say Thank You to Kenbot74 For This Useful Post:

    abulara (04-17-2011), Ashengrace (04-07-2011), Ech0riginal (04-15-2011), FonKaizoku (04-10-2011), Rahllin (04-16-2011)

  3. #2
    What's Jailbreak?
    Join Date
    Oct 2010
    Posts
    19
    Thanks
    0
    Thanked 2 Times in 2 Posts

    This works like a charm! Error gone!

  4. #3
    What's Jailbreak?
    Join Date
    Dec 2009
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    You sir, deserve a medal

  5. #4
    ojb
    ojb is offline
    What's Jailbreak?
    Join Date
    Apr 2011
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Hi,

    in another forum I read that to delete the metadata.plist is ok.

    I tried this and everything seems to work correctly now.

    What is the purpose of the other files? Do I have to delete them?
    Or is metadata.plist only ok?
    Or do I have then inconstent data?

    Thank you in advance.

    Greetings from Munich, Bavaria, Germany
    Oli

  6. #5
    iPhone? More like MyPhone Ashengrace's Avatar
    Join Date
    Sep 2010
    Posts
    176
    Thanks
    24
    Thanked 95 Times in 45 Posts

    OMFG, thank you! You are truly a life saver, i was at my wits end with that sheeeit.

  7. #6
    What's Jailbreak?
    Join Date
    Jun 2009
    Posts
    13
    Thanks
    3
    Thanked 0 Times in 0 Posts

    Thank youuuuuuu!!!!!!!!!!!!

  8. #7
    What's Jailbreak?
    Join Date
    Aug 2007
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts

    This worked for me too, thank you.

    BTW: in terms of which repos you need to write down to add later. These were added automatically via Cydia (at least for me):
    apt.thebigboss.org/repofiles/cydia
    apt.modmyi.com
    repo666.ultrasno0w.com
    cydia.zodttd.com/repo/cydia

  9. #8
    What's Jailbreak?
    Join Date
    Feb 2008
    Posts
    4
    Thanks
    1
    Thanked 0 Times in 0 Posts

    My friend after doing all these steps I lost all the repos and now if I want to add any I still having the same error pls help and thx

  10. #9
    What's Jailbreak?
    Join Date
    Feb 2011
    Posts
    7
    Thanks
    0
    Thanked 0 Times in 0 Posts

    This worked like a charm, thank you!

  11. #10
    What's Jailbreak?
    Join Date
    Oct 2011
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default help!
    now i cant open cydia. why?

  12. #11
    What's Jailbreak?
    Join Date
    Jan 2012
    Location
    Rushall, Walsall, United Kingdom, United Kingdom
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    hi this complicated for me to try lol im a woman who's learning & affraid to mess my phone up, & I was wondering if you could help me plz I've installed siri but it still wont work for me thx

  13. #12
    What's Jailbreak?
    Join Date
    Sep 2012
    Location
    Talisay, Cebu, Philippines
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts

    i still have the same error when i try ti install icleaner and other apps, i did everyting as stated here, but still nothing,,

  14. #13
    What's Jailbreak?
    Join Date
    Dec 2013
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts

    In step 2, I don't have the apt option, and I was wondering if there is a way to get it or to get around it

    Quote Originally Posted by theguythatneedshelp View Post
    In step 2, I don't have the apt option, and I was wondering if there is a way to get it or to get around it
    Nevermind I figured it out, thanks so much for the help
    Last edited by theguythatneedshelp; 12-12-2013 at 02:14 PM.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts