+ Reply
Results 1 to 5 of 5

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: iPhone 3GS 6.15 Baseband Unlock and Jailbreak on 4.2.1

is a discussion within the

redsn0w

forums, a part of the

Jailbreak / Downgrading / Upgrading

section;
I brought this phone and it was already jailbroken and unlocked on 4.2.1. While I was syncing the phone, it crapped out and wouldn't boot. So I tried to restore
...
  1. #1
    Green Apple
    Join Date
    Sep 2010
    Posts
    48
    Thanks
    1
    Thanked 8 Times in 8 Posts

    Default iPhone 3GS 6.15 Baseband Unlock and Jailbreak on 4.2.1
    I brought this phone and it was already jailbroken and unlocked on 4.2.1.

    While I was syncing the phone, it crapped out and wouldn't boot. So I tried to restore it via itunes but it kept throwing up 1015 errors. I tried using TinyUmbrella and Recboot to boot out of recovery but it didn't work.

    I believe the original owner of the iPhone has updated the baseband to 6.15 and used redsn0w or pwnagetool to unlock and jailbreak.

    So I tried using redsn0w to restore it following the guide here.

    It jailbroke fine and went through the whole process but while "Installing Activation Bundles" on the phone, it stalled. I left it for almost 10min but nothing happened at all. I rebooted the phone and it went back to recovery mode. I thought that it may have worked but wouldn't boot because of the tethered jailbreak. So I ran redsn0w and booted with that and the phone came up with the pineapple but hung at that screen for almost 5min.

    Help?
    If I have helped in any way, please hit the "Thanks" button

  2. #2
    Green Apple
    Join Date
    Sep 2010
    Posts
    51
    Thanks
    8
    Thanked 1 Time in 1 Post
    This sounds similar to the problem i also have... and i would appreciate some help too.

  3. #3
    Green Apple
    Join Date
    Sep 2010
    Posts
    48
    Thanks
    1
    Thanked 8 Times in 8 Posts

    I managed to get it working.

    I first restored to official 4.2.1 in iTunes and then when it gave the 1015 error, I used greenpoison to jailbreak.

    This got me to the activation screen on my phone.

    I then went through and used redsn0w as detailed in the link above. This activated the phone but still kept my untethered jailbreak from greenpoison.

    Then I installed untrsn0w to unlock.

    Hope this helps some people.
    If I have helped in any way, please hit the "Thanks" button

  4. #4
    What's Jailbreak? FISH5742's Avatar
    Join Date
    Feb 2011
    Posts
    25
    Thanks
    2
    Thanked 0 Times in 0 Posts

    I recently had the same trouble with mine. I have the 6.15 baseband in my 3GS. What worked for me was
    1: download redsnow & your regular firmware for your device.
    2: download the custom firmware with 6.15 already stored within @ a website called megaupload.
    3: open redsnow, click browse & select the regular firmware for your device & select the box that says "just enter pwned dfu mode right now". Follow the on screen instructs.
    4: open iTunes. Hold down shift & select restore. This will allow you to browse which file you want to use for the restore process. Use the custom firmware ( the one with the ipad baseband already in it) that you dled @ the megaupload site ( not the regular firmware).

    This should allow you to restore you iPhone successfully. After that you can jb & unlock with the custom firmware that has the 6.15 baseband in it.
    However I recommend using the green poison once you've restored. It's untethered so you don't have to use redsnow everytime you turn your phone off & it doesnt crash nearly as much as it does when you use redsnow.
    Hope that helps

  5. #5
    Green Apple
    Join Date
    Sep 2010
    Posts
    51
    Thanks
    8
    Thanked 1 Time in 1 Post
    I think my problem is with the hardware. I've jailbroken several devices and never seen the issues that I'm having. My problem is that iTunes will not activate the handset even with an official carrier sim

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts