+ Reply
Page 1 of 2 12 LastLast
Results 1 to 20 of 32

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: iPhone 3GS 4.2.1 (new bootrom stuck in Recovery Mode)

is a discussion within the

redsn0w

forums, a part of the

Jailbreak / Downgrading / Upgrading

section;
...
  1. #1
    What's Jailbreak?
    Join Date
    Jan 2011
    Posts
    4
    Thanks
    3
    Thanked 0 Times in 0 Posts

    Unhappy iPhone 3GS 4.2.1 (new bootrom stuck in Recovery Mode)
    Background
    - Purchased 3GS on 4.2.1 that was not jailbroken or unlocked.
    - iPhone did operate using AT&T sim. No Cydia loaded so decided to jailbreak
    - I can’t 100% confirm but I think it was on baseband 6.15.00
    - I have confirmed it has new bootrom (359.3.2)
    Current state after performing steps below
    - Can’t get iPhone out of “Recovery Mode” (screen showing USB cable link to iTunes icon)
    - Tried Recboot 2.1 to get out of “Recovery Mode” with no success.
    Pwnage 4.1.3 attempts
    - As it is on new bootrom didn’t try using minimal 4.2.1bundle (Update 3# from dev team)
    - 4.1.3 does not recognize “iPhone2,1_4.2.1_8C148a_Restore.ipsw” (Simple Mode) or says “Wrong Firmware Bundle Selected” (Expert Mode)
    Initial run of RedSn0w 0.9.6b5
    - Didn’t restore to original ISPW as it was already installed (did confirm):
    - First run of RedSn0w appeared to work fine but Cydia icon didn’t show correctly (white outline?) and previous apps still loaded.
    - Didn’t check baseband (stupid me)
    - Used Settings/General/Erase all to clean out apps
    Second and Subsequent runs of RedSn0w 0.9.6b5
    - Hung trying to “Install Activation Bundles” or “Flashing Baseband”
    - Leaves iPhone in “Recovery Mode”
    Attempt to install original ISPW
    - iTunes fails with error 1015 (“An unknown error occurred”) during restore
    Attempt to install to custom 4.1 ISPW
    “this iPhone isn’t eligible for the requested build”

  2. #2
    Super Moderator iYeow's Avatar
    Join Date
    Feb 2008
    Location
    Vancouver, Canada
    Posts
    13,926
    Thanks
    76
    Thanked 2,751 Times in 2,641 Posts

    You need to run redsn0w 0.9.6rc8 , browse to stock 4.2.1, then check only the box dfu mode.
    Once dfu is done, run itunes : shift + restore to cfw of 4.2.1
    Run redsn0w again , choose install Cydia and tether boot after restoring to cfw of 4.2.1 ( in your PM box )

  3. The Following 3 Users Say Thank You to iYeow For This Useful Post:

    alnath (01-10-2011), cornishpd (01-11-2011), jorjjj (02-05-2011)

  4. #3
    What's Jailbreak?
    Join Date
    Jan 2011
    Posts
    4
    Thanks
    3
    Thanked 0 Times in 0 Posts

    Default Update after using RedSn0w 0.9.6rc8 and custom 4.2.1 firmware
    I had some trouble downloading the "iPhone2,1_4-1.2.1_8C148a4.2.1Custom_Restore.ipsw" file using Safari because I think it automatically UNZIPs file after download. I did get Safari to not unzip by changing name to "ipsw" file as it was downloading. (I am re-trying download with Firefox and will re-try below.

    - First run of redsn0w 0.9.6rc8 (to place in DFU Pwnage mode)
    - Successful and leaves screen blank (DFU mode)
    - Used iTunes to restore custom 4.2.1 (provided by modmyi)
    - Leaves in recovery mode requesting SIM card
    - Put in T-Mobile SIM card
    - Second redsn0w 0.9.6rc8 run to Install Cydia
    - Tried selecting custom 4.2.1 but got error Unable to recognize specified IPSW
    - Pointed to original 4.2.1 firmware and selected just Install Cydia
    - After final action re-boot (apple logo) hung

    I assume the second run of redsn0w 0.9.6rc8 has to use original 4.2.1 firmware and that I can't "Install Cydia" and "Run tethered" both at the same time.

    Do I need to re-do some of the above and do something different?

  5. #4
    Super Moderator iYeow's Avatar
    Join Date
    Feb 2008
    Location
    Vancouver, Canada
    Posts
    13,926
    Thanks
    76
    Thanked 2,751 Times in 2,641 Posts

    When you run redsn0w, always browse to stock firmware. Choose install Cydia first, if it doesn't boot up , then rerun redsn0w and choose tether boot.

  6. The Following User Says Thank You to iYeow For This Useful Post:

    cornishpd (01-11-2011)

  7. #5
    What's Jailbreak?
    Join Date
    Jan 2011
    Posts
    4
    Thanks
    3
    Thanked 0 Times in 0 Posts

    Default Success!
    You rock as I have now successfully jailbroken/unlocked 3GS on 4.2.1. Thank you so much for your knowledge and patience. You have made me niece (her 17th birthday 3GS) a very happy young lady!

    I have just one follow up question. Is it true that every time my niece has to re-boot phone that she has to run redSn0w and run untethered? If so, is this likely to be a fix for this upcoming?

    Thanks

    Peter

  8. #6
    Super Moderator iYeow's Avatar
    Join Date
    Feb 2008
    Location
    Vancouver, Canada
    Posts
    13,926
    Thanks
    76
    Thanked 2,751 Times in 2,641 Posts

    Just run tether boot again if you ever power down. Regarding untethered, we will have to wait for either the dev team or Geohot to come up with their magic.

  9. The Following User Says Thank You to iYeow For This Useful Post:

    cornishpd (01-11-2011)

  10. #7
    What's Jailbreak?
    Join Date
    Jan 2011
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts

    iyeow,i wrote you pm

    i hope you can help me

    edit: but i dont know if you get the message
    its not listed in "sent items"
    Last edited by JaxParrow; 01-13-2011 at 03:44 PM.

  11. #8
    iPhone? More like MyPhone Mysterion's Avatar
    Join Date
    Jan 2011
    Posts
    197
    Thanks
    1
    Thanked 1 Time in 1 Post
    pm me that file too iYeow

  12. #9
    What's Jailbreak?
    Join Date
    Jan 2011
    Posts
    3
    Thanks
    1
    Thanked 0 Times in 0 Posts

    Default I need help!
    I have the same issue as Cornishpd,
    Tried to jailbreak and unlock my new 3GS phone the new one.Actually I updated first to 4.2.1 then jailbreak and update the baseband to 6.15 (I shouldn't).
    Now I have iTune logo along with usb cable is sitting on my phone forever.
    I don't know exactly the firmware of my phone initially. I guess 4.1. I believed I updated to 4.2.1 before the jailbreak through redsnow then after unlock it by Cydia package on the iphone after I hit the booting button and the iphone came up forever on the recovery mode and I couldn't restore it back to 4.2.1 through iTune forever error 1015.Is there any best customized firmware for this? I used different customized ones but no luck.
    Thanks for the help!

  13. #10
    What's Jailbreak?
    Join Date
    Jan 2011
    Posts
    4
    Thanks
    3
    Thanked 0 Times in 0 Posts

    Default Armk - Here are the steps that helped me!
    Yeow stated the following in the #2 post in this thread:

    "You need to run redsn0w 0.9.6rc8 , browse to stock 4.2.1, then check only the box dfu mode.
    Once dfu is done, run itunes : shift + restore to cfw of 4.2.1
    Run redsn0w again , choose install Cydia and tether boot after restoring to cfw of 4.2.1."

    I will place the link to 4.2.1 cfw in a PM

  14. #11
    What's Jailbreak?
    Join Date
    Jan 2011
    Posts
    3
    Thanks
    1
    Thanked 0 Times in 0 Posts

    Thank you so much for the file.
    I am getting now error 1600 in iTune while doing restore to cfw of 4.2.1 in the last stage.

  15. #12
    What's Jailbreak?
    Join Date
    Jan 2011
    Posts
    4
    Thanks
    0
    Thanked 2 Times in 2 Posts

    Default Help
    Please can you PM the file thanks

  16. The Following User Says Thank You to Trikki For This Useful Post:

    Armk (01-29-2011)

  17. #13
    What's Jailbreak?
    Join Date
    Jan 2011
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Can you send me the custom ipsw file for 3GS with new bootrom. Thanks

  18. #14
    What's Jailbreak? SlimSilver's Avatar
    Join Date
    Jan 2011
    Location
    Alberta, Canada
    Posts
    9
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Hi there, I also am having the problem with an iphone 3g stuck with error 1015 when trying to restore it.

    Do I do what was mentioned by Yeow? If so, can I get the custom ipsw?

  19. #15
    What's Jailbreak?
    Join Date
    Sep 2010
    Posts
    12
    Thanks
    0
    Thanked 1 Time in 1 Post
    Sounds like I need the custom IPSW too, pleeeeese Cornishpd, !!!!!!

    All of the solutions that I have read to these problems require you to start with the iphone connected to the PC and powered off.
    My iPhone is stuck in restore mode with the "connect to itunes" logo showing.
    I can turn the iphone off by holding down the power button for 4 or 5 seconds but as soon as I plug it into the PC it powers up to the itunes connect logo.
    Supposedly, if I hold down the power button I should get the slide to power off appear but the screen just goes blank. If I then release the power button the iphone starts up again.
    what should I do???
    Last edited by Desert_Dog; 01-29-2011 at 07:49 AM. Reason: Automerged Doublepost

  20. #16
    What's Jailbreak?
    Join Date
    Jan 2011
    Location
    College Station, Texas, United States
    Posts
    23
    Thanks
    1
    Thanked 1 Time in 1 Post
    Have no idea if this is ya'lls problem at all but I had a similar problem last night... If you have iTunes 10.1.1 and Wi-Fi Sync, a restore will not work (or it did not work for me), so you will need to uninstall Wi-Fi Sync, because it is overriding Apple's Mobile Device Services.

    You will then want to go to Control Panel, this goes for whether or not you have Wi-fi Sync...

    In the search bar type "Administrative Tools"

    Then in Administrative Tools click Services

    You will then right click Apple Mobile Device Support and click start (if already started, then stop it and restart)

    Then retry the restore

    Hopefully this works for you, if not then you may need to reinstall iTunes, but I would recommend following Apple's guidelines on uninstalling ALL parts of iTunes. This can be found in their support page.

  21. #17
    What's Jailbreak?
    Join Date
    Feb 2011
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Hello, I bought a Iphone 3gs and it was working fine but the battery was dying and i turned it off. I got home and it wouldn't get pass the apple logo. I connected it to itunes and restored it and I got error 1015. Turns out the phone was tethered with Redsn0w and i just had to Download Redsn0w and the 4.2.1 IPSW and "just boot tethered right now" Now my phone just shows the connect to iTunes image. What can i do to fix this?

    Thank you in advance!

  22. #18
    What's Jailbreak?
    Join Date
    Jan 2011
    Posts
    4
    Thanks
    0
    Thanked 2 Times in 2 Posts

    Quote Originally Posted by zionse7ennoiz View Post
    Hello, I bought a Iphone 3gs and it was working fine but the battery was dying and i turned it off. I got home and it wouldn't get pass the apple logo. I connected it to itunes and restored it and I got error 1015. Turns out the phone was tethered with Redsn0w and i just had to Download Redsn0w and the 4.2.1 IPSW and "just boot tethered right now" Now my phone just shows the connect to iTunes image. What can i do to fix this?

    Thank you in advance!
    you will need to boot your iPhone in to DFU mode using redsn0w.
    once in DFU you can restore it with a custom firmware.
    I will send you the link to the the custom firmware.

    Good Luck!

  23. #19
    What's Jailbreak?
    Join Date
    Apr 2008
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts

    I have exactly the same problem as you corn, can someone please send me a cfw file. PLEASE!!!!! PLEASE!!!!!thanks all

  24. #20
    What's Jailbreak?
    Join Date
    Feb 2011
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default Still need help!
    I have a 3gs and have the same problem as described before-- I'm stuck in recovery mode.

    It's new bootrom and I tried to JB it and unlock it with Redsnw. I also accidentlally upped it my baseband.

    The directions here sound great except that I don't have a custom 4.2.1 and when I try to create one, I can't direct itunes to it since Shift + restore doesn't work.

    Any ideas?

    I'd REALLY appreciate the help!

    Deebler

    Hi Yeow-- Can you PM the custom FW to me as well? I'm dead in the water!

    Thanks!!!

    Deebler
    Last edited by deebler; 02-04-2011 at 02:15 PM. Reason: Automerged Doublepost

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts