+ Reply
Results 1 to 16 of 16

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: iPhone 3G 4.2.1 NO DNS, NO WiFi

is a discussion within the

redsn0w

forums, a part of the

Jailbreak / Downgrading / Upgrading

section;
I am fairly versed in iPhone JB'ing and have used my resources (Google.com :0) and can't find an answer! I am hoping someone in this community will lend some coveted
...
  1. #1
    What's Jailbreak?
    Join Date
    Nov 2010
    Location
    Knoxville, TN
    Posts
    3
    Thanks
    17
    Thanked 0 Times in 0 Posts

    Exclamation iPhone 3G 4.2.1 NO DNS, NO WiFi
    I am fairly versed in iPhone JB'ing and have used my resources (Google.com :0) and can't find an answer! I am hoping someone in this community will lend some coveted and desperately need HeLP!

    Device: iPhone 3G yes the older version so NO tether JailBreak. Also this is not activated but was through AT&T. Sim is still inside.
    Firmware: I have tried this both on 4.1 Limera1n'd and currently 4.2.1 Redsn0w'd
    Problem: My iPhone 3G's DNS will not release a true IP address. Therefore I have zero internet access because I am not on a cell tower.
    Troubleshooting: I have reset ALL routers possible, I have tried this on MyWi (4.10.1) both my PSP and MacPros can connect to the networks. I obviously reset the firmware and reset the network options. I tried a static IP. I tried connection to my MacBook Pro Ad-Hoc network when I use USB tethering and still the dreaded 169.XXX.XXX.XXX address. The routers are NOT the problem as I can connect with them perfectly and the MiWi works as well. I disabled WEP, enabled WEP, changed SSID. As far as I can tell I am out of options.

    PLEASE HELP AS AN UNTETHER iPHONE 3G IS STILL USEFUL....thank you in advance!
    Last edited by lsills81; 11-24-2010 at 11:31 PM.

  2. #2
    What's Jailbreak? chinmay007's Avatar
    Join Date
    May 2009
    Posts
    19
    Thanks
    2
    Thanked 9 Times in 4 Posts

    i have the same problem. I am also running
    I foolishly updated the firmware on 3G and since then wifi problem is persisting.
    tried downgrading to 4.0 and 3.2.1 but all in vain.
    Some times its not even able to find the network
    Some help would be great.

  3. #3
    Super Moderator iYeow's Avatar
    Join Date
    Feb 2008
    Location
    Vancouver, Canada
    Posts
    13,935
    Thanks
    76
    Thanked 2,752 Times in 2,642 Posts

    Quote Originally Posted by chinmay007 View Post
    i have the same problem. I am also running
    I foolishly updated the firmware on 3G and since then wifi problem is persisting.
    tried downgrading to 4.0 and 3.2.1 but all in vain.
    Some times its not even able to find the network
    Some help would be great.
    Have you tried downgrading to 3.1.3 fw

  4. The Following User Says Thank You to iYeow For This Useful Post:

    lsills81 (11-26-2010)

  5. #4
    What's Jailbreak? chinmay007's Avatar
    Join Date
    May 2009
    Posts
    19
    Thanks
    2
    Thanked 9 Times in 4 Posts

    Quote Originally Posted by iYeow View Post
    Have you tried downgrading to 3.1.3 fw
    I m not sure how will it help? sure i will try.. downloading now..

    downgraded to 3.1.3. Still no luck. Also i am unable to save shsh on tiny umbrella for firmware 3.1.3. I have it saved for other firmwares.
    Last edited by chinmay007; 11-26-2010 at 12:52 AM. Reason: Automerged Doublepost

  6. The Following User Says Thank You to chinmay007 For This Useful Post:

    lsills81 (11-26-2010)

  7. #5
    Super Moderator iYeow's Avatar
    Join Date
    Feb 2008
    Location
    Vancouver, Canada
    Posts
    13,935
    Thanks
    76
    Thanked 2,752 Times in 2,642 Posts

    You don't need shsh blogs for 3g for 3.xx firmware. If you get error 1015, use exit recovery from tiny umbrella to kick it out.

  8. #6
    What's Jailbreak? chinmay007's Avatar
    Join Date
    May 2009
    Posts
    19
    Thanks
    2
    Thanked 9 Times in 4 Posts

    Quote Originally Posted by iYeow View Post
    You don't need shsh blogs for 3g for 3.xx firmware. If you get error 1015, use exit recovery from tiny umbrella to kick it out.
    There is no error. I could install 3.1.3, but the problem is persisting.
    No wifi network seen. On trying "choose a network" option, it says unable to scan for wifi networks.

  9. The Following User Says Thank You to chinmay007 For This Useful Post:

    lsills81 (11-26-2010)

  10. #7
    Super Moderator iYeow's Avatar
    Join Date
    Feb 2008
    Location
    Vancouver, Canada
    Posts
    13,935
    Thanks
    76
    Thanked 2,752 Times in 2,642 Posts

    Did you have this problem before you decided to do a restore.

  11. The Following 2 Users Say Thank You to iYeow For This Useful Post:

    chinmay007 (11-26-2010), lsills81 (11-26-2010)

  12. #8
    What's Jailbreak? chinmay007's Avatar
    Join Date
    May 2009
    Posts
    19
    Thanks
    2
    Thanked 9 Times in 4 Posts

    no , actually it started after i updated to 4.2GM with upadate to baseband (5.15.04 ). Since then there is no problem with jailbreaking (redsnow). Initially it use to show the networks available, but since last update to 4.2.1 it has stopped showing the networks as well.

  13. The Following User Says Thank You to chinmay007 For This Useful Post:

    lsills81 (11-26-2010)

  14. #9
    What's Jailbreak?
    Join Date
    Nov 2010
    Location
    Knoxville, TN
    Posts
    3
    Thanks
    17
    Thanked 0 Times in 0 Posts

    Default 3G No WiFi
    I got my 3G on 4.2.1 (I need this firmware to work) to recognize another Wifi router but after I re-jailbroke with Redsn0w (NOT installing Cydia each time) about 3 times it worked.

    NEW PROBLEM....I cant add "http://apt.saurik.com. It says it can't find the Repo. I of course MUST have this repo to install any apps as mobilesubstrate is VERY important. I am getting a little over my head here so I am counting on someone helping me out. I will continue posting until I get this to work. Thanks you guys!

    You should try Redsn0w.....very quick and after about 3 times re-jailbreaking it was about to get the phone to connect to the router. Let me know if that works.
    Last edited by lsills81; 11-26-2010 at 10:56 AM. Reason: Automerged Doublepost

  15. #10
    What's Jailbreak? chinmay007's Avatar
    Join Date
    May 2009
    Posts
    19
    Thanks
    2
    Thanked 9 Times in 4 Posts

    Quote Originally Posted by lsills81 View Post
    I got my 3G on 4.2.1 (I need this firmware to work) to recognize another Wifi router but after I re-jailbroke with Redsn0w (NOT installing Cydia each time) about 3 times it worked.

    NEW PROBLEM....I cant add "http://apt.saurik.com. It says it can't find the Repo. I of course MUST have this repo to install any apps as mobilesubstrate is VERY important. I am getting a little over my head here so I am counting on someone helping me out. I will continue posting until I get this to work. Thanks you guys!

    You should try Redsn0w.....very quick and after about 3 times re-jailbreaking it was about to get the phone to connect to the router. Let me know if that works.
    tried three times, without cydia. But every time it was stuck on the apple sign. Then after that i had to redsn0w it with cydia and then only it could boot. still no wifi.

  16. #11
    What's Jailbreak?
    Join Date
    May 2008
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Having the same issue. Upgraded my wife's 3G 8GB MB model last night to 4.2.1. Used the newest version of Red Snow to jailbreak. Jailbreak went smooth... no issues. Set the phone up as a new phone in iTunes. Sync'd and thought it was good to go. I will add the phone is much snappier with 4.2.1 than it was with 4.1. I was happy.... until I found the wifi was greyed out. I cannot access the wifi settings or search for a wifi network.

    A little bummed.... Wifi worked on 4.1 and not on 4.2.1

    If anyone figures this out, I would love to hear about it!!

  17. #12
    What's Jailbreak?
    Join Date
    Feb 2008
    Posts
    18
    Thanks
    5
    Thanked 2 Times in 2 Posts

    Same issue here on 3 different 3G. Wifi worked before the 4.2.1 update.now it is greyed out after using a custom firmware created by the newest PwnageTool. Going to try and do the jailbreak using the newest Redsn0w next.
    "We chase misprinted lies"

  18. #13
    What's Jailbreak?
    Join Date
    May 2008
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Yep... this update for sure killed the wifi on this 3G Model:MB

    Baseband was updated to 5.15.04 (trying to find out how to downgrade that if possible)

    I have reinstalled 4.2.1 2 times
    Just downgraded to 3.1.2
    Reset Network Settings
    Reset all settings
    did the Erase All Content and Settings
    Hard Reset

    Nothing is bringing back the wifi. Worked fine the morning before I upgraded to 4.2.1.

    Not under warranty anymore as it is an oldie. Thanks Apple. Not sure how this will ever get fixed!

  19. #14
    What's Jailbreak?
    Join Date
    Dec 2010
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Hey guys, having the same problem! The device is a 3g, 4.2.1 firmware, baseband 15.15.04.

    Jailbreaking using a newer version of redsn0w_win_0.9.6b4 (i was using 0.9.6b3) i finally got my wifi settings to be un-greyed out. I thought i was in the clear because it would detect available routers....but its only detecting routers, connecting to them with a checkmark, and then the checkmark disappears and the pinwheel starts rotating and the connection gets dropped back to 3g.

    I started messing around with it and it will stay connected if you create a static ip and have no security on the router. I cant get it to connect to any router with a WPA security code though. It will say enter password and the pinwheel will start going, and then say "failed to join". I've tried this with every mode on my netgear wgt624 v3 router.

    I'll keep trying different things but in the meantime you may want to try the beta4 version of redsn0w and if you must need wifi, make it static and insecure

  20. #15
    What's Jailbreak?
    Join Date
    Sep 2010
    Posts
    23
    Thanks
    0
    Thanked 3 Times in 3 Posts

    Quote Originally Posted by whoiskevinmeyer View Post
    Hey guys, having the same problem! The device is a 3g, 4.2.1 firmware, baseband 15.15.04.

    Jailbreaking using a newer version of redsn0w_win_0.9.6b4 (i was using 0.9.6b3) i finally got my wifi settings to be un-greyed out. I thought i was in the clear because it would detect available routers....but its only detecting routers, connecting to them with a checkmark, and then the checkmark disappears and the pinwheel starts rotating and the connection gets dropped back to 3g.

    I started messing around with it and it will stay connected if you create a static ip and have no security on the router. I cant get it to connect to any router with a WPA security code though. It will say enter password and the pinwheel will start going, and then say "failed to join". I've tried this with every mode on my netgear wgt624 v3 router.

    I'll keep trying different things but in the meantime you may want to try the beta4 version of redsn0w and if you must need wifi, make it static and insecure :
    Did anyone figure out it? My 3g with MB model is sitting in same situation, I tried several times including downgrading, no luck so far!

  21. #16
    What's Jailbreak?
    Join Date
    Jan 2011
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Same problem here. though i did not upgrade or downgrade. it just stopped joining any wifi networks. please help...

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts