+ Reply
Page 1 of 2 12 LastLast
Results 1 to 20 of 22

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Pwnagetool does not recognize 4.2.1 firmware bundle

is a discussion within the

Pwnage

forums, a part of the

Jailbreak / Downgrading / Upgrading

section;
I cannot get pwnagetool 4.1.2 to recognize the 4.2.1 firmware. When I point pwnagetool at iPhone2,1_4.2.1_8C148a_Restore.ipsw, it fails with the error "wrong firmware bundle selected". I downloaded the 4.2.1 file
...
  1. #1
    What's Jailbreak?
    Join Date
    Jan 2009
    Posts
    14
    Thanks
    6
    Thanked 0 Times in 0 Posts

    Default Pwnagetool does not recognize 4.2.1 firmware bundle
    I cannot get pwnagetool 4.1.2 to recognize the 4.2.1 firmware. When I point pwnagetool at iPhone2,1_4.2.1_8C148a_Restore.ipsw, it fails with the error "wrong firmware bundle selected".

    I downloaded the 4.2.1 file here:
    ModMyi Forums - Downloads - iPhone 3GS 4.2.1

    Any suggestions?

  2. #2
    Superbad Modder-ator Simon's Avatar
    Join Date
    Nov 2007
    Location
    Bermuda
    Posts
    46,205
    Thanks
    6,584
    Thanked 14,772 Times in 6,869 Posts

    You need pwnage tool 4.1.3 and you need to add the 3GS bundle as described on the dev team blog in update #3

  3. The Following User Says Thank You to Simon For This Useful Post:

    drice (12-24-2010)

  4. #3
    What's Jailbreak?
    Join Date
    Jan 2009
    Posts
    14
    Thanks
    6
    Thanked 0 Times in 0 Posts

    Thanks for the reply x98car.

    I have the following iPhone 3GS:
    Firmware: 3.1
    Baseband: 05.11.07-6.4_M3S2
    Bootloader: 6.4
    Bootrom: iBoot-359.3 (old bootrom)

    So, are you thinking I have to:
    1. Download Pwnagetool 4.1.3
    2. Add the 3GS bundle described in update #3
    3. Update to firmware 4.1.2 using custom firmware created in Pwnagetool
    4. Install redsn0w to jailbreak.
    5. Install ultrasn0w to unlock.

    It seems to me that Pwnagetool 4.1.3 is intended for use on phone with 05.14.02, 05.15.04 basebands.

    Is there a better way my phone?







    Update #3: For those Mac users with an old-bootrom 3GS who really know what they’re doing, here’s a minimal 3GS 4.2.1 bundle that will get you to 4.2.1 without updating your baseband. Be sure to uncheck “Activate the iPhone” using Expert mode. To actually jailbreak after you’ve restored with the help of that bundle, please use redsn0w. If you don’t know how to drop a bundle into PwnageTool.app, please hold off on 4.2.1 until it’s untethered for everyone (or wait for a nice tutorial from somewhere like iClarified - Apple News and Tutorials)

  5. #4
    Superbad Modder-ator Simon's Avatar
    Join Date
    Nov 2007
    Location
    Bermuda
    Posts
    46,205
    Thanks
    6,584
    Thanked 14,772 Times in 6,869 Posts

    That is the way to do it for you. The only place you need to pay extra attention to is the ipad baseband part. You will want to say no to that. If you say no to it then your baseband will be preserved.

  6. The Following User Says Thank You to Simon For This Useful Post:

    drice (12-24-2010)

  7. #5
    What's Jailbreak?
    Join Date
    Jan 2009
    Posts
    14
    Thanks
    6
    Thanked 0 Times in 0 Posts

    I am surprised that I have to use redsno0w. I thought Pwnagetool did the jailbreak. If so, what is readsn0w doing for me?

    Thanks again.

  8. #6
    Superbad Modder-ator Simon's Avatar
    Join Date
    Nov 2007
    Location
    Bermuda
    Posts
    46,205
    Thanks
    6,584
    Thanked 14,772 Times in 6,869 Posts

    Because it is a minimal bundle cydia is not installed. So you need redsnow to install cydia.

  9. The Following User Says Thank You to Simon For This Useful Post:

    drice (12-24-2010)

  10. #7
    What's Jailbreak?
    Join Date
    Jan 2009
    Posts
    14
    Thanks
    6
    Thanked 0 Times in 0 Posts

    Thank you very much x98car. You have been very helpful. One last question: would this be easier if I only upgraded to 4.1 of the firmware? I suspect that 4.1 is not an option any more because Apple may not allow me restore to the custom 4.1 firmware.

  11. #8
    Superbad Modder-ator Simon's Avatar
    Join Date
    Nov 2007
    Location
    Bermuda
    Posts
    46,205
    Thanks
    6,584
    Thanked 14,772 Times in 6,869 Posts

    It wouldnt make too much difference for you since you are old bootrom and dont have to worry about being tethered on 4.2.1

  12. #9
    What's Jailbreak?
    Join Date
    Jan 2009
    Posts
    14
    Thanks
    6
    Thanked 0 Times in 0 Posts

    x98car:

    Can you comment on this?

    I have been reading that 3GS users with old bootroms should not use Pwnage tool:

    "directly from the iPhone Dev Team: “iPhone3GS users with old bootroms who want to go to iOS 4.2.1 should not use PwnageTool! Update to stock iOS 4.2.1 first (through iTunes) then use redsn0w 0.9.6b5 to update your baseband.”

    I found that statement on these two web pages:
    How to unlock iOS 4.2.1 on iPhone 3G and iPhone 3GS with ultrasn0w

    PwnageTool 4.1.3 Unlock Download Available

    Thanks again

  13. #10
    Superbad Modder-ator Simon's Avatar
    Join Date
    Nov 2007
    Location
    Bermuda
    Posts
    46,205
    Thanks
    6,584
    Thanked 14,772 Times in 6,869 Posts

    That is only for people who have the 5.14 and 5.15 basebands and cannot unlock. If you have a lower baseband which can already be unlocked you should only use pwnage tool to make a custom firmware.

  14. #11
    What's Jailbreak?
    Join Date
    Jan 2009
    Posts
    14
    Thanks
    6
    Thanked 0 Times in 0 Posts

    I completed these 3 steps:
    1. Download Pwnagetool 4.1.3
    2. Add the 3GS bundle described in update #3
    3. Create a custom 4.1.2 firmware in Pwnagetool

    I then put the phone in DFU recovery mode, and attempted to restore to the custom 4.2.1 firmware in iTunes. However, iTunes gave me a 1601 error. I tried again and received a 1600 error.

    I am not sure what to try next - any suggestions?


    -----------------
    Update:
    Things may be worse now. I tried again and this time iTunes gave me a 2006 error, and the iPhone's screen went to all white. When I rebooted the iPhone, I now get the connect to iTunes screen on the iPhone.

    Can I do a normal restore in iTunes? Or do not want to update my baseband or bootrom.
    Last edited by drice; 12-26-2010 at 11:23 PM. Reason: Automerged Doublepost

  15. #12
    Super Moderator iYeow's Avatar
    Join Date
    Feb 2008
    Location
    Vancouver, Canada
    Posts
    13,921
    Thanks
    76
    Thanked 2,751 Times in 2,641 Posts

    You need to use redsn0w 0.9.6b6 to only put you into DFU mode, you cannot use a normal dfu mode.

  16. #13
    What's Jailbreak?
    Join Date
    Jan 2009
    Posts
    14
    Thanks
    6
    Thanked 0 Times in 0 Posts

    I have had some success! I tried the restore to the custom 4.1.2 FW from iTunes on a different macintosh, and it worked. That mac had an older version of iTuens (9.2.1). I am not sure if that is what made the difference, or if it because the new mac had a clean install.

    In any case, I am now running 4.1.2 and have preserved the old baseband and bootrom. I then ran redsn0w. Although that worked, I was confused by what ipsw it required. I first tried the custom 4.1.2 I had created with pwnagetool, but that was rejected. I then pointed redsn0w to the original FW (iPhone2,1_4.2.1_8C148a_Restore.ipsw) and that worked. I thought that was odd.

    Also, I was not sure what options to select in redsn0w, so I just went with the default of just installing cydia and left everything else unselected. After Cydia was installed, I installed ultrasn0w, rebooted, and I am now able to make calls, send txt messages, and even able to use cellular data over an edge connection through t-mobile.

    I am not able to send/receive MMS, but I will work on that next.

    Thanks again for all the help.
    Last edited by drice; 12-27-2010 at 10:23 PM.

  17. #14
    What's Jailbreak?
    Join Date
    Mar 2010
    Posts
    14
    Thanks
    1
    Thanked 0 Times in 0 Posts

    @x98car

    I have a 3gs new boot rom 6.15 bootrom,i stock updated to 4.2.1 but downgraded back to 4.1 (6.15) as when I try to use PWNAGE it does not search or select 4.2.1ipsw if i manually select it say wrong bundle.yest I had managed to make a custom bundle of 4.2.1 thru pwnage but got 1600 error when i tried DFU manually and 21 error when i tried Redsn0w DFU

    pl guide me how i can make PWNAGE select 4.2.1 fw and then how to get around the 1600 or 21 error
    (rite now i have 4.1 .6/15 JB/unlocked
    Thanks

  18. #15
    Superbad Modder-ator Simon's Avatar
    Join Date
    Nov 2007
    Location
    Bermuda
    Posts
    46,205
    Thanks
    6,584
    Thanked 14,772 Times in 6,869 Posts

    You need to add the bundle from update 3 on the dev team blog manually to pwnage tool: Dev-Team Blog

    Then it will recognize 4.2.1. Make the custom firmware without the ipad baseband in it, then get pwnage tool to put the phone in dfu mode. Then restore to that custom firmware in itunes.

    If you are at 4.1 now though it is best to stay there as 4.2.1 would be tethered for you on new bootrom.

  19. #16
    What's Jailbreak?
    Join Date
    Mar 2010
    Posts
    14
    Thanks
    1
    Thanked 0 Times in 0 Posts

    thanks mate
    isnt 4.2.1 faster ,stable and consume less battery?

  20. #17
    Superbad Modder-ator Simon's Avatar
    Join Date
    Nov 2007
    Location
    Bermuda
    Posts
    46,205
    Thanks
    6,584
    Thanked 14,772 Times in 6,869 Posts

    I have heard 4.1 is actually the more stable firmware.

  21. The Following User Says Thank You to Simon For This Useful Post:

    jehdesai (01-07-2011)

  22. #18
    What's Jailbreak?
    Join Date
    Mar 2010
    Posts
    14
    Thanks
    1
    Thanked 0 Times in 0 Posts

    Made and installed 4.2.1 custom firmwarethru pwnage but cant find cydia in there?

  23. #19
    Superbad Modder-ator Simon's Avatar
    Join Date
    Nov 2007
    Location
    Bermuda
    Posts
    46,205
    Thanks
    6,584
    Thanked 14,772 Times in 6,869 Posts

    It is a minimal bundle so you have to use redsnow 0.9.6rc8 to install cydia.

  24. #20
    My iPhone is a Part of Me klouud's Avatar
    Join Date
    Mar 2008
    Posts
    791
    Thanks
    16
    Thanked 80 Times in 58 Posts

    I'm having the same issues as the person that made this post - the difference is that I have done everything that you guys are talking about but pwnage tool still does not recognize 4.2.1 restore IPSW. It does recognize iPhone 3G 4.1 tho.... And yes, I have pwnage tool 4.1.3 with the fixed 3GS bundle.

    Does this jailbreak install the "new" cydia that was released a couple of months ago?

    [EDIT]

    Ok, I was following/using updated bundles from "update #1 instead of #3" - problem solved!
    Last edited by klouud; 01-14-2011 at 04:10 AM.


Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts