Results 1 to 2 of 2

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: iPhone & Straight Talk..."No Service"

  1. #1
    Default iPhone & Straight Talk..."No Service"
    I just purchased 3 iPhone 3GS's to use with Straight Talk (& to save ~$500/year).
    I purchased the SIM cards & activation cards through Straight Talk.
    All 3 iPhones are jailbroken. All three iPhones went to unlockit.co.nz for the APN settings. Of the 3 iPhones, 2 are on iOS 5.01 & the other 4.3.3. (Mine is one of the ones on 5.0.1)
    Two of the 3 iPhones activated fine. The other (mine) shows "no service" as well as no phone number when I checked on the phone.
    I went to ST website & it showed what my number is. I contacted them & was told everything looks fine on their end & no issues in my area with towers, etc.
    They had me switch SIM cards from one phone to the other. My SIM worked in my wife's phone, but hers didn't work in mine. I then took my SIM & put it in a 5 year old unlocked GSM Razr & it worked in it.
    I attempted to restore the phone...no SHSH blobs available, so I made an IPSW w/iFaith. When I did the "shift + restore" in iTunes, I got the 3194 error. I'm running the newest version of iTunes, so I shut it down & I added #74.208.105.171 gs.apple.com to the bottom of my hosts file. Tried again to no avail.
    This particular phone has the 24kpwn and is the old bootrom.
    I ain't the sharpest tack in the box, but it seems to me it's an issue with my phone.
    Can anyone help?
    Thanks.

  2. #2
    It sounds like your iPhone may be damaged. Did you purchase it used, or straight from Apple? If it has a warranty, I would remove any traces of a jailbreak and send it in to be repaired. I have an old iPhone 3G sitting around somewhere. Something is messed up with it (more than likely the antenna), where it doesn't get WiFi signal unless it is literally three inches from my router's antenna. I imagine the same could be happening to your iPhone, but the cellular antenna instead of the WiFi.

    Was your phone purchased from AT&T? You should try putting in an official AT&T SIM (or whatever your iPhone is locked to) and see if you get any signal.

    Also, you shouldn't really worry about not updating your iPhone. First off, I'm pretty sure you can use it on StraightTalk just fine without jailbreaking. Just insert the SIM (assuming you chooses the AT&T option from ST) and then install the APN profile from unlockit. Second, you can always downgrade to whatever you're trying to restore to right now.



    As for restoring, here is what I would recommend. I may have misunderstood you, but it sounds like you're trying to restore to 5.0.1 without any SHSH blobs saved. This simply won't work, and you're better off upgrading to 5.1 and using a tethered jailbreak. It's not that bad, I can go for a month without restarting if I watch my battery. I think some 3GS's with the old bootrom can be jailbroken untethered on 5.1, but I'm not entirely sure.

    If you have the SHSH blobs, here's another thing to try. First, change your hosts file back to normal. Just remove the gs.apple.com line completely, to be safe. Then, download TinyUmbrella and the latest version of Redsn0w. Just Google for redsn0w, you may have to poke around a bit.

    Stitching an ISPW:
    Open up TinyUmbrella with your device plugged in. Select it in the column on the left-hand side, and then press 'Save SHSH'. It may take a few moments. After that, open up redsn0w. Navigate to Extras --> SHSH Blobs --> Stitch. Click on 'ISPW', and then select the ISPW for the firmware you're trying to restore to. After that, press 'Local', and navigate to TinyUmbrella's SHSH blob save location. (In TinyUmbrella, go to the 'Advanced' tab, and there should be a textbox with your SHSH save directory location in it.) Go to that directory in redsn0w, and then select the SHSH blob file for the device and firmware you're trying to restore to. It may take a while to finish this process, but then you should have an ISPW in the same location as the original one, but with an odd name of some sort. You can close redsn0w when it's finished.


    Restoring firmware to device:
    After you've got the stitched ISPW, go to TinyUmbrella and press 'Start TSS Server'. Then, put your device in DFU mode. This is a very important step. Google it for instructions if need be. When it's in DFU, open iTunes if it doesn't come up automatically. Then, select the device that's in DFU mode, (it should automatically be selected) hold Shift (or option on Mac) and press 'Restore' in iTunes. Select the ISPW you made in redsn0w, and then wait it out. Hopefully, your device will be restored.




    If you don't have your device's SHSH blob for 5.0.1, you're screwed, to put it, and I typed all of that out for nothing . The only thing to do in that case is either to not restore or to just update to 5.1.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •