Results 1 to 3 of 3

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: 3GS ios 5.0.1 baseband 05.16.05 and h20

  1. #1
    Question 3GS ios 5.0.1 baseband 05.16.05 and h20
    I just bought a 3GS from the apple store.
    I jailbreaked it using redsn0w 0.9.10b3. It now has ios 5.0.1 and baseband 05.16.05
    It has the newer serial number, so i read i can't put the ipad baseband on it, nor can i unlock it

    I had it working (don't know how) on t-mobile for about a week. I upgraded my itunes , but never updated the phone other than syncing. All of a sudden, I get "no service" .

    All my research so far tells me I can't unlock it, and to look elsewhere. So I am wondering if this would work with H20?

    Their website says i need to have an unlocked phone. It also states however that ATT locked phones would work.
    I also read that ios 5.0.1 is not compatible with h20 ?

    Very unclear, and their customer service is one step away from non-existent..

    Can anyone provide any answers? (i'm wondering if my phone is still ATT locked, or is it some hybrid now?)

  2. #2
    It should work without an unlock.

  3. #3
    Where did you read H2O is not compatible with 5.0.1 ????

    That is the same as saying 5.0.1 is not compatible with AT&T :/

    H2O Woks with any firmware and any baseband h2o uses AT&T towers ,





Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •