+ Reply
Results 1 to 20 of 20

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: errors when installing .ipb

is a discussion within the

OS X Specific Modding Discussion

forums, a part of the

Computer Modding Software

section;
Hello Everyone, After using the most excellent iphone skinner app to make a WoW themed .ipb for my iPhone, I booted up terminal and followed the installation directions. However, I
...
  1. #1
    What's Jailbreak?
    Join Date
    Aug 2007
    Location
    USA
    Posts
    16
    Thanks
    1
    Thanked 0 Times in 0 Posts

    Default errors when installing .ipb
    Hello Everyone,

    After using the most excellent iphone skinner app to make a WoW themed .ipb for my iPhone, I booted up terminal and followed the installation directions. However, I ran into two problems. The first one was a line that occured when I was checking the permissions which said this:

    chmod u+x /phonedmg/installipb.pl
    chmod: /phonedmg/installipb.pl: No such file or directory

    Even though I am quite sure that there is such a directory, that is what I got repeatedly after checking spelling, location, etc., multiple times.

    The second line came up in step 9, and said this:

    michael-bronsons-computer:~/phonedmg michaelbronson$ ./installipb.pl WoW.ipb
    WoW.ipb does not seem to support iPhone OS Version '1.0'!

    I am confused about that one too, because I am pretty sure that I am running 1.0.1 anyway, so it shouldn't matter.

    All right, that's it, any help would be great! I really can't wait to mod my iphone!

  2. #2
    Owner / Founder - ModMyi
    aka poetic_folly
    Kyle Matthews's Avatar
    Join Date
    May 2007
    Location
    Tampa, Florida, United States
    Posts
    8,473
    Thanks
    568
    Thanked 4,797 Times in 1,222 Posts

    Check the Wiki. You need to open the installipb.pl file and change your OS version, and also change your folder in the .ipb file from 1.0 to 1.0.1.
    .


    ↑ ↑ ↓ ↓ ← → ← → B A [select] [start] Kyle Matthews

  3. #3

  4. #4
    Owner / Founder - ModMyi
    aka poetic_folly
    Kyle Matthews's Avatar
    Join Date
    May 2007
    Location
    Tampa, Florida, United States
    Posts
    8,473
    Thanks
    568
    Thanked 4,797 Times in 1,222 Posts

    Again, check the Wiki. If you are getting a permission denied you need to do the chmod command on the script to set permissions to allow it.
    .


    ↑ ↑ ↓ ↓ ← → ← → B A [select] [start] Kyle Matthews

  5. #5

  6. #6
    Owner / Founder - ModMyi
    aka poetic_folly
    Kyle Matthews's Avatar
    Join Date
    May 2007
    Location
    Tampa, Florida, United States
    Posts
    8,473
    Thanks
    568
    Thanked 4,797 Times in 1,222 Posts

    Here to help.
    .


    ↑ ↑ ↓ ↓ ← → ← → B A [select] [start] Kyle Matthews

  7. #7
    iPhoneaholic
    Join Date
    Aug 2007
    Posts
    434
    Thanks
    44
    Thanked 24 Times in 19 Posts

    How do you change the OS version??

    Thanks.

    Marc

    Quote Originally Posted by poetic_folly View Post
    Check the Wiki. You need to open the installipb.pl file and change your OS version, and also change your folder in the .ipb file from 1.0 to 1.0.1.

  8. #8
    Owner / Founder - ModMyi
    aka poetic_folly
    Kyle Matthews's Avatar
    Join Date
    May 2007
    Location
    Tampa, Florida, United States
    Posts
    8,473
    Thanks
    568
    Thanked 4,797 Times in 1,222 Posts

    change your folder in the .ipb file from 1.0 to 1.0.1.

    All new .ipb's created should automatically be set up for the 1.0.1 firmware now, since it is the most common.
    Last edited by Kyle Matthews; 08-20-2007 at 11:10 AM. Reason: Automerged Doublepost
    .


    ↑ ↑ ↓ ↓ ← → ← → B A [select] [start] Kyle Matthews

  9. #9
    Green Apple
    Join Date
    Jul 2007
    Posts
    70
    Thanks
    2
    Thanked 1 Time in 1 Post
    I have the correct OS' set, and am still getting the same...

    chmod: /phonedmg/installipb.pl: No such file or directory

    And concurrently, am getting the permissions denied problem..

    Please help.. I've tried just about everything to enable the installibp.pl, and I keep getting the file not found...
    Last edited by SCMedic; 08-20-2007 at 04:36 PM. Reason: Automerged Doublepost

  10. #10
    Owner / Founder - ModMyi
    aka cash7c3
    Cody Overcash's Avatar
    Join Date
    May 2007
    Location
    Denver, CO
    Posts
    11,894
    Thanks
    340
    Thanked 15,269 Times in 652 Posts

    what are you following? where did you get chmod for that file instructions from?

  11. #11
    Green Apple
    Join Date
    Jul 2007
    Posts
    70
    Thanks
    2
    Thanked 1 Time in 1 Post
    From the Wiki...

  12. #12
    Owner / Founder - ModMyi
    aka cash7c3
    Cody Overcash's Avatar
    Join Date
    May 2007
    Location
    Denver, CO
    Posts
    11,894
    Thanks
    340
    Thanked 15,269 Times in 652 Posts

    past our your entire terminal process here please.

  13. The Following User Says Thank You to Cody Overcash For This Useful Post:

    SCMedic (08-21-2007)

  14. #13
    Owner / Founder - ModMyi
    aka poetic_folly
    Kyle Matthews's Avatar
    Join Date
    May 2007
    Location
    Tampa, Florida, United States
    Posts
    8,473
    Thanks
    568
    Thanked 4,797 Times in 1,222 Posts

    Quote Originally Posted by SCMedic View Post
    I have the correct OS' set, and am still getting the same...

    chmod: /phonedmg/installipb.pl: No such file or directory

    And concurrently, am getting the permissions denied problem..
    Hit Cmd+i on the installipb.pl file. Note the third line under the General dropdown, titled "Where". My guess is for you it will say something like /Users/Blahblahblah/phonedmg. If thats true, rerun the chmod instructions (there's no : though, dunno why you are using that...) with that updated path.
    .


    ↑ ↑ ↓ ↓ ← → ← → B A [select] [start] Kyle Matthews

  15. The Following User Says Thank You to Kyle Matthews For This Useful Post:

    SCMedic (08-21-2007)

  16. #14
    Green Apple
    Join Date
    Jul 2007
    Posts
    70
    Thanks
    2
    Thanked 1 Time in 1 Post
    Did all you said, cmd+i and got the users/bailey/phonedmg, re-ran it, and still get this:


    Welcome to Darwin!
    greg-computer:~ Bailey$ chmod u+x /phonedmg/installipb.pl
    chmod: /phonedmg/installipb.pl: No such file or directory
    greg-computer:~ Bailey$

    Thanks all for the help!
    Last edited by SCMedic; 08-21-2007 at 02:55 PM.

  17. #15
    Owner / Founder - ModMyi
    aka cash7c3
    Cody Overcash's Avatar
    Join Date
    May 2007
    Location
    Denver, CO
    Posts
    11,894
    Thanks
    340
    Thanked 15,269 Times in 652 Posts

    cd phonedmg
    ls *make sure the installipb.pl is actually there*
    chmod u+x ./installipb.pl

  18. #16
    Green Apple
    Join Date
    Jul 2007
    Posts
    70
    Thanks
    2
    Thanked 1 Time in 1 Post
    Did it, and this is the list.. It's there...



    694-5259-38.dmg Services.plist
    694-5262-39.dmg iPhoneBundles
    Firmware iPhoneInterface
    Makefile.osx installipb.pl
    Makefile.win iphoneinterface.dev
    MobileDevice.h jailbreak
    README kernelcache.restore.release.s5l8900xrb
    Readme.txt main.cpp
    Restore.plist tree.cpp
    greg-moores-computer:~/phonedmg Bailey$

  19. #17
    Owner / Founder - ModMyi
    aka cash7c3
    Cody Overcash's Avatar
    Join Date
    May 2007
    Location
    Denver, CO
    Posts
    11,894
    Thanks
    340
    Thanked 15,269 Times in 652 Posts

    so from just logging into terminal

    cd phonedmg
    chmod u+x ./installipb.pl

  20. #18
    Green Apple
    Join Date
    Jul 2007
    Posts
    70
    Thanks
    2
    Thanked 1 Time in 1 Post
    Yup, that's what I did, and I get the error everytime...

    For some reason, it all works! Thanks guys! You guys are awesome!!
    Last edited by SCMedic; 08-21-2007 at 03:14 PM. Reason: Automerged Doublepost

  21. #19
    Owner / Founder - ModMyi
    aka cash7c3
    Cody Overcash's Avatar
    Join Date
    May 2007
    Location
    Denver, CO
    Posts
    11,894
    Thanks
    340
    Thanked 15,269 Times in 652 Posts

    periods and the directory you are running from can be important

    glad you got it running
    Last edited by Cody Overcash; 08-21-2007 at 03:21 PM. Reason: Automerged Doublepost

  22. #20
    What's Jailbreak?
    Join Date
    Jul 2007
    Posts
    18
    Thanks
    0
    Thanked 0 Times in 0 Posts

    I am having these same problems
    Any solution?

    My main problem is that after everything is done and finished, The theme is not showing up
    Last edited by Rameen; 08-23-2007 at 01:06 PM. Reason: Automerged Doublepost

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts