Results 1 to 9 of 9

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Can't use applications because of Boss Tool App Move

  1. #1
    What's Jailbreak?
    Join Date
    Dec 2007
    Location
    Vancouver, British Columbia, Canada
    Posts
    23
    Thanks
    3
    Thanked 0 Times in 0 Posts

    Default Can't use applications because of Boss Tool App Move
    So I was using the Boss Tool to move my Apps, but all it did was just keep reseting and showing me the boss screen...

    I then did a manual reset and now I can see all the apps, but I can't use any of them after I get in them... how do I fix this? do I have to edit a file or do I have to manually move the apps back?

    Help please

  2. #2
    had you installed the bsd tools?
    boss copys and sets up a symlink using the bsd tools.
    if the cp command is not available the copy won't happen. same with the ln command.

    but if the rm command is there, all the apps are gone.

    I did them manually as in http://www.iphoneatlas.com/2007/12/1...hone-apps-fix/
    http://jpassoc.com/x -- with free itunes under the puppy!
    If I help you out, please press THANKS!

    3g QuickPWN'ed with 2.1

  3. #3
    What's Jailbreak?
    Join Date
    Dec 2007
    Location
    Vancouver, British Columbia, Canada
    Posts
    23
    Thanks
    3
    Thanked 0 Times in 0 Posts

    this is weird... but I restarted my phone 3 times and then everything worked but it was with my old old theme... then just to make sure I restarted again and it was my latest theme and nothing worked... I do have bsd subsystem installed

  4. #4
    hmm… what do the themes have to do with the apps?

    so now , none of the applications work? sounds like your partition is not executable.

    does cat /etc/fstab

    show up as
    /dev/disk0s1 / hfs rw 0 1
    /dev/disk0s2 /private/var hfs rw 0 2
    http://jpassoc.com/x -- with free itunes under the puppy!
    If I help you out, please press THANKS!

    3g QuickPWN'ed with 2.1

  5. #5
    What's Jailbreak?
    Join Date
    Dec 2007
    Location
    Vancouver, British Columbia, Canada
    Posts
    23
    Thanks
    3
    Thanked 0 Times in 0 Posts

    are you talking about putting that in Terminal?

  6. #6
    in terminal ssh'ed into the phone... I type
    cat /etc/fstab

    it shows that the 2 partitions are rw (and not noexec)

    http://limitededitioniphone.com/need...free-up-space/

    some of the other ways to do this... I did the manual method in Terminal.
    Last edited by jakecigar; 12-11-2007 at 11:25 PM. Reason: Automerged Doublepost
    http://jpassoc.com/x -- with free itunes under the puppy!
    If I help you out, please press THANKS!

    3g QuickPWN'ed with 2.1

  7. #7
    What's Jailbreak?
    Join Date
    Dec 2007
    Location
    Vancouver, British Columbia, Canada
    Posts
    23
    Thanks
    3
    Thanked 0 Times in 0 Posts

    I get

    /dev/disk0s1 / hfs rw 0 1
    /dev/disk0s2 / private/var hfs rw 0 2

    I was talking to broomhead and he says that the app move was messy... that it didn't move all my apps to the Media folder
    Last edited by phanb; 12-11-2007 at 11:52 PM. Reason: Automerged Doublepost

  8. #8
    your results look good.

    it's possible you were messed up by sloppy code... I prefer a good couple of commands to a program I can't verify!

    the first time I moved apps, I used the mv command, it left me with half moved directories! The only fix I had for missing apps, was to go back to 1.1.1, jailbreak, oktoprep and start over again!

    I'd search your phone for missing apps and code files that aren't marked executible.
    pick a bad app,
    and issue the command ls -l
    make sure the code file inside the app has the x's as in :

    ls -l /Applications/Preferences.app

    -rwxrwxr-x 1 root 172736 Oct 10 17:47 Preferences


    that means the code inside the app is executible.
    if not,
    cd /Applications/Preferences.app
    chmod +x Preferences
    http://jpassoc.com/x -- with free itunes under the puppy!
    If I help you out, please press THANKS!

    3g QuickPWN'ed with 2.1

  9. #9
    pls help me !! pls pls

    i just installed that *&^%$#$%^& categorise application by boss tools and it removed every icon in my spring board menu..!!

    i have no clue how to fix this and restore is not an option for me :/

    SSH is Off in services.. i cant get neither into services nor installer.app to remove that god damned app

    tried to reinstall, installer.app (cant)

    pls help me ! pls!

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •