Page 3 of 4 FirstFirst 1234 LastLast
Results 41 to 60 of 67

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: [RELEASE] WbApp WinterBoard GUI

  1. #41
    My iPhone is a Part of Me
    Join Date
    Jul 2007
    Location
    Orlando FL
    Posts
    767
    Thanks
    17
    Thanked 23 Times in 22 Posts

    as always good job man u really kick start theme apps nice ty
    iTouch 2.0 (free update/pwn'd)
    iPhone 3G white (pwn'd)
    MacBook Pro 15inch (using tethered)

    2 broken wrists so give me a break. no more 2007 Yamaha r6

  2. #42
    iPhoneaholic
    Join Date
    Jul 2008
    Location
    Winter Park, Florida
    Posts
    494
    Thanks
    64
    Thanked 101 Times in 60 Posts

    Quote Originally Posted by pingwhen View Post
    as always good job man u really kick start theme apps nice ty
    How'd you get it working ping?

  3. #43
    My iPhone is a Part of Me signori's Avatar
    Join Date
    Oct 2007
    Location
    Toronto
    Posts
    535
    Thanks
    292
    Thanked 357 Times in 189 Posts

    I just installed it from Cydia. Used terminal to set the permissions etc. Everything works perfectly. Great App. Now I can can use my WinterBoard theme icons from whatever theme that I have and use my own springboard wallpaper that I used Kate app to create because before if I set a theme with winterboard I had to use that themes wallpaper only and not my own that I made with kate on the phone. I did not feel like ssh 100 wallpapers. You are a life saver. Thanks.

  4. #44
    Quote Originally Posted by jabbawalkee View Post
    How'd you get it working ping?
    The permission on the subfolders must be set properly. If the app launches and then crashes, it can not create the plist for available themes (due to permissions problems in the Documents folder, then if the preview doesn't work it's a permissions problem on the Themes sub-folder). If you can ssh into your device you can fix it by running the commands that were in my postinst.sh script

    From the WbApp.app folder run:
    chown mobile:wheel Documents
    chown mobile:wheel Documents/Themes

    If not just uninstall and reinstall through Cydia. I just tested the install and it worked okay for me.

    Good luck
    Last edited by CyberGreg; 08-13-2008 at 08:45 PM.
    White 3G

  5. #45
    My iPhone is a Part of Me
    Join Date
    Jul 2007
    Location
    Orlando FL
    Posts
    767
    Thanks
    17
    Thanked 23 Times in 22 Posts

    cyber said it lol
    iTouch 2.0 (free update/pwn'd)
    iPhone 3G white (pwn'd)
    MacBook Pro 15inch (using tethered)

    2 broken wrists so give me a break. no more 2007 Yamaha r6

  6. #46
    iPhoneaholic
    Join Date
    Jul 2008
    Location
    Winter Park, Florida
    Posts
    494
    Thanks
    64
    Thanked 101 Times in 60 Posts

    Quote Originally Posted by CyberGreg View Post
    The permission on the subfolders must be set properly. If the app launches and then crashes, it can not create the plist for available themes (due to permissions problems in the Documents folder, then if the preview doesn't work it's a permissions problem on the Themes sub-folder). If you can ssh into your device you can fix it by running the commands that were in my postinst.sh script

    From the WbApp.app folder run:
    chown mobile:wheel Documents
    chown mobile:wheel Documents/Themes

    If not just uninstall and reinstall through Cydia. I just tested the install and it worked okay for me.

    Good luck
    I just tried ALL of those methods and it's still not working ugh

    I've tried uninstalling/reinstalling a number of times and that DOESN'T work either. This is ridiculous
    I've never had a problem with any third party app so I know its not my phone.
    Last edited by jabbawalkee; 08-13-2008 at 09:47 PM. Reason: Automerged Doublepost

  7. #47
    Quote Originally Posted by jabbawalkee View Post
    I just tried ALL of those methods and it's still not working ugh

    I've tried uninstalling/reinstalling a number of times and that DOESN'T work either. This is ridiculous
    I've never had a problem with any third party app so I know its not my phone.
    If you can ssh into your phone, run this command from the WbApp.app folder

    ls -l >dirlist.txt

    Grab the dirlist.txt file and either email (gregmeach at gmail dot com) it to me or post the contents here (it will list out the "l"ong directory listing so I can see the permissions and owners.

    Thanks
    White 3G

  8. The Following User Says Thank You to CyberGreg For This Useful Post:

    stadler (08-14-2008)

  9. #48
    iPhone? More like MyPhone Real_Iphonecrazy's Avatar
    Join Date
    Aug 2008
    Location
    Blackpool,England, UK
    Posts
    217
    Thanks
    15
    Thanked 25 Times in 19 Posts

    Available through Cydia now. Works great.

  10. #49
    iPhoneaholic
    Join Date
    Jul 2008
    Location
    Winter Park, Florida
    Posts
    494
    Thanks
    64
    Thanked 101 Times in 60 Posts

    Quote Originally Posted by CyberGreg View Post
    If you can ssh into your phone, run this command from the WbApp.app folder

    ls -l >dirlist.txt

    Grab the dirlist.txt file and either email (gregmeach at gmail dot com) it to me or post the contents here (it will list out the "l"ong directory listing so I can see the permissions and owners.

    Thanks
    Okay so I did what you said and I opened the dirlist.txt file as shown below:
    total 240
    -rwxr-xr-x 1 root mobile 33135 Aug 13 15:56 Default.png*
    drwxr-xr-x 3 mobile wheel 170 Aug 14 00:48 Documents/
    -rwxr-xr-x 1 root mobile 518 Aug 13 15:56 Info.plist*
    -rwxr-xr-x 1 root mobile 8 Aug 13 15:56 PkgInfo*
    -rwxr-xr-x 1 root mobile 150 Aug 13 15:56 ResourceRules.plist*
    -rwxr-xr-x 1 root mobile 965 Aug 13 15:56 SummerBoard_24.png*
    -rwxr-xr-x 1 root mobile 1052 Aug 13 15:56 SummerBoard_30.png*
    -rwxr-xr-x 1 root mobile 1653 Aug 13 15:56 SummerBoard_37.png*
    -rwxr-xr-x 1 root mobile 79792 Aug 13 15:56 WbApp*
    -rwxr-xr-x 1 root mobile 965 Aug 13 15:56 WinterBoard_24.png*
    -rwxr-xr-x 1 root mobile 1531 Aug 13 15:56 WinterBoard_30.png*
    -rwxr-xr-x 1 root mobile 2325 Aug 13 15:56 WinterBoard_37.png*
    -rw-r--r-- 1 root mobile 0 Aug 14 00:49 dirlist.txt
    -rwxr-xr-x 1 root mobile 1630 Aug 13 15:56 flipper_list_blue.png*
    -rwxr-xr-x 1 root mobile 69777 Aug 13 15:56 iPhone_base.png*
    -rwxr-xr-x 1 root mobile 3255 Aug 13 15:56 icon.png*
    -rwxr-xr-x 1 root mobile 558 Aug 13 15:56 name_gray.png*
    -rwxr-xr-x 1 root mobile 501 Aug 13 15:56 rank_gray.png*

    I have also attached the file too. I really appreciate your help. Thanks, let me know what's up!
    Attached Files Attached Files

  11. #50
    Another data point for ya....

    Installed straight from Cydia, it saw all my themes, changes them all, works perfect.

    Thank you!

  12. The Following User Says Thank You to hartphoto For This Useful Post:

    CyberGreg (08-14-2008)

  13. #51
    Quote Originally Posted by jabbawalkee View Post
    I have also attached the file too. I really appreciate your help. Thanks, let me know what's up!
    I removed it from my iPod and then reinstalled from Cydia and my list matches yours exactly (except for dirlist.txt).

    Compare your Documents and Documents/Themes folder to mine. Perhaps the problem is in there. I's attached a screenshot of my Terminal session to help.

    What we need to make sure is that starting at the Documents folder, everything needs to be mobile:wheel, which is why we set the folders to that and then anything that goes into the folders inherits those settings.


    BTW I only previewed one theme before I grabbed those screenshots.
    Attached Thumbnails Attached Thumbnails -termsession.png  
    Last edited by CyberGreg; 08-14-2008 at 07:42 AM.
    White 3G

  14. #52
    iPhone? More like MyPhone Real_Iphonecrazy's Avatar
    Join Date
    Aug 2008
    Location
    Blackpool,England, UK
    Posts
    217
    Thanks
    15
    Thanked 25 Times in 19 Posts

    ive used poof to hide Winterboard and am using WbApp to theme my phone. Works a treat. Great work Dev.

    Is there any chance Saurik and Greg can team up and merge WbApp and winterboard into one fantastic App. Just a thought.

  15. #53
    What's Jailbreak?
    Join Date
    Mar 2008
    Location
    Illinois
    Posts
    9
    Thanks
    1
    Thanked 2 Times in 2 Posts

    Default CYDIA Install on 2 3G Iphones one works the other one doesnt
    I've been reading all of these posts, with no success...

    I have 2 Jailbroken 16GB 3G iPhones almost completely identical in terms of installed apps. Both Iphones installed WBApp via Cydia. My wife's works fine without a single problem, mine continuosly crashes at the start screen (without any theme lists or previews) and resprings to the home screen.

    I am using Vista and WinSCP, and I have taken the following actions:

    1. Unistall via Cydia and reinstall (20 times)
    2. Respring/ Reboot during reinstalls or changing of permissions (40+)
    3. WinSCP to WBApp.app folder (and subfolders Documents and Themes) all permissions were set to:
    a. 755 (4 times)
    b. 777 (3 times)
    4. From the WbApp.app folder I ran:
    chown mobile:wheel Documents
    chown mobile:wheel Documents/Themes

    Nothing has worked for me.
    It's certainly not the app. It's my iPhone. My wife's works fine

    You know, sometimes life just isn't fair.

  16. The Following User Says Thank You to starlox For This Useful Post:

    CyberGreg (08-14-2008)

  17. #54
    iPhoneaholic
    Join Date
    Jul 2008
    Location
    Winter Park, Florida
    Posts
    494
    Thanks
    64
    Thanked 101 Times in 60 Posts

    Ok, did it Greg. It looks exactly the same to me.
    iPhone:~ root# cd /Applications/WbApp.app
    iPhone:/Applications/WbApp.app root# ls -l
    total 244
    -rwxr-xr-x 1 root mobile 33135 Aug 13 15:56 Default.png*
    drwxr-xr-x 3 mobile wheel 170 Aug 14 11:55 Documents/
    -rwxr-xr-x 1 root mobile 518 Aug 13 15:56 Info.plist*
    -rwxr-xr-x 1 root mobile 8 Aug 13 15:56 PkgInfo*
    -rwxr-xr-x 1 root mobile 150 Aug 13 15:56 ResourceRules.plist*
    -rwxr-xr-x 1 root mobile 965 Aug 13 15:56 SummerBoard_24.png*
    -rwxr-xr-x 1 root mobile 1052 Aug 13 15:56 SummerBoard_30.png*
    -rwxr-xr-x 1 root mobile 1653 Aug 13 15:56 SummerBoard_37.png*
    -rwxr-xr-x 1 root mobile 79792 Aug 13 15:56 WbApp*
    -rwxr-xr-x 1 root mobile 965 Aug 13 15:56 WinterBoard_24.png*
    -rwxr-xr-x 1 root mobile 1531 Aug 13 15:56 WinterBoard_30.png*
    -rwxr-xr-x 1 root mobile 2325 Aug 13 15:56 WinterBoard_37.png*
    -rw-r--r-- 1 root mobile 1123 Aug 14 00:49 dirlist.txt
    -rwxr-xr-x 1 root mobile 1630 Aug 13 15:56 flipper_list_blue.png*
    -rwxr-xr-x 1 root mobile 69777 Aug 13 15:56 iPhone_base.png*
    -rwxr-xr-x 1 root mobile 3255 Aug 13 15:56 icon.png*
    -rwxr-xr-x 1 root mobile 558 Aug 13 15:56 name_gray.png*
    -rwxr-xr-x 1 root mobile 501 Aug 13 15:56 rank_gray.png*
    iPhone:/Applications/WbApp.app root# cd Documents
    iPhone:/Applications/WbApp.app/Documents root# ls -l
    total 20
    -rw-r--r-- 1 mobile wheel 1262 Aug 14 11:55 DotThemeList.plist
    -rw-r--r-- 1 mobile wheel 12754 Aug 14 11:55 ThemeList.plist
    drwxr-xr-x 2 mobile wheel 68 Aug 13 15:56 Themes/
    iPhone:/Applications/WbApp.app/Documents root# cd Themes
    iPhone:/Applications/WbApp.app/Documents/Themes root# ls -l
    total 0
    iPhone:/Applications/WbApp.app/Documents/Themes root#

  18. #55
    Quote Originally Posted by starlox View Post
    Nothing has worked for me.
    It's certainly not the app. It's my iPhone. My wife's works fine

    You know, sometimes life just isn't fair.
    Thanks for posting. I'll think about the loading process to try and hone in on the problem.... it certainly doesn't appear that the problem lies in the permissions but somewhere else.
    Last edited by CyberGreg; 08-14-2008 at 11:44 AM.
    White 3G

  19. #56
    iPhoneaholic
    Join Date
    Jul 2008
    Location
    Winter Park, Florida
    Posts
    494
    Thanks
    64
    Thanked 101 Times in 60 Posts

    Yeah you're probably right. If that's the case, maybe I should just restore using my Custom 2.0.1 firmware again?

  20. #57
    What's Jailbreak?
    Join Date
    Mar 2008
    Location
    Illinois
    Posts
    9
    Thanks
    1
    Thanked 2 Times in 2 Posts

    Quote Originally Posted by CyberGreg View Post
    Thanks for posting. I'll think about the loading process to try and hone in on the problem.... it certainly doesn't appear that the problem lies in the permissions but somewhere else.
    Greg, First I need to say thank you. This is not given enough to the developers. I respect your knowledge and skill, and you've put out some truely great applications for the iphone since the very beginning of jb. And taking the time to answers our problems is appreciated.

    I'm stumped. I had two ALMOST identical devices, side by side, install WbApp via Cydia.
    one is working fine (Without any changes or modifications), the other is not (Regardless of the number of things I tried and the numer of times I tried as in the previous posting).

    Not ruling anything out: It could be the application, or it could be the installation process, or maybe the dependancies needed to run the Wbapp and WinterBoard differ on the two phones.
    Could be user error, but with Cydia, it's just point and click.

    I typically read the threads to see if there is a solution to a problem I'm having. Sometimes, there just isn't enough input. So, please let me know if there is anything I can give to you for troubleshooting.

    or if anyone else has any thoughts let me know (You can read what I tried from the previous posting)

  21. #58
    To all,

    First, please don't thank me - Saurik deserves ALL the credit for WinterBoard and making it open source.

    Second, I'll list out WbApp's startup steps and we'll see if we can't figure out what's going on.

    1. WbApp launches
    2. During the initialization;
    a. it reads the theme folders and writes out a plist file
    i. it reads the WinterBoard themes first and adds them to the file. During this process it skips any folder beginning with "." (this eliminates poorly zipped theme installs). During this time it also builds a second theme plist file for any theme named .theme (this file is not used in this version)
    ii it reads the SummerBoard themes (skips ones that begin with "." too)
    b. It now reads that file to build the alphabetical view and the view by type
    c. It presents the alphabetical view
    At this point it's done. the app is really very small and doesn't really "do" much.

    User interaction
    When you select a theme (in either view) just before it makes the transition to the preview it looks to see if the theme folder has been linked to the Documents/Themes folder (again , for those that are concerned, even though it looks like the app is copying over all your theme files let me reassure you it is not. It is making "soft" links as opposed to hard links, anyhow...), if not it (fairly) quickly creates the symlink and then displays the preview. From here it behaves "almost" the same as the WinterBoard app and takes your settings and theme and writes out the file for WinterBoard to use. So at this very last step is the ONLY place where I actually alter the WinterBoard plist file. So if you never load a theme using WbApp, WinterBoard would never know.

    So given all that I can see the following problems:
    1. The app launches and then quickly crashes
    Causes: Either it can not read the Documents/ThemesList.plist file OR the app is no longer signed. When I forget to issue the "ldid -S WbApp" while I'm checking my builds this is exactly what happens, the app launches shows the Default.png and then goes back to the SpringBoard

    2. The app launches but shows themes the you do not have
    Causes: The Documents/ThemesList.plist file was not created most likely due to a permissions error.

    So now that I have typed all this crap out here's what those that can't launch the app can try. From Cydia download and install the "Link Identity Editor". Now I run this from Terminal on my Mac so you PC guys need to use Putty????? regardless the easiest way to run it is change to the app folder (cd /Applications/WbApp.app) and then enter this command "ldid -S WbApp" (without the quotes).

    White 3G

  22. #59
    iPhoneaholic
    Join Date
    Jul 2008
    Location
    Winter Park, Florida
    Posts
    494
    Thanks
    64
    Thanked 101 Times in 60 Posts

    Quote Originally Posted by CyberGreg View Post
    So now that I have typed all this crap out here's what those that can't launch the app can try. From Cydia download and install the "Link Identity Editor". Now I run this from Terminal on my Mac so you PC guys need to use Putty????? regardless the easiest way to run it is change to the app folder (cd /Applications/WbApp.app) and then enter this command "ldid -S WbApp" (without the quotes).

    I tried doing this and still when I open WbApp I see the default screen and then it crashes. Bummer. I appreciate you trying to figure this out though. I wonder if there's anything else that I can try (besides re-pwning my phone)

  23. #60
    What's Jailbreak?
    Join Date
    Mar 2008
    Location
    Illinois
    Posts
    9
    Thanks
    1
    Thanked 2 Times in 2 Posts

    Quote Originally Posted by CyberGreg View Post
    To all,

    First, please don't thank me - Saurik deserves ALL the credit for WinterBoard and making it open source.
    First, please don't be modest, no one does it alone, it takes many many people to contribute towards the growth and development of this device. I appreciate the help and you HAVE brought some great apps to the iphone. (I have and will continue to thank Saurik for his GENIUS)

    Second, I have tried the above. Didn't work (or couldn't figure out the right commands for PC users.)

    So. for sh*ts and giggles, I decided to WinSCP into my wife's iPhone (WbApp working fine there) and copy the entire WbApp.app folder. As it was copying over to my local HD, I noticed that it was copying over theme files.

    Opening up in explorer I found that inside /Applications/WbApp.app/Documents/Themes - that indeed the program COPIED HER THEMES into this folder.

    Next, I copied the folder (set permissions to 755) over to my iPhone (WbApp.app not working) and rebooted. Guess what? It works, no problem. Previews and installs themes without issues.

    So, I deleted all of the copied themes, leaving the folder empty. WbApp still shows the themes listed in the opening window, but no previews and can't install. (I guess the plist doesn't update).

    I then copied a different theme folder into the iPhone and respringed to see if the plist would update, it didn't.

    So, the question is how do we get the listing to update and does it really need to copy over all of the folders?

    UPDATE:
    I deleted the above ssh'd app from the phone and then I did a FULL Re-install via CYDIA. Tried to launch from the home screen, it still Crashes. Then I ssh'd into /Applications/WbApp.app/Documents/ and opened the two plist files (DotThemeList.plist and ThemeList.plist) in Wordpad and it does indeed gather my Wintrboard and Summerboard themes from their current locations, but they DID NOT COPY the entire themes into the /Applications/WbApp.app/Documents/Themes folder (as it did for my wife's iPhone).

    Now I'm thinking of what could be the difference in the two? Well, my wife only had about 14 themes, whereas I have maybe 130 plus. Could the number of themes installed be an issue?

    I have attached my plist files so that you can see that it does gather the data.

    FINAL UPDATE:

    So, you are probably thinking, does he really need 142 themes installed on his iPhone. Really, no. So, I deleted most of them to a total of 47 Winterboard and Summerboard themes.

    SUCCESS!!!

    GREG and Everyone NOTE: THE APPLICATION DOES COPY YOUR THEMES INTO /Applications/WbApp.app/Documents/Themes once you have installed your themes through the WbApp UI.You can verify this by SSH'ing into the folder after installing a theme.

    So, Greg, I guess there is a limit to the number of installed themes you can have.
    Attached Files Attached Files
    Last edited by starlox; 08-14-2008 at 08:11 PM. Reason: UPDATE

  24. The Following User Says Thank You to starlox For This Useful Post:

    CyberGreg (08-14-2008)

Page 3 of 4 FirstFirst 1234 LastLast
Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •